Page 1 of 1

[SOLVED] "system-config-samba" GUI not available. Need Samba share Help

Posted: Fri Jul 10, 2020 2:32 pm
by JoeBingo
Hi ...

Linux Mint 20 MATE

I have Sonos wireless speakers and home sound system.
In Mint 19.3 I used Samba to share the Music folder found in my Mint home folder, to Sonos Music Library. I have over 7,000 songs stored locally in my Mint Music folder.

In order to set the share up, I used "system-config-samba" GUI. This GUI is no longer in the repository and I can't find a Deb file of it anywhere. This is a huge problem, because I have NO idea what entry I need to manually include in the /etc/samba/smb.conf file in order to share the Music folder. Now I have 7,000 songs I can't listen to on my home stereo system.

Had I known "system-config-samba" wouldn't be available, I would have at least kept a copy of /etc/samba/smb.conf file before slicking my SSD and installing Mint 20.

Of course Warpinator is useless, because it's only for file sharing between computers and Sonos isn't a computer and not even seen by Warpinator.

All I know is that when I used "system-config-samba" GUI, it was set up /home/[home folder name]/Music ... Read Only ... Visible. Simple easy and it worked. I have NO idea what the actual entry was in the smb.conf file though.

PLEASE help me manually enter the necessary smb.conf file edit to share the Music folder or ideally, you may know a link to a "system-config-samba" GUI Deb file so I can install the GUI. Thanks !!!

Re: "system-config-samba" GUI not available. Need Samba share Help

Posted: Fri Jul 10, 2020 3:00 pm
by altair4
Um ... how about this:

Edit /etc/samba/smb.conf

At the bottom of the file add this - assuming your Mint user name is "joe":

Code: Select all

path = /home/joe/Music
read only = no
guest ok = yes
force user = joe
Restart smbd:

Code: Select all

sudo service smbd restart

Re: "system-config-samba" GUI not available. Need Samba share Help

Posted: Fri Jul 10, 2020 3:07 pm
by JoeBingo
Thanks altair4 !!! That looks exactly like what I need. I'll try it this evening :)

Re: "system-config-samba" GUI not available. Need Samba share Help

Posted: Fri Jul 10, 2020 3:22 pm
by altair4
Not familiar with Sonos as a samba client so I don't know if there will be a "discovery" or access issues but the share definition is rudimentary.

For example if the Sonos device can only use SMB1 it won't be able to connect regardless of the share definition. You would either need to add SMB2 / SMB3 to Sonos which may be impossible or you would need to add SMB1 support to your Mint server. The version of Samba in Mint20 removes SMB1 support.

You would do that by going back into smb.conf and adding a line under workgroup = WORKGROUP:

Code: Select all

server min protocol = NT1
EDIT: And if the Sonos smb client is really old you may need another line under that:

Code: Select all

ntlm auth = ntlmv1-permitted
Then reboot your Mint box.

Samba calls SMB1 NT1 apparently to confuse as many people as possible.

Just trying to anticipate a problem since I'm unfamiliar with Sonos.

Re: "system-config-samba" GUI not available. Need Samba share Help

Posted: Fri Jul 10, 2020 4:51 pm
by JoeBingo
Thanks altair4 !!! :)

I have NO idea which SMB Sonos is. Alls I can tell you is that with Mint Mate 19.3 I had everything working flawlessly.
Sonos ... Samba ... shared Music in my home folder.

Sonos does not have a controller app for Linux nor intends to develop one.
I've been using an unoffical-sonos-controller-for-linux by Pascal Opitz as a GUI interface between Sonos, Mint and Music folder where 7,000+ songs are stored. That too was working flawlessly.

Life was good and filled with high quality home stereo music !!! WOooHOoo. Doesn't get much better.

THEN I slicked my SSD and installed Mint Mate 20. BOOooooooo !!!
- "system-config-samba" GUI no longer available
- "unoffical-sonos-controller-for-linux" messes with file paths when installed. For example when I click "menu > Computer" ... it opens unoffical-sonos-controller-for-linux ... same when I click "menu > Home Folder" ... there may be others.
- When I install Samba and try to manually configure /etc/samba/smb.conf to share the Music folder on Mint ... Sonos is unable to connect. Your suggested edit MAY be entirely correct and there MAY be other issues. Maybe there are some samba dependencies missing since Mint now chooses to look the other way from Samba and go foremost with Warpinator.
- What was working flawlessly and effortlessly in Mate 19.3 is completely foreign in Mate 20 and totally unattainable for me and my end user knowledge.

So it is that I will now abandon Linux Mint as a controller platform for Sonos.
Sonos doesn't like Linux and Mint doesn't like Sonos. It is what it is.

Instead for the time being, I will use my iPad(Gen 5) because Sonos requires iOS for its "True Play" feature that acoustically tunes the Sonos system to a room environment through audio sampling. Hate is a strong word but I HATE Apple as much as I HATE Windows. AND I HATE that Linux Mint no longer works as a Sonos / Music library platform.

But the iPad(Gen 5) has a HUGE problem too !!! ... it only has 32GB memory and no hardware feature for expanded memory and my 7,000+ songs encompass over 50GB. SOooooo ... I will also be ordering an Amazon Fire HD 8 Plus + Wireless Charging Dock that DOES have expanded memory capability to hold the songs, an authorized and supported Sonos app with GUI and it will live on a living room piece of furniture and dedicated as a home stereo controller.

Looks like "upgrading" ... and I use that term loosely ... to Mint Mate 20 will cost me about $200 to halt the harshing of my calm and frustration with Linux. Oh, I could reinstall 19.3 but that regression would only last so long until 19.3 if I could even get it to work again, is abandoned. So I'll be moving forward rather than regressing ... one HUGE regression in "updating" is enough.

I will mark this [SOLVED]