Long uptime = dead Google web services

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
User avatar
kneekoo
Level 2
Level 2
Posts: 74
Joined: Tue Nov 06, 2007 2:38 pm
Location: Stuttgart, Germany
Contact:

Long uptime = dead Google web services

Post by kneekoo » Sun Sep 04, 2011 5:32 pm

I already described the issue in the blog but I'll copy/paste the relevant part here.

Summary: Google web services stop working in Linux Mint on PCs with long uptimes. Versions used (that I remember of): Helena, Isadora, Julia, Katya, LMDE.

There is one issue I keep having with Linux Mint for more than a year. First I thought it was something in my PC but after we painted the house I started working on my laptop for a few days and I just let it on for a few days. I run Isadora on this laptop and I ran all the other LM versions on my PC. Google stops working after a while. Sometimes it takes 3-4 days of uptime for Google to fail on me, other times it only takes a day until it dies. And when I say Google I mean virtually everything on the web related to Google. The Google sites won’t load at all and whatever site has Google AdSense, Analytics etc only load after a very long wait (until the browser decides to drop the connections to the Google web services).

I don’t know what’s wrong. I just reboot and everything comes back to life. But if I can’t restart my PC I just use bing or yahoo search to find whatever I need.
Image
Come visit PHP-Fusion Romania

Jesse654
Level 3
Level 3
Posts: 126
Joined: Thu Sep 02, 2010 8:04 pm

Re: Long uptime = dead Google web services

Post by Jesse654 » Sun Sep 04, 2011 6:42 pm

While I haven't had this issue myself, here's a shot in the dark:
Delete your Google cookies.
(Is the time Google takes to stop working correlated to the time you spend uploading pages from Google sites?)

User avatar
kneekoo
Level 2
Level 2
Posts: 74
Joined: Tue Nov 06, 2007 2:38 pm
Location: Stuttgart, Germany
Contact:

Re: Long uptime = dead Google web services

Post by kneekoo » Sun Sep 04, 2011 7:15 pm

It's not by far a cookie related issue. When Google stops working I can't even ping any of their servers (and ping works fine when Google works so it's not a firewall/ICMP thing). It's like they vanish in thin air. And that causes enormously long timeouts while accessing sites with Google ads, like distrowatch.com, linuxmint.com and many others.
Image
Come visit PHP-Fusion Romania

TBABill
Level 6
Level 6
Posts: 1361
Joined: Wed Dec 30, 2009 1:02 pm
Location: Leonardtown, MD

Re: Long uptime = dead Google web services

Post by TBABill » Tue Sep 06, 2011 2:08 pm

It's not just Mint. My Mint does it, so does Ubuntu, Windows 7 and Windows XP. This is both at home and on a work network. I can immediately get to Yahoo or MSN when the failure occurs so it leads me to believe Google is having issues intermittently.

Post Reply

Return to “Other networking topics”