Found firewall (default ufw) disabled one fine day...

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
User avatar
mzsade
Level 5
Level 5
Posts: 777
Joined: Sun Jul 19, 2009 4:36 am

Found firewall (default ufw) disabled one fine day...

Post by mzsade » Wed Dec 28, 2011 7:29 pm

...and now when i enable it, i cannot connect to the Internet.
Linux User #481272 Reg: 15th Sept., 2008

lmintnewb
Level 7
Level 7
Posts: 1568
Joined: Fri Apr 01, 2011 5:13 pm

Re: Found firewall (default ufw) disabled one fine day...

Post by lmintnewb » Wed Dec 28, 2011 7:51 pm

Might look this over.

And this too. Said it has a link to a tutorial for ufw. Was thinking you could try the terminal command "sudo ufw default allow outgoing" and see if that clears up the net connect probs. Could also try "sudo ufw reset" thought by default ufw disallows any incoming, but allows outgoing connections. So resetting it to default might have some potential for ya.

User avatar
mzsade
Level 5
Level 5
Posts: 777
Joined: Sun Jul 19, 2009 4:36 am

Re: Found firewall (default ufw) disabled one fine day...

Post by mzsade » Thu Dec 29, 2011 3:01 am

Code: Select all

$ sudo ufw enable
ERROR: problem running ufw-init
If i delete the /etc/ufw folder, will it regenerate itself on reboot, with the default configuration and the mess hopefully cleared up?

Installed firestarter, getting a similar error; Failed to open the system log, No event records will be available, and this for when i ran it from the terminal;

Code: Select all

$ sudo firestarter
[sudo] password for antony: 

(firestarter:4256): libgnomevfs-CRITICAL **: gnome_vfs_async_open: assertion `text_uri != NULL' failed
Firewall started
At least this time the firewall is active and not blocking Internet access.

Firestarter issue is solved; http://ubuntuforums.org/showthread.php?t=1749703
Linux User #481272 Reg: 15th Sept., 2008

Post Reply

Return to “Other networking topics”