Missing MBR Helper

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 14
Joined: Mon Jun 07, 2010 8:27 am

Missing MBR Helper

Postby lovejames » Wed Jun 09, 2010 2:23 am


I have installed Isadora using Mint4Win. Installation went fine but at the time of booting, when I chose Linux Mint, it shows me an error "Missing MBR Helper". I am using a Netbook with the following configuration:
Intel Atom (1.6GHz)
Realtek Ethernet

I have tried reinstalling windows, repartitioning the hard drive but the problem still persists. The full history of what happened earlier is available at: http://ubuntuforums.org/showthread.php?t=1484068

Any help is greatly appreciated. Thanks!

Level 1
Level 1
Posts: 14
Joined: Mon Jun 07, 2010 8:27 am

Re: Missing MBR Helper

Postby lovejames » Sat Jun 12, 2010 3:11 am

Surprise to see no help here...! Am I facing so complex problem?? :o

User avatar
Level 17
Level 17
Posts: 7543
Joined: Wed Jun 17, 2009 8:20 pm

Re: Missing MBR Helper

Postby DrHu » Sat Jun 12, 2010 4:55 am

lovejames wrote:Surprise to see no help here...! Am I facing so complex problem?? :o

Not entirely, quite obviously it is a motherboard issue, for which there may be some work-around
And despite your hardware data, there is still no context being provided..
(I don't necessarily want to search your links, when it could be provided right here!)
    Which mint, which desktop environment, how was it it installed (Mint4win /WUBI) within a VM or otherwise, straight onto a mint hard drive partition space ?
--there are some people available, who might be able to help, if they know a little more about your setups..
    EDIT: OOPS: OK< I see you do list that you installed via wubi (min4win)
    --so, either check the Ubuntu forums for the equivalent Ubuntu issues under WUBI or these forums for mint4win issuses vis-a-vis Isadora (that is Mint 9, Ubuntu 10)

Mint4win (WUBI) start..these forums

I would use a query like this for Ubuntu: "Ubuntu 10 wubi missing mbr helper"
http://ubuntu-ky.ubuntuforums.org/showt ... 417&page=2

Level 1
Level 1
Posts: 14
Joined: Mon Jun 07, 2010 8:27 am

Re: Missing MBR Helper

Postby lovejames » Sat Jun 12, 2010 12:01 pm

Thanks for the links. I've been searching all around Ubuntu and Linux mint forums for some help on this topic for almost a month now. Unfortunately, I am not able to get any solution. The reason why posted a link for the history was that it would give a better understanding of all that has happened to my problem and all the suggestions provided to me by many people.

Anyway, following is the summary of all that happened before:

I initially installed Ubuntu Net Book Remix (using live USB) version on my netbook as a dual boot with win xp. The installation went fine and I used it for almost couple of days. Then suddenly, one day it stopped booting. It started throwing some error messages (DRDY ERR). I thought something got corrupted so I removed it. But later since grub got corrupted i was not even able to boot into win xp. Then I tried reinstalling Ubuntu NBR. But it failed. Ever since, I was never able to install Ubuntu / LM again. Even Live USB/CD are not working any more. Some how I am able install and use Windows but not Linux. Finally, when nothing else was working, I tried of atleast using linux through mint4win, but even this seems to be having some problems. At the startup, I am able to chose Linux Mint but soon after that I get this message: Try (FD0) Invalid or Null. Missing MBR-Helper.

I hope I am able to atleast give some background on my problem. Any help is greatly appreciated.

Level 1
Level 1
Posts: 4
Joined: Sun Jul 25, 2010 5:17 am

Re: Missing MBR Helper

Postby MeneerWitte » Wed Aug 04, 2010 1:37 pm


First: Sorry for my por English, but some times Google is more wurse than my English.

I don't know much about it, I have a MBR problem myself. But after making an primary partition to a (don't know the technames) sub-partition. Now, I can't start Linux Mint 8 with out a Grube-cd. Super Grube it's cold. You could download it, it is an ISO. super_grub_disk_0.9799.iso iso-size: 4,490 kB
I don't know how to use the program. I can find the OS-installations and start them, but I can't rewrite a MBR with it.
And next time, don't start imedietly with reïnstalling. Nonsen. If you have a Windows OS, put in the Windows CD and after loaded, start 'R' repear. After some time you have a commandline and wil be asked for wich installation you want to start for this session. If you have more then one Windows installation. If not, choos the one that's been shown and type the number in front of the writings. In this case 1 and press Enter, than the password will be asked (I didn't set a password for Administrator, if you did, fil in the password), press Enter. For help, you only need to type 'help' and there will be a list of commands.
From there you can choos the commands you need, if don't know much about it like I, try somethings with out actually doing it.
Like 'bootcfg' and you see more options.
If you like to use your Windows OS again, you could go for 'fixboot'. Doesn't mean that you Linux OS will start, only the Windows OS.
So, no need for reinstalling. Now you can go to the web and find your answers. Or use the Live-CD of Linux Mint or what ever. And to boot up your other OS, you can use the Super Grube CD. It will work, for the mean time, to me it is.
With the Super Grube CD I can start the MBR of the Linux installation, but not with out it. And I installed with command a Grube installation, it wasn't installed. So, the Grube-PC was something from Linux Mint there selfs. And I don't know how to get it back either, the original grube-pc is what I want back for MBR.
So, here are some selutions, but no answers.
I think DrHu might have the answers and maby some better programs for helping out in these situations.

So, next time no reinstall. Use some programs and get help.

Hopefully I let you know enough and hope you find the answers where you are looking for.




Try the Linux Mint Forum, look for Installation & Boot, second part Toppics:

- Solution for random shutdown on some laptops when installing
- Grub rescue ?
- If you get grub errors after install look here - not grub 2

Return to “Installation & Boot”

Who is online

Users browsing this forum: Bing [Bot] and 12 guests