Will not save mouse settings

Forum rules
Before you post please read how to get help
jwandta
Level 1
Level 1
Posts: 1
Joined: Sun Mar 11, 2012 6:37 pm

Will not save mouse settings

Postby jwandta » Mon Mar 12, 2012 7:07 pm

Every time I reboot I loose my mouse settings. Any one know what the fix is?

bugreprt
Level 1
Level 1
Posts: 6
Joined: Sat Jun 18, 2011 5:06 pm

Re: Will not save mouse settings

Postby bugreprt » Wed Mar 14, 2012 8:35 pm

I have this problem as well! Please, someone help.

luna paradox
Level 1
Level 1
Posts: 36
Joined: Tue Nov 16, 2010 6:54 pm

Re: Will not save mouse settings

Postby luna paradox » Sat Mar 17, 2012 7:16 am

I was having same problem with lxde 11 maybe this will help viewtopic.php?f=175&t=68521#p395991

dxrobertson
Level 1
Level 1
Posts: 1
Joined: Mon Sep 05, 2011 7:00 am

Re: Will not save mouse settings

Postby dxrobertson » Sun Mar 18, 2012 8:42 am

When you make changes to the keyboard or mouse via Preferences>Keyboard and Mouse; the changes are saved in 2 files name "sms" for the mouse, and "sks" for the keyboard. These script files are then run to set the mouse and keyboard settings. Problem is that they are NOT run at each boot so the settings are not remembered.

To fix this myself, I added a desktop file to the autostart directory to run the sms script file (I dont have any custom keyboard settings). Desktop files in the autostart directory will run at each login. The autostart directory is located at /home/yourhome/.config/autostart, for "yourhome" being your own home directory name. The autostart directory was not created by default, so you may need to create it (use pcmanfm, right-click, create new-folder....).

!st, go ahead and make your mouse changes via Preferences>Keyboard and Mouse to create your sms file.

The desktop file I use is pasted below, make sure you replace "yourhome" with you actual home directory name. The Exec line is the important part of this file, it is what runs the sms script file:


[Desktop Entry]
Version=1.0
Name=sms
Comment=set synclient
Exec=/home/yourhome/.linuxmint/sms
Icon=mouse
Type=Application
Encoding=UTF-8
Name[en_US]=sms



Something else odd is that if you run Keyboard and Mouse again, the settings are not reflected there either. The mouse-keyboard application could probably use some minor improvements in this area.


Return to “Others”

Who is online

Users browsing this forum: No registered users and 0 guests