[SOLVED] Enable Ctrl + U for unicode characters

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Lakef
Level 1
Level 1
Posts: 20
Joined: Sat Feb 25, 2017 4:12 pm

[SOLVED] Enable Ctrl + U for unicode characters

Postby Lakef » Thu Apr 20, 2017 12:15 pm

I have searched the internet quite a bit, but I have not found a clear answer what one should do in order to enable Ctrl + U in Linux Mint Cinnnamon 18.1. If one presses the buttons Ctrl + u in an editor, then an underlined u (u) should appear, and then one writes the unicode code in hex format for the wanted character, followed by enter I think. For example ctrl +u 03b1 return for a Greek alpha character. How do I enable the Ctrl + u activated unicode function?

Maybe I have to install some package? Maybe I have to change some setting?

Unicode codes:
http://jrgraphix.net/r/Unicode/
Last edited by Lakef on Fri Apr 21, 2017 7:47 am, edited 2 times in total.

Cosmo.
Level 21
Level 21
Posts: 13586
Joined: Sat Dec 06, 2014 7:34 am

Re: Enable Ctrl + U for unicode characters

Postby Cosmo. » Thu Apr 20, 2017 4:50 pm

Not ctrl-u (this would be bad, as some programs might use this shortcut), but ctrl-shift-u; next enter (without a space) the code followed by a space. Example-code 2328: ⌨

Lakef
Level 1
Level 1
Posts: 20
Joined: Sat Feb 25, 2017 4:12 pm

Re: Enable Ctrl + U for unicode characters

Postby Lakef » Fri Apr 21, 2017 1:31 am

Dear Cosmo, I tried control+shift+u, enter, 03b1 and space in that order, but it did not work. I also tried several other combinations beginning with control+shift-u, but none worked for me. If I start out with ctrl+shift+u and then push return, then I get a line break. If I start out with ctrl+shift+u and then enter 03b1, then I get 03b1 on the screen. I have tried in xed text editor and Libre Office writer.

In all information about ctrl+u relating to Linux Ubuntu and Linux I have encountered instructions to use ctrl+u, and not ctrl+shift+u.

I suspect that I should add some IBus (Intelligent Input Bus) package in order to make it function, but there are quite many IBus packages and I have not been able to figure out which one that is relevant.

https://en.wikipedia.org/wiki/Intelligent_Input_Bus

https://help.ubuntu.com/community/ComposeKey
Last edited by Lakef on Fri Apr 21, 2017 2:30 am, edited 1 time in total.

Lakef
Level 1
Level 1
Posts: 20
Joined: Sat Feb 25, 2017 4:12 pm

Re: Enable Ctrl + U for unicode characters

Postby Lakef » Fri Apr 21, 2017 2:09 am

I installed "Ibus", i.e. intelligent input bus - core. This is only the core of IBus. Still ctrl+u does not function for writing unicode characters by their hexadecimal code.

I now have access to IBus Preferences dialogue by either:
1. Menu > Search for ibus > click on IBus Preferences in search result
2. terminal window > write ibus-settings

Cosmo.
Level 21
Level 21
Posts: 13586
Joined: Sat Dec 06, 2014 7:34 am

Re: Enable Ctrl + U for unicode characters

Postby Cosmo. » Fri Apr 21, 2017 5:22 am

Lakef wrote:In all information about ctrl+u relating to Linux Ubuntu and Linux I have encountered instructions to use ctrl+u, and not ctrl+shift+u.

Some links please.

If you press ctrl-shift-u: Does the u gets underlined?


Cosmo.
Level 21
Level 21
Posts: 13586
Joined: Sat Dec 06, 2014 7:34 am

Re: Enable Ctrl + U for unicode characters

Postby Cosmo. » Fri Apr 21, 2017 7:10 am

Create a fresh new user account. Log ut of your main account and into the new one. Open there the text editor and and try to enter the unicode character I gave you. What happens?

Lakef
Level 1
Level 1
Posts: 20
Joined: Sat Feb 25, 2017 4:12 pm

Re: Enable Ctrl + U for unicode characters

Postby Lakef » Fri Apr 21, 2017 7:15 am

Problem solved! After installing IBus core and rebooting, I got an IBus option that I selected and rebooted again. Now, I get an underlined u after pressing Ctrl+Shift+u, I enter the code and then pushes the space bar, and the wanted character appears!

Solution

In order to have the IBus option below, one has to install the IBbus core package first, and reboot.

Select Menu > Preferences > System Settings > Languages > Select "Input method" in upper tabs. In the first table there is a line saying Input method, in its drop down selection list, select IBus. Then reboot, and you should be able to write unicode characters in editors by use of Ctrl+Shift+U, the wanted unicode code (e.g. 3b1 for greek alpha), and finish by pressing the space bar.

Comment

This Linux functionality is great. One has access to the whole world of unicode anywhere at any time by a fairly simple command. I think this is much better than the ALT codes of Windows, which only allow for a very limited set of characters. With Linux IBus Ctrl+Shift+U one has access to ALL unicode characters. And they do not have to be lengthy at all. For example a greek alpha α, one only needs to type 3b1 as code, only three characters, as leading zeroes are not needed.

Not only exotic characters are available this way, some characters are quite useful for daily use such as for example:

a0 no-break space
202F narrow no-break space
200b zero width space
2009 thin space
ad soft hyphen
2011 non-breaking hyphen ‑
2013 en dash –
2014 em dash —
2043 hyphen bullet ⁃
2022 bullet • (in Windows it would have been ALT+7)

All Unicode characters: http://jrgraphix.net/r/Unicode/
Last edited by Lakef on Fri Apr 21, 2017 8:00 am, edited 1 time in total.

Lakef
Level 1
Level 1
Posts: 20
Joined: Sat Feb 25, 2017 4:12 pm

Re: Enable Ctrl + U for unicode characters

Postby Lakef » Fri Apr 21, 2017 7:59 am

Cosmo. wrote:Create a fresh new user account. Log ut of your main account and into the new one. Open there the text editor and and try to enter the unicode character I gave you. What happens?


Dear Cosmo, I solved the problem as described above. Thanks anyway! And thank you for alerting me that I had missed the use of the shift-key!


Return to “Other topics”

Who is online

Users browsing this forum: No registered users and 2 guests