How to install Japanese IME (as in Windows)?

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
sukerukudasai
Level 1
Level 1
Posts: 3
Joined: Wed May 16, 2018 9:04 am

How to install Japanese IME (as in Windows)?

Post by sukerukudasai » Mon May 21, 2018 1:36 pm

Standard Japanese layout is not good - for special keyboard. I want to use IME like in Windows, when i can use romadji and they converts to kana/kanji.

User avatar
Pierre
Level 16
Level 16
Posts: 6750
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: How to install Japanese IME (as in Windows)?

Post by Pierre » Mon May 21, 2018 4:04 pm

you will need to give us some more information:
- what version of LinuxMint are you using ?.
and what is the Make & Model of your machine ?.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

sukerukudasai
Level 1
Level 1
Posts: 3
Joined: Wed May 16, 2018 9:04 am

Re: How to install Japanese IME (as in Windows)?

Post by sukerukudasai » Tue May 22, 2018 5:58 am

It doesn't make sense coz i checked forums and it's problem with debian/ubuntu/etc. I've tried on PC and laptops. Problem the same. I use latest LinuxMint from official site. Also i've tried other debian-like systems. Problem in others too.

It's problem with iBus. Now i am trying to use fctix but it makes 2 layouts: standard (system) + additional which intercepts selected layout and changes pressings to kana.

So if you know how to easy install and setup IME like in Windows: tell me.

ps I have a standard "english" computer and keyboard. Mint's Japanese layout is for keyboards with Kana already. I don't use this method as many japanese guys. I just use IME, when i type "kana" and get かな and after 仮名

Hoser Rob
Level 11
Level 11
Posts: 3863
Joined: Sat Dec 15, 2012 8:57 am

Re: How to install Japanese IME (as in Windows)?

Post by Hoser Rob » Tue May 22, 2018 8:23 am

The only things I can find are for ubuntu 16.04, which apples to Mint 18.x. You'd have to find the equivalent things in Mint because the steps are for Unity but they should be similar:

https://moritzmolch.com/2287

http://www.localizingjapan.com/blog/201 ... ial-xerus/

mashineman
Level 1
Level 1
Posts: 5
Joined: Fri Dec 04, 2015 2:52 am

Re: How to install Japanese IME (as in Windows)?

Post by mashineman » Fri Jun 01, 2018 1:15 pm

I've got exactly that sort of Japanese input set up on my system. Try this:

1. Go to Settings -> Language Settings -> Language Tab -> Language Support, click Install/Remove, then Add and install all Japanese language entries.

2. Go to Software Manager, search for Anthy and install it. Then do the same for Ibus-anthy, unless it was already also installed with Anthy.

3. Go to Settings -> Language Settings -> Input Method -> Language Support and install Japanese if it isn't already.

4. As I recall, you need to reboot now.

5. Go to Settings -> Language Settings -> Input Method and set the Input Method to Ibus.

6. You should see a little "EN" icon on the tray. Right click it and open Preferences. Go to Input Method, click Add, select Japanese and then choose Anthy. It should be all set up now, you can toggle languages by left clicking the EN and selecting the one you want-though it's more convenient to do it by setting up a keyboard shortcut.

Some of these steps are probably unnecessary or redundant, but I know the correct setup is in there somewhere.

tatariw
Level 1
Level 1
Posts: 4
Joined: Sun May 20, 2018 10:03 am

Re: How to install Japanese IME (as in Windows)?

Post by tatariw » Sun Jun 03, 2018 1:20 pm

I have had similar issue to type in Amharic. iBus should work if you install ibus-gtk and ibus-gtk3 from Synaptic, Of course in addition to ibus-m17n. Please check these two.
In my case I did not have to install Language Support as log as Amharic fonts are installed.
Good luck!

Post Reply

Return to “Other topics”