Clock not updating on restore from sleep

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
User avatar
meToo
Level 1
Level 1
Posts: 26
Joined: Sat Feb 02, 2019 6:52 am
Location: Staffordshire, England

Clock not updating on restore from sleep

Post by meToo »

Mint 19.2, Lenovo T520
Not at my machine this minute so can't include inxi.

To get the clock to update to correct time I have to left-click the clock on the panel. Correct time is maintained then till the next sleep. Internet time sync is activated.

I think this has been the result of some update as the fault has not aways been present.

TIA.
Lenovo T520 i5, 8GB ram, 1TB HDD Mint 19.3 Tricia XFCE

gm10
Level 20
Level 20
Posts: 10921
Joined: Thu Jun 21, 2018 5:11 pm

Re: Clock not updating on restore from sleep

Post by gm10 »

meToo wrote:
Sat Nov 30, 2019 1:24 pm
Not at my machine this minute so can't include inxi.
Until you do not much to say - panel applets are specific to your desktop environment, and you didn't tell us which that is (the inxi output would have).

Think ahead. ;)
Tune up your LM 19+: ppa:gm10/linuxmint-tools

User avatar
meToo
Level 1
Level 1
Posts: 26
Joined: Sat Feb 02, 2019 6:52 am
Location: Staffordshire, England

Re: Clock not updating on restore from sleep

Post by meToo »

Thanks, sorry for delay, just returned.
Dual boot with win 10 which I never use.
Also noticed that clock updates after sleep when mouse pointer passes over clock on panel.

Code: Select all

ThinkPad-T520:~$ inxi -Fxz
System:
  Host: ThinkPad-T520 Kernel: 4.15.0-70-generic x86_64 bits: 64 
  compiler: gcc v: 7.4.0 Desktop: Xfce 4.12.3 Distro: Linux Mint 19.2 Tina 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: LENOVO product: 4243P82 v: ThinkPad T520 
  serial: <filter> 
  Mobo: LENOVO model: 4243P82 serial: <filter> UEFI [Legacy]: LENOVO 
  v: 8AET66WW (1.46 ) date: 09/20/2016 
Battery:
  ID-1: BAT0 charge: 43.3 Wh condition: 45.2/47.5 Wh (95%) 
  model: LGC 45N1005 status: Unknown 
CPU:
  Topology: Dual Core model: Intel Core i5-2520M bits: 64 type: MT MCP 
  arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19933 
  Speed: 798 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 797 2: 796 
  3: 799 4: 797 
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Lenovo ThinkPad T520 driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 19.0.8 
  direct render: Yes 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Lenovo ThinkPad T520 driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.15.0-70-generic 
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo ThinkPad T520 
  driver: e1000e v: 3.2.6-k port: 5080 bus ID: 00:19.0 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi 
  v: kernel port: efa0 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 86.05 GiB (9.2%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541010A9E680 
  size: 931.51 GiB 
Partition:
  ID-1: / size: 170.11 GiB used: 86.05 GiB (50.6%) fs: ext4 dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 33.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 251 Uptime: 1d 10h 02m Memory: 7.68 GiB used: 1.01 GiB (13.1%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32 
This is the only problem I ever had with Mint and can live with it if need be.
Lenovo T520 i5, 8GB ram, 1TB HDD Mint 19.3 Tricia XFCE

gm10
Level 20
Level 20
Posts: 10921
Joined: Thu Jun 21, 2018 5:11 pm

Re: Clock not updating on restore from sleep

Post by gm10 »

Known issue with Xfce. First google result with a workaround: https://forum.xfce.org/viewtopic.php?id=12229
Tune up your LM 19+: ppa:gm10/linuxmint-tools

User avatar
meToo
Level 1
Level 1
Posts: 26
Joined: Sat Feb 02, 2019 6:52 am
Location: Staffordshire, England

Re: Clock not updating on restore from sleep

Post by meToo »

Thanks gm10,

The panel applet I'm using ids as datetime-30 not clock so the xfconf-query shown on the xfce forum does not work with the necessary substitution. However I had the panel set to auto-hide but changing it to never hide seems to have resolved the problem. Further tests to be carried out and if necessary will live with it in anticipation of a fix later. I don't want to 'jeopardise' my reliable system making changes I'm not confident of.
Lenovo T520 i5, 8GB ram, 1TB HDD Mint 19.3 Tricia XFCE

User avatar
MrEen
Level 16
Level 16
Posts: 6583
Joined: Mon Jun 12, 2017 8:39 pm

Re: Clock not updating on restore from sleep

Post by MrEen »

Hi meToo.

I have an idea that might work, but first need to see the output of xfconf-query -c xfce4-panel -l -v

User avatar
MrEen
Level 16
Level 16
Posts: 6583
Joined: Mon Jun 12, 2017 8:39 pm

Re: Clock not updating on restore from sleep

Post by MrEen »

Actually, patches were submitted in March 2018, so I'm hoping Mint Xfce 19.3 will have the fix built in with the upgrade of xfce4 to 4.14. I'm assuming xfce4-timer-plugin will be upgraded as well, but that's not guaranteed.

Source of patch: https://bugzilla.xfce.org/attachment.cgi?id=8026
Discussion of patches that include this fix: https://bugzilla.xfce.org/show_bug.cgi?id=14748

User avatar
meToo
Level 1
Level 1
Posts: 26
Joined: Sat Feb 02, 2019 6:52 am
Location: Staffordshire, England

Re: Clock not updating on restore from sleep

Post by meToo »

MrEen wrote:
Sun Dec 01, 2019 7:15 pm
Actually, patches were submitted in March 2018, so I'm hoping Mint Xfce 19.3 will have the fix built in with the upgrade of xfce4 to 4.14. I'm assuming xfce4-timer-plugin will be upgraded as well, but that's not guaranteed.

Source of patch: https://bugzilla.xfce.org/attachment.cgi?id=8026
Discussion of patches that include this fix: https://bugzilla.xfce.org/show_bug.cgi?id=14748
Thank you MrEen, Mint 19.3 is due soon AFAIK so I will stall at this point and come back to this topic if the problem still exists after upgrade, if that's OK with you. After a number of sleep/restore cycles it does seem that the clock update works as long as the panel does not auto-hide.

Mike.
Lenovo T520 i5, 8GB ram, 1TB HDD Mint 19.3 Tricia XFCE

User avatar
MrEen
Level 16
Level 16
Posts: 6583
Joined: Mon Jun 12, 2017 8:39 pm

Re: Clock not updating on restore from sleep

Post by MrEen »

Sounds good Mike.

The 19.3 beta should be released tomorrow I believe, followed a few weeks later by the official release.

User avatar
MrEen
Level 16
Level 16
Posts: 6583
Joined: Mon Jun 12, 2017 8:39 pm

Re: Clock not updating on restore from sleep

Post by MrEen »

Heh. Don't ask me why I wrote xfce4-timer-plugin. I meant xfce4-datetime-plugin. It is upgraded in the new Xfce:

Code: Select all

scott@scottbeta-vm:~$ apt policy xfce4-datetime-plugin
xfce4-datetime-plugin:
  Installed: 0.8.0-1~18.04
  Candidate: 0.8.0-1~18.04
  Version table:
 *** 0.8.0-1~18.04 500
        500 http://mirror.cs.jmu.edu/pub/linuxmint/packages tricia/backport amd64 Packages
        100 /var/lib/dpkg/status
     0.7.0-1ubuntu1 500
        500 http://mirror.cs.jmu.edu/pub/ubuntu bionic/universe amd64 Packages
scott@scottbeta-vm:~$
Only problem is I don't know if those patches were ever applied. I'll try setting the panel to autohide and see if I can reproduce your issue in the 19.3 VM and my 18.3 install.

EDIT: Well, so much for that idea. Suspending the 19.3 VM just locks it up. Probably not enough RAM assigned. You'll find out soon enough anyway.

Post Reply

Return to “Other topics”