Time not setting correctly, desk clock changes every second.

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
tek3195
Level 1
Level 1
Posts: 18
Joined: Fri Feb 22, 2019 4:45 am

Time not setting correctly, desk clock changes every second.

Post by tek3195 »

Hi, my desktop time is off by 5 hours and then it is correct every second. I mean like every second on the second the clock flashes between NTP and I guess UTC which is a five hour diff, at the moment it's flashing between 0722 and 0222. Trying to update anything is hit or miss with apt errors for time stamps and signing certificates not being valid yet. There is nothing I know to do to fix it, setting to network time shows 5 hours off from local and if I try to change time manually it changes back within 5 sec and starts flashing back and forth again.

Code: Select all

tek3195@micro-mini:~$ inxi -Fxxxrz
System:    Kernel: 5.8.0-50-lowlatency x86_64 bits: 64 compiler: N/A Desktop: Cinnamon 4.8.6 wm: muffin 4.8.1 
           dm: LightDM 1.30.0 Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal 
Machine:   Type: Desktop Mobo: ASRock model: B365M Phantom Gaming 4 serial: <filter> UEFI: American Megatrends 
           v: P4.30 date: 05/14/2020 
Battery:   Device-1: hidpp_battery_36 model: Logitech MX Ergo Multi-Device Trackball serial: <filter> 
           charge: 100% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Topology: 8-Core model: Intel Core i7-9700 bits: 64 type: MCP arch: Kaby Lake rev: D 
           L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 48000 
           Speed: 4702 MHz max: 4700 MHz Core speeds (MHz): 1: 4687 2: 4710 3: 4642 4: 4638 5: 4696 6: 4698 
           7: 4697 8: 4641 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: ASRock driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:3e98 
           Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.2.6 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a2f0 
           Sound Server: ALSA v: k5.8.0-50-lowlatency 
Network:   Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:1f.6 
           chip ID: 8086:15b8 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: f040 
           bus ID: 03:00.0 chip ID: 8086:24fb 
           IF: wlp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 3.25 TiB used: 358.89 GiB (10.8%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB size: 465.76 GiB speed: 31.6 Gb/s 
           lanes: 4 serial: <filter> rev: 2B2QEXE7 scheme: GPT 
           ID-2: /dev/sda vendor: Smart Modular Tech. model: SHGS31-1000GS-2 size: 931.51 GiB speed: 6.0 Gb/s 
           serial: <filter> rev: 0Q00 scheme: GPT 
           ID-3: /dev/sdb vendor: Western Digital model: WD20SPZX-22UA7T0 size: 1.82 TiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: 1A01 scheme: GPT 
           ID-4: /dev/sdc type: USB model: General USB Flash Disk size: 14.55 GiB serial: <filter> rev: 1100 
           scheme: MBR 
           ID-5: /dev/sdd type: USB vendor: SanDisk model: Ultra Fit size: 57.28 GiB serial: <filter> 
           rev: 1.00 scheme: MBR 
Partition: ID-1: / size: 456.83 GiB used: 19.45 GiB (4.3%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /home size: 888.20 GiB used: 338.44 GiB (38.1%) fs: ext4 dev: /dev/sda1 
           ID-3: swap-1 size: 28.13 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 26.0 C mobo: 30.0 C 
           Fan Speeds (RPM): fan-1: 3013 fan-2: 734 fan-3: 721 fan-4: 0 fan-5: 0 
           Voltages: 12v: N/A 5v: N/A 3.3v: 3.38 vbat: 3.09 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http://mirrors.evowise.com/linuxmint/packages ulyssa main upstream import backport
           2: deb http://la-mirrors.evowise.com/ubuntu focal main restricted universe multiverse
           3: deb http://la-mirrors.evowise.com/ubuntu focal-updates main restricted universe multiverse
           4: deb http://la-mirrors.evowise.com/ubuntu focal-backports main restricted universe multiverse
           5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http://archive.canonical.com/ubuntu/ focal partner
Info:      Processes: 304 Uptime: 7h 16m Memory: 30.30 GiB used: 3.78 GiB (12.5%) Init: systemd v: 245 
           runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash v: 5.0.17 running in: gnome-terminal 
           inxi: 3.0.38
i7-9700, B365M Phantom Gaming 4, 4x8GB TEAM T-Force DDR4@3000MHz, 970 EVO M.2NVMe 500GB, SK Hynix Gold S31 1TB, WD Blue 2TB HDD, Alphacool custom Eisbaer, Rosewill Photon 550W, Cooler Master Q300L mATX-Mini
User avatar
manyroads
Level 3
Level 3
Posts: 176
Joined: Wed Mar 30, 2011 11:14 am
Location: just around the corner
Contact:

Re: Time not setting correctly, desk clock changes every second.

Post by manyroads »

Is there some reason you elected not to reset the system clock to using UTC?

This may help. viewtopic.php?t=289710
Pax vobiscum,
...mark
dwm, i3wm
Professional Genealogist & Technologist (http://eirenicon.org & http://many-roads.com)
User avatar
LanceM
Level 12
Level 12
Posts: 4123
Joined: Sun Jul 08, 2018 11:50 pm
Location: Gem State

Re: Time not setting correctly, desk clock changes every second.

Post by LanceM »

Is this a dual boot with Windows? If so you can set Mint to local time to keep the motherboard time in sync. To do that:

Code: Select all

timedatectl set-local-rtc 1
To revert it:

Code: Select all

timedatectl set-local-rtc 0
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php
tek3195
Level 1
Level 1
Posts: 18
Joined: Fri Feb 22, 2019 4:45 am

Re: Time not setting correctly, desk clock changes every second.

Post by tek3195 »

LanceM wrote:
Sun May 09, 2021 5:29 pm
Is this a dual boot with Windows? If so you can set Mint to local time to keep the motherboard time in sync. To do that:

Code: Select all

timedatectl set-local-rtc 1
To revert it:

Code: Select all

timedatectl set-local-rtc 0
No dual boot. I've set and reset everything I have read could be reset. My clock still goes back and forth every second. I used dpkg-reconfigure tzdata to make sure I had the right time and it shows local time 5 hours off the wrong way. Below you can see where it is 16:51 local there is a 5 hour offset to UTC but my clock is 5 hours the other way showing 11:51 and 16:51 alternately. I am not timing it but it seems like it will flash every second for 30~60 seconds and then change. I can't understand the 11:51 showing on desktop when it doesn't show anywhere with timedatectl cmd. I'm going to try to record screen again and see if I can get it with clock, volkoscreen-ng cut panel out last time

root@tek3195-OptiPlex:/home/tek3195# timedatectl
Local time: Sun 2021-05-09 16:51:00 CDT
Universal time: Sun 2021-05-09 21:51:00 UTC
RTC time: Sun 2021-05-09 21:51:00
Time zone: America/Chicago (CDT, -0500)
System clock synchronized: yes
NTP service: active
RTC in local TZ: no

EDIT: I am on a diff PC than when I first asked the question. I have same issue on it and they are nothing alike except OS. Could my internet provider(which sucks) be causing this ?
i7-9700, B365M Phantom Gaming 4, 4x8GB TEAM T-Force DDR4@3000MHz, 970 EVO M.2NVMe 500GB, SK Hynix Gold S31 1TB, WD Blue 2TB HDD, Alphacool custom Eisbaer, Rosewill Photon 550W, Cooler Master Q300L mATX-Mini
User avatar
LanceM
Level 12
Level 12
Posts: 4123
Joined: Sun Jul 08, 2018 11:50 pm
Location: Gem State

Re: Time not setting correctly, desk clock changes every second.

Post by LanceM »

You can shut the internet connection off to see. Otherwise it's a mystery to me. Does your time setting look like mine except for different city?
3.jpg
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php
tek3195
Level 1
Level 1
Posts: 18
Joined: Fri Feb 22, 2019 4:45 am

Re: Time not setting correctly, desk clock changes every second.

Post by tek3195 »

LanceM wrote:
Sun May 09, 2021 5:29 pm
Is this a dual boot with Windows? If so you can set Mint to local time to keep the motherboard time in sync. To do that:

Code: Select all

timedatectl set-local-rtc 1
To revert it:

Code: Select all

timedatectl set-local-rtc 0
I've included screenshot with it showing 14:44 and the time is 19:44. It has local time wrong. Is it constantly trying to adjust for incorrect time maybe ? I've lived in CST/CDT time zone for 50 years and I know what time it is, my computers can't figure it out though. Doesn't it get its time from internet connection ?

Image
[URLhttps://www.mediafire.com/view/2lpficwobs0gkct/ ... 0.png/file][/url]
i7-9700, B365M Phantom Gaming 4, 4x8GB TEAM T-Force DDR4@3000MHz, 970 EVO M.2NVMe 500GB, SK Hynix Gold S31 1TB, WD Blue 2TB HDD, Alphacool custom Eisbaer, Rosewill Photon 550W, Cooler Master Q300L mATX-Mini
tek3195
Level 1
Level 1
Posts: 18
Joined: Fri Feb 22, 2019 4:45 am

Re: Time not setting correctly, desk clock changes every second.

Post by tek3195 »

LanceM wrote:
Sun May 09, 2021 7:05 pm
You can shut the internet connection off to see. Otherwise it's a mystery to me. Does your time setting look like mine except for different city?3.jpg
yes looks like that with chicago and shows it 5 hours earlier than it is. About to see if it does same with no internet connection.

@LanceM thanks for the hint, I was not thinking about turning off internet. That's where it is. Ran straight without it and as soon as I turned it back on and selected network time it went back to 5 hours earlier and trying to compensate every second. This shit wreaks havoc on a system, causes things not to build correctly, or download and install.

Now to figure out why and how to fix. WOW will be of no help I'm sure.
i7-9700, B365M Phantom Gaming 4, 4x8GB TEAM T-Force DDR4@3000MHz, 970 EVO M.2NVMe 500GB, SK Hynix Gold S31 1TB, WD Blue 2TB HDD, Alphacool custom Eisbaer, Rosewill Photon 550W, Cooler Master Q300L mATX-Mini
User avatar
LanceM
Level 12
Level 12
Posts: 4123
Joined: Sun Jul 08, 2018 11:50 pm
Location: Gem State

Re: Time not setting correctly, desk clock changes every second.

Post by LanceM »

Another gimmick you might try is to set the time to a different city (say wast coast) let it update and restart your PC. After 20 minutes or so, set it back to Chicago.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php
sleeper12
Level 16
Level 16
Posts: 6533
Joined: Thu May 25, 2017 3:22 pm

Re: Time not setting correctly, desk clock changes every second.

Post by sleeper12 »

I don't know if it's the same for you, but the way I fixed my time/date problem was to uninstall NTP in Synaptic. If it doesn't solve your problem, just reinstall NTP.
tek3195
Level 1
Level 1
Posts: 18
Joined: Fri Feb 22, 2019 4:45 am

Re: Time not setting correctly, desk clock changes every second.

Post by tek3195 »

LanceM wrote:
Mon May 10, 2021 1:03 pm
Another gimmick you might try is to set the time to a different city (say wast coast) let it update and restart your PC. After 20 minutes or so, set it back to Chicago.
Been away for a bit but I found that it is a mint issue. I partitioned some space to dual boot another linux distro and the issue is not there with Bodhi Linux or Ubuntu Cinnamon Remix. I installed both so i wasn't running a live usb, and it is same drive and same hardware. If I boot Mint my clock tries to adjust every second, boot one of the others and smooth as glass without that 5 hours diff the wrong way showing anywhere. I've not tried on the second machine yet as it is currently in a case mod state. When I get it back together I'm pretty confident I will see same results.

Nowhere near solved by any means. I can resolve the issue on the machine by not running Linux Mint, but that seems like giving up. There's not a lot a quit in me, so I'm not done trying but damn, sometimes you got to work smarter and not harder. It's a lot easier to boot a different OS.
i7-9700, B365M Phantom Gaming 4, 4x8GB TEAM T-Force DDR4@3000MHz, 970 EVO M.2NVMe 500GB, SK Hynix Gold S31 1TB, WD Blue 2TB HDD, Alphacool custom Eisbaer, Rosewill Photon 550W, Cooler Master Q300L mATX-Mini
User avatar
LanceM
Level 12
Level 12
Posts: 4123
Joined: Sun Jul 08, 2018 11:50 pm
Location: Gem State

Re: Time not setting correctly, desk clock changes every second.

Post by LanceM »

An unsolved mystery :?:
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php
Post Reply