SLR Camera not recognised under Mint 20.2

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Bob Unitt
Level 2
Level 2
Posts: 88
Joined: Tue Feb 12, 2013 7:04 pm

SLR Camera not recognised under Mint 20.2

Post by Bob Unitt »

My SLR camera (Fuji HS10) isn't detected when plugged into a USB port on Mint 20.2. It used to work on this PC on Mint 19. It works OK on a Mint 19 laptop, so it's not the camera or the cable. I've tried multiple USB ports and successfully connected to those same ports with other equipment, so it's not the PC's USB ports. Any suggestions gratefully received...
Bob Unitt
Level 2
Level 2
Posts: 88
Joined: Tue Feb 12, 2013 7:04 pm

Re: SLR Camera not recognised under Mint 20.2

Post by Bob Unitt »

Bump ? or an I posting to the wrong forum ?
User avatar
AndyMH
Level 18
Level 18
Posts: 8150
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: SLR Camera not recognised under Mint 20.2

Post by AndyMH »

With it plugged in does it show up in lsusb?
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 4 x Thinkpad T430 Cinnamon 20.1, 2 x i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
mikeflan
Level 9
Level 9
Posts: 2532
Joined: Sun Apr 26, 2020 9:28 am
Location: Houston, TX

Re: SLR Camera not recognised under Mint 20.2

Post by mikeflan »

Hi Bob. I believe you when you say
My SLR camera (Fuji HS10) isn't detected
But it is more helpful if you say what you did to determine it was not detected.
Bob Unitt
Level 2
Level 2
Posts: 88
Joined: Tue Feb 12, 2013 7:04 pm

Re: SLR Camera not recognised under Mint 20.2

Post by Bob Unitt »

AndyMH - Yes, it shows as "Bus 002 Device 003: ID 04cb:020f Fuji Photo Film Co., Ltd Digital Camera" (exactly the same as on the Mint 19.1 laptop).

mikeflan - When I plug it into my laptop's Mint 19.1 Cinnamon it pops-up a Nemo window called "Digital Camera", with a view of the camera's file folder, and it appears in Nemo's 'Devices' list as "Digital Camera". Neither of these things happens in my Desktop PC's Mint 20.2 Cinnamon. Both used to happen when this particular PC was running Mint 19.1 Cinnamon.
User avatar
absque fenestris
Level 11
Level 11
Posts: 3711
Joined: Sat Nov 12, 2016 8:42 pm
Location: Confoederatio Helvetica

Re: SLR Camera not recognised under Mint 20.2

Post by absque fenestris »

.
See the System Settings Preferred Applications > Removable Media > ... when a camera is connected

Image
Linux Mint 18.3 Sylvia (MATE) 32-bit - Acer D250 Netbook (currently in age-related vacations)
Linux Mint 20.0 Ulyana (Cinnamon) - Huawei MateBook X Pro
User avatar
AndyMH
Level 18
Level 18
Posts: 8150
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: SLR Camera not recognised under Mint 20.2

Post by AndyMH »

Bob Unitt wrote:
Tue Oct 12, 2021 2:19 pm
AndyMH - Yes, it shows as "Bus 002 Device 003: ID 04cb:020f Fuji Photo Film Co., Ltd Digital Camera" (exactly the same as on the Mint 19.1 laptop).
Not that I have any helpful suggestions, but to confirm that it does NOT show up in nemo in the devices pane?

Have you tried other usb ports, e.g. if usb3 then a usb2 port.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 4 x Thinkpad T430 Cinnamon 20.1, 2 x i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
Bob Unitt
Level 2
Level 2
Posts: 88
Joined: Tue Feb 12, 2013 7:04 pm

Re: SLR Camera not recognised under Mint 20.2

Post by Bob Unitt »

AndyMH wrote:
Tue Oct 12, 2021 2:54 pm
Not that I have any helpful suggestions, but to confirm that it does NOT show up in nemo in the devices pane?
Yes, I confirm that it doesn't appear.
AndyMH wrote:
Tue Oct 12, 2021 2:54 pm
Have you tried other usb ports, e.g. if usb3 then a usb2 port.
I've tried other ports, but not sure what you mean by 'usb3 port' etc - is that the same as 'Bus' on the lsusb output ?
Bob Unitt
Level 2
Level 2
Posts: 88
Joined: Tue Feb 12, 2013 7:04 pm

Re: SLR Camera not recognised under Mint 20.2

Post by Bob Unitt »

absque fenestris wrote:
Tue Oct 12, 2021 2:38 pm
.
See the System Settings Preferred Applications > Removable Media > ... when a camera is connected
I tried both 'Ask what to do' and 'Open folder', neither had any effect.
User avatar
AndyMH
Level 18
Level 18
Posts: 8150
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: SLR Camera not recognised under Mint 20.2

Post by AndyMH »

This could be a kernel issue, what version of LM19 was it? I think LM19.2 shipped with a 4.15 kernel and LM19.3 with 5.4 (could be wrong). LM20 is the 5.4 kernel (unless you have upgraded it to 5.11).
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 4 x Thinkpad T430 Cinnamon 20.1, 2 x i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
Bob Unitt
Level 2
Level 2
Posts: 88
Joined: Tue Feb 12, 2013 7:04 pm

Re: SLR Camera not recognised under Mint 20.2

Post by Bob Unitt »

AndyMH wrote:
Wed Oct 13, 2021 7:50 am
This could be a kernel issue, what version of LM19 was it? I think LM19.2 shipped with a 4.15 kernel and LM19.3 with 5.4 (could be wrong). LM20 is the 5.4 kernel (unless you have upgraded it to 5.11).
I'd forgotten that LM19.1 was still intact on my desktop PC (I installed 20 from scratch rather than updating 19), I can now confirm that the camera still works OK on 19.1, on the same PC and the same port that doesn't work on 20.2.

The 19.1 Kernel is 4.4.0-109-generic, the 20.2 kernel is 5.4.0-88-generic.
User avatar
SMG
Level 18
Level 18
Posts: 8260
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: SLR Camera not recognised under Mint 20.2

Post by SMG »

Bob Unitt wrote:
Wed Oct 13, 2021 3:11 pm
The 19.1 Kernel is 4.4.0-109-generic, the 20.2 kernel is 5.4.0-88-generic.
Just an FYI: that is not a currently supported kernel for LM19.1. The supported kernels are 4.15 and 5.4.

If you have your camera attached to your LM20 install, is it showing up as a drive in the Disks app? I'm wondering if maybe it is just not mounting automatically and maybe you can get it to mount in Disks?
Image
A woman typing on a laptop with LM20.2 Cinnamon.
User avatar
AndyMH
Level 18
Level 18
Posts: 8150
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: SLR Camera not recognised under Mint 20.2

Post by AndyMH »

LM18 shipped with a 4.4 kernel, LM19 was 4.15. I liked the 4.4 kernel, it was the last kernel where my ultrawide monitor worked 'out of the box' at its native resolution. Ever since then I've had to set the resolution with xrandr.

UKUU will give you 4.x mainline kernel (or it used to and the old free version I've got does*). Mainline will only give you 5.x kernels.

I think if you use an old mainline kernel and it works the only thing you would miss with, say, a 4.4 kernel is security updates. May be wrong. I've no idea what tweaks mint does to the kernel.

* just checked, oldest is 4.0.1, newest 5.6.17
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 4 x Thinkpad T430 Cinnamon 20.1, 2 x i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
User avatar
Lady Fitzgerald
Level 8
Level 8
Posts: 2209
Joined: Tue Jan 07, 2020 3:12 pm
Location: AZ, SSA (Squabbling States of America)

Re: SLR Camera not recognised under Mint 20.2

Post by Lady Fitzgerald »

This does not address the actual issue but may be a workaround you can use. I don't use a cable to connect my two cameras to a computer because copying the files from the camera to the computer runs down the camera batteries and the transfer speed was slow. Instead, I pull the SD card out of the camera and plug it into a computer card reader (either onboard or with a USB card adapter) and copy directly from the card. This is both faster for me and spares the camera's' batteries.

Hopefully, your camera's data card is as easy to access as mine are.
Jeannie

One has to be proactive, not reactive, to ensure the safety of one's data so backup your data! And RAID is NOT a backup!

Linux Mint Cinnamon 19.3 Cinnamon 64 bit - System 76 Serval WS (serw11) 17" Laptop
User avatar
AndyMH
Level 18
Level 18
Posts: 8150
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: SLR Camera not recognised under Mint 20.2

Post by AndyMH »

Drifting, but only slightly. Putting in the SD card from my camera (Pentax) into the built-in SD card reader in my thinkpad won't work. It refuses to read the card, similarly reformatting the card from mint to fat32 - the camera insists on reformatting it. However, put the card in a SD/usb adapter and no problems at all. Never figured out why, just live with it.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 4 x Thinkpad T430 Cinnamon 20.1, 2 x i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
Bob Unitt
Level 2
Level 2
Posts: 88
Joined: Tue Feb 12, 2013 7:04 pm

Re: SLR Camera not recognised under Mint 20.2

Post by Bob Unitt »

SMG wrote:
Wed Oct 13, 2021 7:13 pm
If you have your camera attached to your LM20 install, is it showing up as a drive in the Disks app? I'm wondering if maybe it is just not mounting automatically and maybe you can get it to mount in Disks?
No, it doesn't show in Disks, only in lsusb.
Bob Unitt
Level 2
Level 2
Posts: 88
Joined: Tue Feb 12, 2013 7:04 pm

Re: SLR Camera not recognised under Mint 20.2

Post by Bob Unitt »

I have a workaround already. I can reboot to Mint 19.1 on a different partition on the same PC, copy the files to that file-system, reboot to Mint 20.2, mount the 19.1 file system, and copy the files to 20.2. However this is pretty cumbersome, and it would be nice to be able to copy them directly to 20.2.
User avatar
AndyMH
Level 18
Level 18
Posts: 8150
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: SLR Camera not recognised under Mint 20.2

Post by AndyMH »

Still cumbersome - install LM19.1 in a VM on your LM20.2 PC.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 4 x Thinkpad T430 Cinnamon 20.1, 2 x i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
Bob Unitt
Level 2
Level 2
Posts: 88
Joined: Tue Feb 12, 2013 7:04 pm

Re: SLR Camera not recognised under Mint 20.2

Post by Bob Unitt »

The plot thickens...
I tried having the camera plugged-in and switched-on when I restarted the PC under Mint 20.2. It gave me several occurrences of the message "usb 2-6: device descriptor read/64 error -110" followed by "usb 2-6: device not accepting address 5 error 110" followed by "USB 2 Port 6: Unable to enumerate USB device.". These messages do not appear on a Mint 19.1 restart.
User avatar
SMG
Level 18
Level 18
Posts: 8260
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: SLR Camera not recognised under Mint 20.2

Post by SMG »

Bob Unitt wrote:
Fri Oct 15, 2021 5:22 am
I have a workaround already. I can reboot to Mint 19.1 on a different partition on the same PC, copy the files to that file-system, reboot to Mint 20.2, mount the 19.1 file system, and copy the files to 20.2. However this is pretty cumbersome, and it would be nice to be able to copy them directly to 20.2.
I presume you are using the exact same physical usb port in both cases. Is that correct?
Bob Unitt wrote:
Fri Oct 15, 2021 7:42 am
The plot thickens...
I tried having the camera plugged-in and switched-on when I restarted the PC under Mint 20.2. It gave me several occurrences of the message "usb 2-6: device descriptor read/64 error -110" followed by "usb 2-6: device not accepting address 5 error 110" followed by "USB 2 Port 6: Unable to enumerate USB device.". These messages do not appear on a Mint 19.1 restart.
The -110 errors I have seen generally are a timing out error. The connection keeps trying until a certain amount of time elapses and then it stops trying rather than going in an endless loop of attempts. I do not know if that is the same error you are seeing.

Are other usb devices working on the LM20 install?

You didn't give any data about your computer, but in this (very old) topic Unable to enumerate USB device several people found enabling IOMMU in the BIOS worked to get the device enumerated.
Image
A woman typing on a laptop with LM20.2 Cinnamon.
Post Reply