Black screen after Suspend OR Hibernation

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 4
Joined: Fri Nov 23, 2012 3:02 am

Black screen after Suspend OR Hibernation

Post by thebeardedchild » Fri Nov 23, 2012 4:02 am

Hey everyone,

So I just got into Linux only a couple years ago, starting with Ubuntu on an old HP Pavilion I had. It ran alright, but I got sick of it (REALLY sick of it when Unity came out). It was mostly just for fun, so I didn't learn a TON from it, but I'm still interested so I recently took an old HP Mini 311 I had and decided to throw Mint on it. I installed Linux Mint 14 with Cinnamon via USB and it all seemed to go very well. I am impressed with Mint so far and think it is nice and clean, which I like coming from Ubuntu. However, a crippling problem I've found with my set up is that I seem to be unable to use Suspend or Hibernate without the computer freezing. Honestly, the issue is a little confusing, especially considering my lack of knowledge of Linux overall. My confusion mostly stems from the facts that I don't know what the difference with Suspend and Hibernate is, the issue has seemed to NOT happen a small handful of times for no reason, it has occurred in slightly different ways that usually involve being able to move the mouse vs. not being able to or being able to hit some sort of CTRL+ALT+F7 or F8 or whatever combo to get out of it SOMETIMES, etc. etc.
That all being said, here's the real meat to my issue (thanks for bearing with me so far!):

Like I said, in general it happens when I suspend the computer or put it into hibernation mode. I've researched the issue a lot the last day (to no avail, of course, since everyone seems to have a little different issue than I or it just hadn't been solved) and some have said their problem lies with the fact the computer won't even enter those modes. Mine does, and when I click on them from the power menu or close the lid, I can definitely hear the computer kind of hum down and see lights go off so that all seems in order for the most part. But when I open the lid or wake the computer up some other way, it takes a second for a log in screen to appear (the one where I enter the user name and hit enter, then enter a password and hit enter. NOT just the one where you enter just the password, if this distinction is important) and I enter it all like normal but after that, just black screen. Initially it had a clock at the top middle and my name with a padlock symbol at the top right, but lately my black screen doesn't have those so I dunno what that's all about. I can move the mouse but nothing happens, but a couple times the mouse is really laggy and slow or might freeze entirely. SOMETIMES, as I mentioned, I can use a button combo to get out of it. Mostly these combos do nothing or they'll bring up the login menu again and start it all over again. I typically just hold the power button to force it to shutdown. Also to note, booting up from shut down/restarting doesn't have any problems for me.

So there's that... I know it's a lot but details are important so I hope someone has the patience to read all my blabbering! I've read this thread and checked out the links a poster referenced about a similar issue in Ubuntu that a script solved. I ran the terminal command in step one, entered all the code and saved the file, then went back to the terminal and ran the second command (nothing in particular happened that I saw at least) but it didn't fix the issue... I see this solution often while researching my problem, so I'm hopeful it could work in some way and perhaps I do it wrong, I'm not sure though.

Finally, here's my system info I got from an inxi command, which I'm sure will be useful:
System: Host: jordan-linuxmint Kernel: 3.5.0-17-generic i686 (32 bit) Desktop: Gnome Distro: Linux Mint 14 Nadia
Machine: System: Hewlett-Packard product: HP Mini 311-1000 version: 0392100000201B00000320000
Mobo: Quanta model: 3651 version: 49.14 Bios: Hewlett-Packard version: F.02 date: 08/04/2009
CPU: Single core Intel Atom CPU N270 (-HT-) cache: 512 KB flags: (nx sse sse2 sse3 ssse3)
Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz
Graphics: Card: NVIDIA ION VGA [GeForce 9400M]
X.Org: 1.13.0 drivers: (unloaded: fbdev,vesa) FAILED: nouveau Resolution: 1366x768@60.0hz
GLX Renderer: Gallium 0.4 on NVAC GLX Version: 3.0 Mesa 9.0
Audio: Card: NVIDIA MCP79 High Definition Audio driver: snd_hda_intel Sound: ALSA ver: 1.0.25
Network: Card-1: Broadcom BCM43224 802.11a/b/g/n driver: bcma-pci-bridge
IF: wlan0 state: up mac: 00:26:82:33:f7:c5
Card-2: NVIDIA MCP79 Ethernet driver: forcedeth
IF: eth0 state: down mac: 00:26:9e:83:47:96
Drives: HDD Total Size: 160.0GB (2.7% used) 1: id: /dev/sda model: FUJITSU_MJA2160B size: 160.0GB
Partition: ID: / size: 145G used: 4.1G (3%) fs: ext4 ID: swap-1 size: 1.87GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 47.0C mobo: N/A gpu: 54.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 132 Uptime: 5 min Memory: 163.3/1761.8MB Client: Shell inxi: 1.8.4
I fear that the computer itself is the problem...I saw some sparse mentions in my research of graphics cards creating this issue. Maybe I can get new drivers somehow (wouldn't know how, sadly...)?

Thanks again to anyone who reads this! I appreciate it and hopefully you have any sort of advice! It all helps!

User avatar
Brahim Salem
Level 8
Level 8
Posts: 2408
Joined: Tue May 29, 2012 10:12 pm
Location: USA

Re: Black screen after Suspend OR Hibernation

Post by Brahim Salem » Fri Nov 23, 2012 2:08 pm

Try these steps only when the following command at the terminal doesn't work.

sudo shutdown -P now

If it works, no worries. Else, you need to try Step 1 and 2 along with the Note provided below. With these my shutdown problem is a thing of the past.

Step 1: Go to terminal and type

sudo gedit /etc/default/grub

It will open the grub file. Change the line
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" acpi=force apm=power_off
and close it after saving.

Step 2: Again hit the terminal and type

sudo gedit /etc/modules

It will open the modules - just type apm power_off=1 below lp and save the file.

Step 3: Next type in the terminal
sudo update-grub

Now the grub will be updated and you won't face any issue with shutdown.

This works like a charm in Ubuntu 11.04 with grub2. Hopefully it will work for other versions as well.

Addition on 14Nov2011:

In addition, you may need to modify ACPI configuration to enable smooth shutdown. To do so, type the following in the terminal.

sudo modprobe -rf rt2860sta
sudo modprobe rt2860sta
echo blacklist rt2800pci | sudo tee -a /etc/modprobe.d/blacklist.conf

Once you restart your computer, your shutdown would be proper and things won't hang at shutdown.

This is caused by the switch to plymouth. You can get a patch for mountall from a ppa that will allow you to remove plymouth but this is not going to help this problem which is caused by libplymouth2.

You need libplymouth2.

You need to file a bug on this or find one that you can join;

ubuntu-bug libplymouth2

Level 1
Level 1
Posts: 4
Joined: Fri Nov 23, 2012 3:02 am

Re: Black screen after Suspend OR Hibernation

Post by thebeardedchild » Fri Nov 23, 2012 2:54 pm

I'm not having any problems with shutting down/restarting though... does this fix work for Suspend and Hibernate as well or something?

Post Reply

Return to “Other topics”