[SOLVED] Hard drive permissions

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
M4rtyz
Level 1
Level 1
Posts: 3
Joined: Thu Aug 23, 2012 7:59 am

[SOLVED] Hard drive permissions

Postby M4rtyz » Thu Aug 23, 2012 8:07 am

Hello, I have 2 hard drives. 1 is 120GB for operating system and another 500GB for music, films, games etc and I want to allow all users to use that drive, but I'm having problems with that. I go to 500GB properties > Permissions then changing Others folder access from 'None' to 'Create and delete files' , but it changes it back to 'None'. Any ideas? :?
By the way sorry for my bad english..
Last edited by M4rtyz on Sun Aug 26, 2012 10:50 am, edited 1 time in total.

User avatar
Flemur
Level 10
Level 10
Posts: 3258
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Hard drive permissions

Postby Flemur » Thu Aug 23, 2012 9:43 am

You might start a terminal (xterm, etc) and do:

$ sudo chmod -R a+w /partition_name

-R = recursive = do all the files
a+w = all users have write (and delete) permission.
Mint 18 Mate/fluxbox/pulse-less - Xubuntu 16.04/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

User avatar
Flemur
Level 10
Level 10
Posts: 3258
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Hard drive permissions

Postby Flemur » Thu Aug 23, 2012 10:49 am

Edit: you might need to be root for your method ("Properties"):

$ sudo nautilus

then try the Properties.
Mint 18 Mate/fluxbox/pulse-less - Xubuntu 16.04/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

altair4
Level 18
Level 18
Posts: 8053
Joined: Tue Feb 03, 2009 10:27 am

Re: Hard drive permissions

Postby altair4 » Thu Aug 23, 2012 11:49 am

I go to 500GB properties > Permissions then changing Others folder access from 'None' to 'Create and delete files' , but it changes it back to 'None'. Any ideas?

Yes, it's an ntfs formated partition. Please post the output of the following commands:

Code: Select all

sudo blkid -c /dev/null

Code: Select all

cat /etc/fstab

Code: Select all

mount
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

M4rtyz
Level 1
Level 1
Posts: 3
Joined: Thu Aug 23, 2012 7:59 am

Re: Hard drive permissions

Postby M4rtyz » Fri Aug 24, 2012 3:50 am

altair4 wrote:
I go to 500GB properties > Permissions then changing Others folder access from 'None' to 'Create and delete files' , but it changes it back to 'None'. Any ideas?

Yes, it's an ntfs formated partition. Please post the output of the following commands:

Code: Select all

sudo blkid -c /dev/null

Code: Select all

cat /etc/fstab

Code: Select all

mount


Code: Select all

martynas@martynas-ect ~ $ sudo blkid -c /dev/null
[sudo] password for martynas:
/dev/sda1: UUID="61e1517c-c0ce-46dd-859f-7aae63cdee41" TYPE="ext4"
/dev/sda5: UUID="3621905c-862f-44fb-942e-49f02e36a935" TYPE="swap"
/dev/sdb5: LABEL="500GB" UUID="00F40A76F40A6E6A" TYPE="ntfs"
martynas@martynas-ect ~ $ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=61e1517c-c0ce-46dd-859f-7aae63cdee41 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=3621905c-862f-44fb-942e-49f02e36a935 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
martynas@martynas-ect ~ $ mount
/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/martynas/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=martynas)
martynas@martynas-ect ~ $ ^C
martynas@martynas-ect ~ $



@Flemur doesn't work

altair4
Level 18
Level 18
Posts: 8053
Joined: Tue Feb 03, 2009 10:27 am

Re: Hard drive permissions

Postby altair4 » Fri Aug 24, 2012 6:16 am

[1] If your partition is currently mounted unmount it:

Code: Select all

sudo umount /media/500GB

[2] Create a permanent home for the partition.

Code: Select all

sudo mkdir /media/500GB

[3] Edit fstab as root:

Code: Select all

gksu gedit /etc/fstab

[4] Add a line to the end of the file:

Code: Select all

UUID=00F40A76F40A6E6A /media/500GB ntfs defaults,nls=utf8,umask=000 0 0

[5] Run the following command to test for errors and if there are none mount the partition:

Code: Select all

sudo mount -a
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

M4rtyz
Level 1
Level 1
Posts: 3
Joined: Thu Aug 23, 2012 7:59 am

Re: Hard drive permissions

Postby M4rtyz » Sun Aug 26, 2012 10:49 am

thanks!


Return to “Other topics”

Who is online

Users browsing this forum: No registered users and 3 guests