Disable Touchscreen

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
Jmurrs
Level 1
Level 1
Posts: 3
Joined: Sun Jul 08, 2012 11:04 am

Disable Touchscreen

Post by Jmurrs » Mon Feb 18, 2013 3:17 pm

My dell xps has a glitchy problem with its touchscreen and it drives me crazy and I need to disable it.
I am running mint 14 cinnamon desktop.
I've tried xinput set-prop 13 "Device Enabled" 0 and that does not seem to turn off the touchscreen.
Help!

alicebtoklas
Level 1
Level 1
Posts: 6
Joined: Sat Nov 24, 2012 6:31 pm

Re: Disable Touchscreen

Post by alicebtoklas » Sat Nov 30, 2013 6:41 am

Type in the terminal:

Code: Select all

xinput list
and see what shows. Somewhere under "virtual core pointer" the name of your touchscreen device should appear (on my ASUS X202E it's "Atmel Atmel maXTouch Digitizer")

Then type

Code: Select all

xinput set-prop <device-name> "Device Enabled" 0
(So in my case it was

Code: Select all

xinput set-prop "Atmel Atmel maXTouch Digitizer" "Device Enabled" 0
)

And that's it.

If you you want to enable it back type

Code: Select all

xinput set-prop <device-name> "Device Enabled" 1

FiruzzZ
Level 1
Level 1
Posts: 2
Joined: Mon May 25, 2015 2:14 pm

Re: Disable Touchscreen

Post by FiruzzZ » Mon May 25, 2015 2:18 pm

I got a problem with this, the device doesn't stay disabled, every time I reboot my book, it is enabled again.
How can I make this config permanently?

Buzzsaw
Level 6
Level 6
Posts: 1307
Joined: Sat Aug 23, 2014 12:53 pm

Re: Disable Touchscreen

Post by Buzzsaw » Wed May 27, 2015 9:24 pm

Add the command to your autostart list.

SteveH_66
Level 2
Level 2
Posts: 59
Joined: Wed Feb 08, 2012 10:08 pm

Re: Disable Touchscreen

Post by SteveH_66 » Sun Feb 14, 2016 12:38 am

Buzzsaw wrote:Add the command to your autostart list.
This was a very useful tip, as I don't really care for touchscreen on a laptop. But I am new to Mint and Linux in general, running Mint 17.3 KDE 64-bit, and I was wondering how do I find the autostart list? Thanks for any assistance
System 1: Acer-Aspire V3-472P-324J. Hardware : 14" Touch Screen dual-band 2.4GHz & 5.0GHz Acer Nplify wireless LAN (802.11a/b/g/n); BT 4.0; OS : Linux Mint 17.3 Rosa; Kernel: 4.4.0-96 (64 bit) MATE 1.12.0

SteveH_66
Level 2
Level 2
Posts: 59
Joined: Wed Feb 08, 2012 10:08 pm

Re: Disable Touchscreen

Post by SteveH_66 » Wed Feb 24, 2016 4:48 pm

This fix wasn't working for me. It worked when I first started the computer, and stayed working until the computer suspended, the lid was closed or opened, etc. I lucked across what seems to be a permanent fix in the Ubuntu forums, and here is the link to that post :

http://ubuntuforums.org/showthread.php?t=2209083

As you can see, you edit the "/usr/share/X11/xorg.conf.d/10-evdev.conf" file. You edit the touchscreen section, which in my 10-evdev.conf file is the last section. It will have this identifier in the section - Identifier "evdev touchscreen catchall" - the identifier seems to be the 2nd line in all the sections. Just add in this line - Option "Ignore" "on" - I put it in as the last line before "End Section". Then I rebooted before it would take effect. You might be able to just log off and back on, not sure.

Seems to be working great for permanently disabling the touchscreen. If you want touchscreen functionality back, I'm sure just take the line out, or probably even comment it out with a # at the beginning of the line should work.

Oh, and if any other newbies like myself are looking for the autostart list for some other reason, I got the answer to that question in this post viewtopic.php?f=90&t=216794 along with some useful tips and information from the guru's that answered my question.
System 1: Acer-Aspire V3-472P-324J. Hardware : 14" Touch Screen dual-band 2.4GHz & 5.0GHz Acer Nplify wireless LAN (802.11a/b/g/n); BT 4.0; OS : Linux Mint 17.3 Rosa; Kernel: 4.4.0-96 (64 bit) MATE 1.12.0

Iswearimtrin
Level 1
Level 1
Posts: 5
Joined: Sun Jan 28, 2018 1:49 am

Re: Disable Touchscreen

Post by Iswearimtrin » Sun Jan 28, 2018 4:09 am

Are y'all trolling? What you actually do is
xinput list
Then find your touchscreen name on that list ( should say "touchscreen" in the name)
Then put in
Xinput disable "DEVICE NAME"
REALLY ACTUALLY DONE :lol:

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Disable Touchscreen

Post by Cosmo. » Sun Jan 28, 2018 10:23 am

Iswearimtrin wrote:Are y'all trolling?
Posting in a 2 years old thread leads to the question, what you are doing. At least I know, what you are not doing Do do not read or respect the forum rules (Section II, #2).

Iswearimtrin
Level 1
Level 1
Posts: 5
Joined: Sun Jan 28, 2018 1:49 am

Re: Disable Touchscreen

Post by Iswearimtrin » Tue Jan 30, 2018 1:06 am

Well this is all just very hard to find help for..... Do you know how i can get permission to edit this file? I tired opening it with sudo in the terminal but it still didn't let me edit it.

Post Reply

Return to “Other topics”