Mint Crashing...

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 18
Joined: Fri Mar 09, 2007 10:13 am

Mint Crashing...

Postby bitshifter » Fri Mar 09, 2007 10:31 am

I am new to Linux and Mint and very much enjoy the OS. However, it seems to crash for reasons that I don't understand. Here are the contents of one of the crash files that was generated this morning /var/crash/_usr_bin_mono.1000.crash:
{The file is too large for this message, but here are some of the contents}

ProblemType: Crash
Date: Fri Mar 9 08:05:41 2007
libglib2.0-0 2.12.4-0ubuntu1
perl-modules 5.8.8-6
libgdbm3 1.8.3-3
lsb-base 3.1-10ubuntu4
ncurses-bin 5.5-2ubuntu1
libdb4.4 4.4.20-6ubuntu1
perl 5.8.8-6
tzdata 2007b-0ubuntu0.6.10
perl-base 5.8.8-6
sed 4.1.5-1
binfmt-support 1.2.8
locales 2.3.22
belocs-locales-bin 2.4-1ubuntu6
libc6 2.4-1ubuntu12.3
libncurses5 5.5-2ubuntu1
zlib1g 1:1.2.3-13ubuntu2
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/".
Core was generated by `beagled-helper --debug /usr/lib/beagle/IndexHelper.exe'.
Program terminated with signal 11, Segmentation fault.
#0 0x08156873 in mono_handle_native_sigsegv ()
Dump of assembler code from 0x8156873 to 0x8156893:
0x08156873 <mono_handle_native_sigsegv+1283>: mov 0x8(%eax),%eax
0x08156876 <mono_handle_native_sigsegv+1286>: test %edx,%edx
0x08156878 <mono_handle_native_sigsegv+1288>: mov %eax,0xffffffec(%ebp)
0x0815687b <mono_handle_native_sigsegv+1291>: je 0x815688b <mono_handle_native_sigsegv+1307>
0x0815687d <mono_handle_native_sigsegv+1293>: mov 0x10(%edx),%eax
0x08156880 <mono_handle_native_sigsegv+1296>: lea 0xfffffff0(%ebp),%ecx
0x08156883 <mono_handle_native_sigsegv+1299>: cmp %eax,%ecx
0x08156885 <mono_handle_native_sigsegv+1301>: ja 0x8156cad <mono_handle_native_sigsegv+2365>
0x0815688b <mono_handle_native_sigsegv+1307>: movl $0x0,0xffffff70(%ebp)
End of assembler dump.
DistroRelease: Ubuntu 6.10
ExecutablePath: /usr/bin/mono
Package: mono-jit
ProcCmdline: beagled-helper --debug /usr/lib/beagle/IndexHelper.exe
ProcCwd: /home/robert

Please let me know how I should proceed.


User avatar
Level 4
Level 4
Posts: 244
Joined: Wed Nov 15, 2006 11:05 am
Location: Canada

Postby Fragadelic » Fri Mar 09, 2007 11:39 am

Beagle is what caused the crash. If you don't need to search everything on your sytem on a regular basis, you can go ahead and remove it.

Mono, IMHO, is still buggy and so are some of the apps that use it. I had problems with Beagle myself and removed it along with all the other mono stuff. FSpot is a mono app and so is Tomboy. Gthumb replaces Fspot as a photo importer/manager.

Return to “Other topics”

Who is online

Users browsing this forum: No registered users and 3 guests