Help with ntfs - permissions? [SOLVED - work around]

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
User avatar
edwardr
Level 4
Level 4
Posts: 248
Joined: Thu Jun 03, 2010 1:09 pm
Location: USA - Texas

Help with ntfs - permissions? [SOLVED - work around]

Post by edwardr »

Thanks in advance for any help!

I like to share my data directories between my Mint and Windows installations, so I have the data directories on an ntfs partition. It used to work great, I could rip my CD's to my Music folder, use custom commands in Gthumb to organize and move pictures in my Pictures folder etc. But for a while now this has been broken. For example, in Asunder, I set the preferences to save the ripped music to the ntfs partition, but when I start ripping it saves the music instead to my home folder. It's like the program cannot write to the ntfs partition. This used to work fine, and I feel like some upgrade somewhere along the way broke it. I have had this issue with Mint 9 xfce and Mint 14 xfce.

My ntfs partition is mounted at startup using an entry in fstab. I have tried the following entries in fstab (and probably some other variants too), but no luck:
/dev/sda3 /media/Windows ntfs defaults,umask=007,uid=1000,gid=46 0 0
/dev/sda3 /media/Windows ntfs defaults,umask=000,uid=1000,gid=46 0 0
/dev/sda3 /media/Windows ntfs-3g defaults,umask=000,uid=1000,gid=1000 0 0

Thanks again!

Ed
Last edited by edwardr on Fri Dec 27, 2013 4:28 pm, edited 1 time in total.
The optimist proclaims that we live in the best of all possible worlds; and the pessimist fears this is true
altair4
Level 20
Level 20
Posts: 10309
Joined: Tue Feb 03, 2009 10:27 am

Re: Help with ntfs - permissions?

Post by altair4 »

What's not clear from your post is whether you yourself cannot write to /media/Windows ( through Thunar for example ) or just this Asunder application you speak of cannot write to the partition.

You might want to post the output of the following commands so folks here can see how you are set up:

Code: Select all

cat /etc/fstab

Code: Select all

sudo blkid -c /dev/null

Code: Select all

mount
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
Habitual
Level 13
Level 13
Posts: 4861
Joined: Sun Nov 21, 2010 8:31 pm
Location: 0.0.0.0

Re: Help with ntfs - permissions?

Post by Habitual »

Code: Select all

rw,uid=1000,gid=100,dmask=022,fmask=133 0 0
options will give you the Linux permissions of
755 on directories and 644 on files.

gid=100 may be uid=1000 for you.
User avatar
edwardr
Level 4
Level 4
Posts: 248
Joined: Thu Jun 03, 2010 1:09 pm
Location: USA - Texas

Re: Help with ntfs - permissions?

Post by edwardr »

I did a little bit of checking - I can use Thunar to copy files to the ntfs partition and delete files from it also. I also tried deleting an image from within Here are the outputs:

from cat /etc/fstab:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda6 during installation
UUID=6377a6bb-e45d-42c4-adcf-8953221c6cd3 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=606c1eed-c829-4be6-b691-7b44e1cbe973 none swap sw 0 0
/dev/sda3 /media/Windows ntfs-3g defaults,umask=000,uid=1000,gid=1000 0 0

from sudo blkid -c /dev/null:
/dev/sda1: SEC_TYPE="msdos" LABEL="DellUtility" UUID="3030-3030" TYPE="vfat"
/dev/sda2: LABEL="RECOVERY" UUID="942E6C132E6BED24" TYPE="ntfs"
/dev/sda3: LABEL="OS" UUID="AC4C1B954C1B5982" TYPE="ntfs"
/dev/sda5: UUID="606c1eed-c829-4be6-b691-7b44e1cbe973" TYPE="swap"
/dev/sda6: UUID="6377a6bb-e45d-42c4-adcf-8953221c6cd3" TYPE="ext4"

from mount:
/dev/sda6 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
/dev/sda3 on /media/Windows type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
gvfsd-fuse on /run/user/edward/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=edward)


thanks
The optimist proclaims that we live in the best of all possible worlds; and the pessimist fears this is true
User avatar
edwardr
Level 4
Level 4
Posts: 248
Joined: Thu Jun 03, 2010 1:09 pm
Location: USA - Texas

Re: Help with ntfs - permissions?

Post by edwardr »

Habitual, I tried the edit you recommended to my fstab, but Asunder still ended up saving the file to my home folder. Then I tried running it using "sudo asunder", chose teh directory in the ntfs partition, and it still did not save the file there, instead saving it to the Root home..
The optimist proclaims that we live in the best of all possible worlds; and the pessimist fears this is true
altair4
Level 20
Level 20
Posts: 10309
Joined: Tue Feb 03, 2009 10:27 am

Re: Help with ntfs - permissions?

Post by altair4 »

Although I would have set the line in fstab differently there is nothing wrong with the line you already had:
/dev/sda3 /media/Windows ntfs-3g defaults,umask=000,uid=1000,gid=1000 0 0
And it seems to have mounted it correctly since the output of "mount" yields this:
/dev/sda3 on /media/Windows type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
And you can in fact access the partition yourself:
I can use Thunar to copy files to the ntfs partition and delete files from it also
To me the culprit seems to be Asunder especially since it decides on it's own to save it in a location of it's choosing not yours. I don't know what to tell you. I can give you what I think the line should look like but I don't think it would solve this particular issue.

When asunder saves this file to your home directory can you use Thunar to copy it to /media/Windows or does it fail there as well?
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
User avatar
jahid
Level 6
Level 6
Posts: 1217
Joined: Sat Dec 07, 2013 4:07 pm
Location: Khulna, Bangladesh

Re: Help with ntfs - permissions?

Post by jahid »

try this entry:
/dev/sda3 /media/your_user_name/windows ntfs defaults 0 0
jahid@HP ProBook 440 G1 Laptop
User avatar
edwardr
Level 4
Level 4
Posts: 248
Joined: Thu Jun 03, 2010 1:09 pm
Location: USA - Texas

Re: Help with ntfs - permissions?

Post by edwardr »

So I gave up on Asunder (which I have used for years) and tried another ripper in the repos, Ripoff, which works just fine with saving to the Windows partition. Thanks for looking in to this for me guys.
The optimist proclaims that we live in the best of all possible worlds; and the pessimist fears this is true
Post Reply

Return to “Other topics”