Magicjack on Linux

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 31
Joined: Mon Apr 23, 2012 3:58 pm

Magicjack on Linux

Post by gary428509 »

Has anybody out there found a way to run Magicjack on Linux?
User avatar
Level 4
Level 4
Posts: 380
Joined: Mon Dec 16, 2013 3:21 pm

Re: Magicjack on Linux

Post by panorain »

I have looked this up a bit but have not found any solution.

Some people have said to at least try to write to Magicjack requesting linux driver support.

Now with the Magic Jack + one can just logon to the Magicjack website and renew their subscription there. No need to plug it into a computer running Windows to do that anymore.

Thank you,
Linux Mint 20 Ulyana
Linux Mint 19.1 Tara
NetBSD 8.2 [beginner] :)
openSUSE 15.2 LEAP
Always =updatedb=
Level 1
Level 1
Posts: 24
Joined: Thu Aug 27, 2015 1:56 am

Re: Magicjack on Linux

Post by educatedidiot »

I thought some more recent info would be helpful to some.
There is still no Linux driver for Magic Jack, so you cannot use a softphone on your Linux computer with it. Some people apparently have had success doing this by using Wine, or by certain other, highly technical, workarounds.
If you only want to use Magic Jack as an ATA (analog telephone adaptor), and thus just hook up MJ to your physical phone and your router, it doesn't matter what Op system you are using, because you are simply bypassing your computer. You just need to get your device registered at, and set up an account there. The MJ server will then talk directly to your MJ device and your physical phone, through your router.
Important: You probably will not be able to register using Linux. In my case (Mint 17.2), although I had heard that you have to register using a PC or Mac, I tried it through Mint anyway. I figured that if your browser (mine is Firefox 54, 64 bit) can navigate their website, what's the problem? Well, I actually got 90% through the process, but in the last step, where your phone number is given to you, the web page registered an error, and referred me to chat for help.
I bagged that idea, since their chat support apparently stinks mightily. I have a dual boot system, so I just rebooted into Window$ 7, and successfully registered and set up an account from there. Although I could not set up my account from Linux, once it was done from Window$, thereafter I am able to access it from Linux.
Post Reply

Return to “Other topics”