Linux Mint 17.1 multiple issues (X, sound, MTP)

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 26
Joined: Fri Aug 14, 2009 9:29 pm

Linux Mint 17.1 multiple issues (X, sound, MTP)

Post by rvsjimbo »


I have Linux Mint 17.1 (64bit) MATE installed on a Lenovo ThinkPad T520. It was all working perfectly (I think). Certainly the X login manager was automatically starting and sound was working.

So, the most annoying problem is that there is now no sound. If I bring up the sound preferences GUI, and select the Hardware tab, there are no devices. However, if I bring up a terminal and use lsmod I see, amongst other things, several modules to do with sound:

snd_seq 55383 2 snd_seq_midi_event,snd_seq_midi
scsi_dh 14458 1 dm_multipath
btusb 27580 0
aes_i586 16995 1 aesni_intel
cfg80211 409394 3 iwlwifi,mac80211,iwldvm
xts 12749 1 aesni_intel
bluetooth 342208 22 bnep,btusb,rfcomm
snd_seq_device 14137 3 snd_seq,snd_rawmidi,snd_seq_midi
lrw 13057 1 aesni_intel
snd_timer 28584 2 snd_pcm,snd_seq
gf128mul 14503 2 lrw,xts
serio_raw 13230 0
ablk_helper 13357 1 aesni_intel
snd 60939 12 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,thinkpad_acpi,snd_seq_device,snd_seq_midi
cryptd 15578 1 ablk_helper
shpchp 32128 0
soundcore 12600 1 snd

So I am wondering if it is something to do with PulseAudio - or something other X-specific problem.

So, regarding X, this no longer starts up automatically. I can work around this by logging in on one of the virtual consoles and typing startx, but it is slightly annoying.

Finally there is the mobile phone (Android, Samsung Galaxy S3). I'm fairly sure I have been able to transfer files to and from this in the past, but now I get a message saying "Unable to open MTP device '[usb:001,009]'". I have followed instructions elsewhere on here, and executed the following command to try and remedy this:

sudo apt-get install mtp-tools mtpfs

But its still not working. Short of a complete re-install can anyone tell me what to fix these issues?


Level 1
Level 1
Posts: 9
Joined: Sat Sep 28, 2013 10:04 am

Re: Linux Mint 17.1 multiple issues (X, sound, MTP)

Post by JonathanHarford »

Same MTP issue, except my code is [usb:003,014]. T-Mobile Galaxy Note 3 vs. Mint 17.1 Cinnamon. Just started happening a few days ago.
Level 3
Level 3
Posts: 131
Joined: Tue Dec 24, 2013 7:12 pm

Re: Linux Mint 17.1 multiple issues (X, sound, MTP)

Post by Aristotelian »

What output are you trying to use for sound? You may need to set your default "sink" (soundcard) and "profile" (HDMI, analog, or both). HDMI is often disabled by default.

As for MTP, I have never had a smooth experience with media devices. The best workaround that I know of is to use the app Airdroid for file transfer. This has always worked seamlessly for me. You install the app on your phone, then access your phone and do file transfer through a web browser on your computer.
Post Reply

Return to “Other topics”