[Resolved] Copy/Paste do not work RELIABLY

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
User avatar
tovian
Level 5
Level 5
Posts: 529
Joined: Sun Nov 22, 2015 1:17 pm
Location: Heart of Dixie

Re: Copy/Paste do not work RELIABLY

Post by tovian » Tue Apr 05, 2016 6:56 pm

@Cosmo... Got it. In KDE it's an app named Klipper (icon is vertical scissors). Another one of those things right in front of me but I didn't know what I was looking at until your prodding. I will do some testing and post my observations.

THANK YOU TO EVERYONE WHO IS CONTRIBUTING TO THIS THREAD !!!
“I think that this situation absolutely requires a really futile and stupid gesture be done on somebody's part!"
"We're just the guys to do it.”

Animal House

User avatar
LinuxJim
Level 5
Level 5
Posts: 659
Joined: Tue Jan 26, 2016 8:01 pm
Location: Oregon, USA

Re: Copy/Paste do not work RELIABLY

Post by LinuxJim » Tue Apr 05, 2016 8:01 pm

tovian wrote:@Cosmo - Thank you for your suggestion. I'm really NOT shooting from the hip. After I read your post yesterday I tried to do exactly what you suggested. In fact, I fooled with it for about a half hour and never could find what you referred to in the "panel". I checked the "Cashew" and the System-settings app, I even did a single Google search, but I never found what you were referring to. I know I'm a brick sometimes, but if you'd give me specific instructions I should be able to perform your test. AND - regardless of what I observe - the results will be useful to me and (hopefully) others.
Here is what I did to test what Cosmo suggested.

I didn't have a Mint 17.3 KDE system, so I installed one (and updated to current).

Installed KWrite.

Started Klipper (the KDE clipboard). A "scissors" icon appeared in the panel. Hovering over it shows the text "clipboard is empty". (see my EDIT below - this should have been a clue, but I missed it first time around).

I then opened a document in KWrite. Selected some text. Hit "ctrl-C". Hovered the mouse over the scissors icon in the panel and it showed the text I had just copied.

I then closed KWrite. The scissors icon still showed the copied text.

I then shut down the system, powered off, powered back on, and restarted.

The scissors icon still showed my selected text from the last session. I opened KWrite, hit ctrl-V, and the text was pasted into my document.

To, me, this is the expected behavior, and it seems to work that way in Mint as well - at least with a "vanilla" installation.

EDIT: Ahhh, it just dawned on me - you have been operating without a clipboard at all. Unless Klipper is running, KWrite (and other editors) use their internal copy/paste buffers to provide that function, so of course the contents go away when you close the application. I'll bet that's the whole problem. And indeed, in the Mint version of KDE, Klipper is not configured to start by default.

User avatar
tovian
Level 5
Level 5
Posts: 529
Joined: Sun Nov 22, 2015 1:17 pm
Location: Heart of Dixie

Re: Copy/Paste do not work RELIABLY

Post by tovian » Wed Apr 06, 2016 9:32 am

Hey LinuxJim, you might be on to something....

When I posted my comments (above) from my PCLinuxOS distro I noticed that Klipper was already running. I had to manually start it when I returned to MINT. After I started Klipper everything began working as it should for me. Klipper is still running, and things are still working correctly (clipboard NOT being cleared when window closes). I thought somebody had gone and changed something in Mint, but I also worried that when I was fooling around with Klipper I changed something on my computer. Now, it appears that the real answer is the latter. I'm sure that I did NOT modify PCLinuxOS to start Klipper at boot time - so that is the default in that distro (and probably lots of others as well) and that's why the copy/paste keyboard shortcuts work properly elsewhere.

Now, should the default for KDE be changed for all of MINT - or should I (and everyone else who is interested) change our machines to start Klipper when KDE starts ?

I believe MINT should change the global default to make KDE consistent with the other DE's MINT supports - but that's just my opinion. Now that the solution is in hand I will make sure I use it regardless of what I need to do to get there.

""

See that quote above? I don't either !! I just killed Klipper and the old behavior has returned. For me, this absolutely proves LinuxJim's theory.

I would ask the admins to have a look at this and consider making a change to LM's implementation of KDE so that Klipper starts automatically.

No matter what happens from here on.... MAJOR THANK YOU's TO EVERYONE WHO HELPED FIGURE THIS OUT !!!!!
(especially Karlchen who finally got the ball rolling)

[Whew................. wiping the sweat from my brow and breathing easier]
“I think that this situation absolutely requires a really futile and stupid gesture be done on somebody's part!"
"We're just the guys to do it.”

Animal House

User avatar
tovian
Level 5
Level 5
Posts: 529
Joined: Sun Nov 22, 2015 1:17 pm
Location: Heart of Dixie

Re: Copy/Paste do not work RELIABLY

Post by tovian » Tue Apr 12, 2016 12:14 pm

Resolution:

For KDE users... apparently unless the Klipper app is manually started KDE users are running WITHOUT a global clipboard service. For those who want to fix this issue you can manually start Klipper one time...

<Alt + F2> ... type klipper ... [Enter]

When the icon (scissors) appears in the panel you can right-click the icon and select "Quit". At that point you will be given an option to automatically start Klipper when each (login) session starts.

Click START and this problem will disappear.
“I think that this situation absolutely requires a really futile and stupid gesture be done on somebody's part!"
"We're just the guys to do it.”

Animal House

User avatar
phd21
Level 19
Level 19
Posts: 9015
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: [Resolved] Copy/Paste do not work RELIABLY

Post by phd21 » Tue May 10, 2016 10:21 pm

Hi Everyone,

I just read the original post and the good replies to it. Here are my thoughts on this as well.

In KDE, you also have the "Autostart options in the "Startup and Shutdown" settings in the "System Settings Menu" where you can add programs like "Klipper" as well.

On May 6, 2016 this article came out regarding Clipboards:

10 Best Clipboard Managers for Linux
http://www.tecmint.com/best-clipboard-m ... r-linux/2/

Another post on Clipboard managers which of course involves Copy & Paste functions that you might find interesting.
viewtopic.php?f=90&t=219530&hilit=clipboard

Hope this helps ...
Linux Mint_KDE_StartUp_Shutdown_Options1sm.jpg
Linux Mint KDE -StartUp/Shutdown Options
-Autostart options
Linux Mint_KDE_StartUp_Klipper1sm.jpg
Linux Mint KDE -StartUp/Shutdown settings
Autostart options showing "Klipper"
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

xmanmonk
Level 2
Level 2
Posts: 53
Joined: Sun Mar 11, 2012 8:42 pm
Location: Palm Springs, California, USA
Contact:

Re: [Resolved] Copy/Paste do not work RELIABLY

Post by xmanmonk » Sat Mar 11, 2017 3:52 pm

In case someone else comes across this, I ran into the same "problem," and here's how I "fixed" it:

First, make sure your machine is set up to start klipper at startup (in systemsettings -> Startup and Shutdown -> Autostart, and add /usr/bin/klipper there).

You may have to manually start klipper for the current session (Alt-F2, then type klipper or run it from a command line somewhere).

The klipper icon should be in the menu bar. Click on it and select Configure Klipper...

Make sure that "Synchronize contents of the clipboard and the selection" is checked.

Should work now. Does for me :)
-The X-Man

Post Reply

Return to “Other topics”