Headphone problem since installing Mint 18 [WORKAROUND APPLIED]

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
jerkins
Level 1
Level 1
Posts: 44
Joined: Mon Jun 01, 2009 3:55 pm

Headphone problem since installing Mint 18 [WORKAROUND APPLIED]

Post by jerkins » Mon Jul 25, 2016 5:09 am

Operating system details:
Linux Mint 18 64-bit
Mate 1.14.1

Audio setup is: line jack at the back of the motherboard goes to a pair of speakers, headphones plugged into socket at the front of the PC.

Problem:

When I start my computer in the morning the headphones don't work. Speakers plugged into the line out socket on the motherboard work OK.
I have to go into 'Control center' - 'Hardware' - 'Sound' - 'Output' tab and change 'selected device' from 'Line out' to 'headphones'.
After doing this, both the headphones and the speakers work OK until the computer is turned off again.

This used to work properly on Mint 17.3 prior to the fresh installation of Mint 18.

Any suggestions for fixing this?
Last edited by jerkins on Tue Jul 26, 2016 1:24 pm, edited 1 time in total.

User avatar
Flemur
Level 17
Level 17
Posts: 7238
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Headphone problem since installing Mint 18

Post by Flemur » Mon Jul 25, 2016 2:13 pm

If you don't get a better answer, a couple of short scripts (add to menu or desktop or key sequence, for easy access) might do it:

Code: Select all

amixer set "Headphone" unmute
amixer set "Speaker" mute
Get the proper names for "Headphone" and "Speaker" from alsamixer, or

Code: Select all

amixer
(lot of output)
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

User avatar
phd21
Level 19
Level 19
Posts: 9321
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Headphone problem since installing Mint 18

Post by phd21 » Mon Jul 25, 2016 2:52 pm

Hi "jerkins",

I just read your post and the good replies to it. Here are my thoughts on this as well.

You might consider installing and using "qasmixer" and the other "qas" programs from the Software Manager or Synaptic Package Manager (SPM).

There are some really nice graphical (GUI) programs for sound that start with "Qas", like the fantastic "Qasmixer", in the Software Manager or Synaptic Package Manager (SPM) that you can install and use. Sound "Mixers" can be a little confusing if you are not familiar with them. If you bring up "Qasmixer" full screen, on the right side you will have mixer devices where you can control your system sound. The item "sysdefault" will show all installed sound card devices and you will have various options to adjust various volume controls using "sliders" which you can turn off and on using the "dot" below the volume slider. There are also various other check boxes below that you can use.

The applications included are:
- qasconfig - browser for the alsa configuration tree
- qashctl - mixer for alsa's high level control interface
- qasmixer - desktop mixer with features similar to alsamixer
qasmixer is a desktop mixer application for alsa's "simple mixer interface" and offers features similar to alsamixer. it also features a sytem tray icon with basic mixer functionality.

Install "libasound2-plugin-equal" which is another system wide equalizer that's in the Software Manager or Synaptic Package Manager (SPM) that shows up in "QasMixer".

Veromix is a "superb" mixer for the Pulseaudio sound server.
Works with all editions of Linux Mint and is in the Software Manager or Synaptic Package Manager (SPM). KDE users should install this as a widget.
Features:
– Media Player Controls (aka nowplaying)
– per application volume control (replay & record)
– global hotkeys
– can be in your system tray

https://padoca.wordpress.com/2011/03/18 ... r-stories/

Hope this helps ...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

jerkins
Level 1
Level 1
Posts: 44
Joined: Mon Jun 01, 2009 3:55 pm

Re: Headphone problem since installing Mint 18

Post by jerkins » Mon Jul 25, 2016 3:47 pm

Flemur, The first command does the trick! It leaves me with both headphones and the speakers (when turned on) working as required. If I no-one comes up with a more elegant solution then I'll add your command to my login script (I won't need a 'change-over' script).

phd21 - I'll examine those if I want to try something more advanced.

Thanks to both,
David
Flemur wrote:If you don't get a better answer, a couple of short scripts (add to menu or desktop or key sequence, for easy access) might do it:

Code: Select all

amixer set "Headphone" unmute
amixer set "Speaker" mute
Get the proper names for "Headphone" and "Speaker" from alsamixer, or

Code: Select all

amixer
(lot of output)

okasion
Level 1
Level 1
Posts: 15
Joined: Wed Jun 07, 2017 11:19 am

Re: Headphone problem since installing Mint 18 [WORKAROUND APPLIED]

Post by okasion » Sat Aug 19, 2017 2:47 am

Why the heck Mint 18 has this problem?
I NEVER had a problem like in 11 years of working with a lot of POSIX based operative systems.

Post Reply

Return to “Other topics”