SOLVED:Corrupted keyboard input

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 15
Joined: Mon Apr 16, 2007 5:08 am

SOLVED:Corrupted keyboard input

Postby master_b » Sun Apr 22, 2007 12:08 am

MintLinux (2.2-KDE-Beta-0.22 with ALL upates) is running fine on my BenQ Joybook A32E laptop, except that at times the cursor relocates itself whilst I am entering text from te keyboard, sometimes re-aranging the input, sometimes exiting the input point (ie the log-in screen)and losing text, someimes changing lines (ie googles advance search input sceen), someties just loosing letters in midst of input.

Help/ideas/sugestions appreciated.

Laptop worked fine with Kubuntu 6.06, Mepis etc.

Last edited by master_b on Sun Apr 22, 2007 10:37 pm, edited 1 time in total.

Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Sun Apr 22, 2007 6:24 am

A mouse pointer behaving like that is mostly hardware related, but it might on occasion be software related.
You have the beta, it might be a good idea to get the stable just in case it is software related.
Clem recommends a fresh install to be sure to get rid of old bugs.
As it is a laptop - do you use a separate mouse or just the touchpad? If you use a mouse turn off the touchpad.
Don't fix it if it ain't broken, don't break it if you can't fix it

Level 1
Level 1
Posts: 15
Joined: Mon Apr 16, 2007 5:08 am

Corrupted keyboard input

Postby master_b » Sun Apr 22, 2007 10:46 pm

Installed ksynaptics and associated library ( can use gsynaptics or qsynaptics instead).

edited /etc/X11/xorg.conf - synaptics touchpad section

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "true"
Option "ShmConfig" "true" #added this line

NOTE 2nd Last Line

use correct case - some sites/forums show SHM instead of Shm and "on" instead of "true"

Go to /Settings/Peripherals/Touchpad and you can turn the Touchpad on or off and change other settings


User avatar
Level 2
Level 2
Posts: 89
Joined: Thu Mar 22, 2007 8:36 am
Location: Out at the Range, Confirming Zero.

Postby RedJak » Tue Apr 24, 2007 7:46 am

I had this problem before on my Dell 9400, and i took me a while to realize that i was accidentally hitting the touchpad with my thumb while typing :?

Return to “Other topics”