Linux Mint shows wrong time for photographs [SOLVED]

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Level 16
Level 16
Posts: 6681
Joined: Sun Mar 27, 2016 6:58 pm

Re: Linux Mint shows wrong time for photographs [SOLVED]

Post by rene »

Relative wrote:

Code: Select all

timedatectl set-local-rtc 1
Failed to issue method call: Input/output error
You probably have a bad /etc/adjtime file (which might also be the reason for your issue in the first place). Try deleting it, sudo rm /etc/adjtime and recreating it through another invocation of timedatectl set-local-rtc 1.

But at the same time note that this should be the wrong answer. Petermint was having issues with NTFS as well hence was and probably still is experiencing a different issue. The gist of things is: with the RTC in local time, the FAT timestamp-issue is well-known and expected on systemd systems such as Mint 18, and the solution should consist of conversely setting the RTC to UTC with timedatectl set-local-rtc 0. If the system dual-boots Windows, tell Windows that the RTC is set to UTC as per above.

Note that this would not magically fix formerly copied timestamps, but with the RTC in UTC and all operating systems informed of such (and your camera set to the correct time of course) newly taken photo's should be fine. If really they are not: I don't in fact run Mint 18.x but will try and investigate further if you can report the contents of your /etc/adjtime file, output of timedatectl status, whether or not the system dual-boots Windows and if so, which version and whether or nor you have told Windows that the RTC is in UTC.
Last edited by rene on Tue Jan 24, 2017 8:18 am, edited 1 time in total.
Level 6
Level 6
Posts: 1147
Joined: Tue Feb 16, 2016 3:12 am

Re: Linux Mint shows wrong time for photographs [SOLVED]

Post by Petermint »

Google produces many posts for that error. You can get errors from /etc/adjtime containing the wrong value. After the change, mine contains the following. LOCAL was added to the last line.

Code: Select all

0.0 0 0.0
Level 3
Level 3
Posts: 111
Joined: Fri Jul 30, 2010 9:43 pm
Location: Garden Grove, CA

Re: Linux Mint shows wrong time for photographs [SOLVED]

Post by Relative »

Will stop commenting to this thread. " Linux Mint 17.3 copy photos changes date to current. " is the thread I am updating.

Cinnamon 20 - MacBookPro2,1, MacBook2,1
Mate 20 - Lenovo ThinkPad L430, Lenovo ThinkPad T430, Dell N7110, Toshiba A215
Mate 19.3 - (32-bit version) Old home-built P4 desktop.
LMDE 4 - (32-bit version) Dell Inspiron 8600.
Raspbian - Pi3 & Pi4
User avatar
Level 2
Level 2
Posts: 60
Joined: Fri Dec 30, 2016 3:26 pm

Re: Linux Mint shows wrong time for photographs [SOLVED]

Post by mintage »

* * * * * * * * * * * * * * * * * * * * * * * * * * * *
Thanks to the mint support throng goodness
* * * * * * * * * * * * * * * * * * * * * * * * * * *
Post Reply

Return to “Other topics”