[solved] nfs parameters in Mint Mate 18

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
erikjan
Level 1
Level 1
Posts: 24
Joined: Tue Apr 14, 2015 6:18 am

[solved] nfs parameters in Mint Mate 18

Post by erikjan » Wed Dec 07, 2016 4:21 pm

When Mate 18, "Sara" came out, I installed it on my Acer Inspire One netbook, because version 17.3 had become slow like melasse. I do not understand why. I installed "Sara" on newly made partitions in order to be certain that there are no allocation tables problems. After installation I could not check the boot procedure, because pressing escape during the boot process did not show me the log but a black screen. Problem 1.

After adding the the line

192.168.1.10:/home/erikjan /mnt/erikjan nfs users,auto,rw 0 0

just like it was in version 17.3 booting and shutdown took several minutes. Problem 2.

I spent hours and hours to find out why I got these problems. I found this:

Without warning in the release notes another parameter has been added in grub: "vt_handoff". Only after removing this parameter could I check the boot process again. I saw then that connecting and disconnecting to my main computer via nfs took an extraordinarily long time. I have never seen this before. After a lot of searching on the internet I found that the line in fstab needs other parameters because of the use of systemd: auto,x-systemd,automount. There was no warning of this in the release notes either.

A main reason that I always mention advising the use of a Linux distribution, is ease of use: that (almost) everything works out of the box. This has been my experience with version 17.3 and its predecessors. It is only when one wants to change the defaults that one may need to search on the internet.

So what I would like to see, please, is that the release notes mention changes like these. Linux Mint Mate is a beautiful and easy to use operating system, but drives one mad when such unexpected changes are made without warning.

Greetings and keep up the good work.

Erik Jan
Last edited by erikjan on Sat Mar 11, 2017 7:58 am, edited 1 time in total.

AscLinux
Level 4
Level 4
Posts: 342
Joined: Sat Oct 29, 2016 3:32 pm

Re: nfs parameters in Mint Mate 18

Post by AscLinux » Wed Dec 07, 2016 4:37 pm

I never had so much trouble configure simple things as I do with Mint. I had to replace my wife's computer, our home was flooded and we lost practically everything. Normally I run Gentoo in all my desktops/laptops. This time a friend of mine donated a 32-bit Dell laptop and I thought I put Mint in it. It was a mistake. I still haven't figured out how to load a custom keymap when X starts. I got it briefly working messing with .desktop files, but it stopped working again. Do not know why. The problem is of course Mint ignores X basics and does not source startup files in users home directory. I could alter the files in /etc/X11 to regain the normal behavior but the changes made there are not protected against upgrades. This sucks ... I regret I installed Mint.

erikjan
Level 1
Level 1
Posts: 24
Joined: Tue Apr 14, 2015 6:18 am

Re: nfs parameters in Mint Mate 18

Post by erikjan » Tue Feb 21, 2017 4:56 pm

Today I installed Mate 18.1 on another computer and to my dismay I cannot get nfs share working. The solutions that I had found before (see first post of this thread) does not work. I searched on the internet but I did not find a solution. I cannot believe that no one else using Mate 18.1 has tried to contact a nfs-server as a client.

Please, enlighten me what parameters I must use in fstab to get the nfs share working.

Greetings,

Erik Jan.

deleted

Re: nfs parameters in Mint Mate 18

Post by deleted » Tue Feb 21, 2017 8:01 pm

Not the answer you're looking for, but I use autofs (the automounter) for nfs. Takes few minutes to install and no fstab modifications.
-H

grumpy_geek
Level 2
Level 2
Posts: 80
Joined: Tue Jan 03, 2017 3:50 am
Contact:

Re: nfs parameters in Mint Mate 18

Post by grumpy_geek » Wed Feb 22, 2017 6:00 am

erikjan wrote:

Code: Select all

192.168.1.10:/home/erikjan  /mnt/erikjan  nfs  users,auto,rw  0  0
May sound silly ... but did you try mounting the nfs share with default options?

Code: Select all

192.168.1.10:/home/erikjan  /mnt/erikjan  nfs  defaults  0  0
- What works for me (using Mint 18 as server and Debian 8 as client, though):

Code: Select all

# server:/etc/exports
/home/share  *(rw,all_squash,anonuid=1000,anongid=1000)
# client:/etc/fstab
[local_ip]:/home/share  /mnt/nfs  nfs  defaults  0 0

erikjan
Level 1
Level 1
Posts: 24
Joined: Tue Apr 14, 2015 6:18 am

Re: nfs parameters in Mint Mate 18

Post by erikjan » Thu Feb 23, 2017 6:58 am

Thank you all for your suggestions.

I tried them all. I found that in my case "auto,x-systemd,automount" works fastest during boot, but did not start the nfs-share on the client. Searching the internet I found the suggestion to start rpcbind via the command: "sysctl enable rpcbind && sysctl start rpcbind" (or something like this; I quote from memory now.) After this command I could start nfs-client with the command: "gksu mount -t nfs 192.168.178.16:/home erikjan /mnt/erikjan". In spite of "automount"and "auto" in fstab the share did not start automatically. This is why I believe the problem might be in the files of the policykit. I could not yet find the polkit files, nor do I know what changes to make in order to have the nfs client start automatically. I suspect that the developers of Mint 18.1 may have made a change in the policy kit files. If anyone knows about these matters, please direct me to the correct website or instruct me.

I also installed "autofs", but I still need to start nfs share with "gksu mount -t nfs 192.168.178.16:/home erikjan /mnt/erikjan". This strengthens my suspicion that the problem is in the policy kit files.

Thank you all for your help.

Greetings.

Erik Jan

deleted

Re: nfs parameters in Mint Mate 18

Post by deleted » Thu Feb 23, 2017 10:48 am

if you're using autofs, you'll want to edit /etc/auto.master
In my case, all I had to do is uncomment the /net line
and then create a /net directory
-Hinto

erikjan
Level 1
Level 1
Posts: 24
Joined: Tue Apr 14, 2015 6:18 am

Re: nfs parameters in Mint Mate 18

Post by erikjan » Sat Mar 04, 2017 9:13 am

Dear Hinto,

I followed your advice, installed autofs, edited /etc/auto.master put a new directory in root, /net, and booted again. Still no joy. To my surprise I could not find the program "autofs" anywhere, so I don't know what happened. I had a look at boot.log and found:

~ $ systemctl status mnt-erikjan.mount
● mnt-erikjan.mount - /mnt/erikjan
Loaded: loaded (/etc/fstab; bad; vendor preset: enabled)
Active: active (mounted) (Result: exit-code) since za 2017-03-04 13:58:39 CET
Where: /mnt/erikjan
What: 192.168.178.16:/home/erikjan
Docs: man:fstab(5)
man:systemd-fstab-generator(8)
Process: 1122 ExecMount=/bin/mount 192.168.178.16:/home/erkjan /mnt/erikjan -t

I read the docs mentioned, but still I do not know what is wrong; I do not understand what I read.

Does all this mean anything to you?

Thank you for your help.

Greetings,

Erik Jan.

deleted

Re: nfs parameters in Mint Mate 18

Post by deleted » Sat Mar 04, 2017 10:10 am

autofs is a service.
You'll also want to make sure that you have nfs-common installed, too,

I use this setup on every installation I have connecting to an nfs server.
You also want to make sure your user id (your number found in /etc/passwd) matches what the server expects.
https://community.linuxmint.com/tutorial/view/228

-H

erikjan
Level 1
Level 1
Posts: 24
Joined: Tue Apr 14, 2015 6:18 am

Re: nfs parameters in Mint Mate 18

Post by erikjan » Thu Mar 09, 2017 6:45 am

Dear Hinto,
thank you for all your help. User ID and group ID are the same on all computers that are connected via NFS. I have given up. I believe that there is some change of policy in Linux Mint Mate 18.1 compared to 17.3. I do not know how to change this. I had a look at the polkit-1 files in /etc and could not interpret what I read and find what tot change. When I find a distro that allows automounting , I shall install it.

Greetings,

Erik Jan.

deleted

Re: nfs parameters in Mint Mate 18

Post by deleted » Thu Mar 09, 2017 10:11 am

Nothing has changed.
I have used this on all Mints, Ubuntus, Debians, Redhats, etc.
-H

erikjan
Level 1
Level 1
Posts: 24
Joined: Tue Apr 14, 2015 6:18 am

Re: nfs parameters in Mint Mate 18

Post by erikjan » Sat Mar 11, 2017 7:58 am

Dear Hinto,

I reinstalled Linux Mint Mate 18.1 on freshly formatted partitions and, mirabile dictu, the problem is solved. Everything works as expected: the nfs directory opens at boot! I have no idea what I did differently now, but all is well.

Thank you very much for your support.

Greetings,

Erik Jan.

deleted

Re: [solved] nfs parameters in Mint Mate 18

Post by deleted » Sat Mar 11, 2017 8:59 am

Good to hear!.
-H

Post Reply

Return to “Other topics”