subprocess post-removal script returned error code 1

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

subprocess post-removal script returned error code 1

Postby Husse » Mon Apr 30, 2007 10:29 am

I can't get my multifunction Brother to scan so I thought I'd remove the driver and (x)sane. Sane is gone but when I try to remove the driver I get this message:
"E: brscan2: underprocess post-removal script gav felkod 1"
I have the swedish localized version and it should translate to:"E: brscan2: subprocess post-removal script returned error code 1"
Now I can't get rid of the driver and a search did not give much. I can roll back yesterdays version from my backup disk image so it's no big deal, but I want to be able to reinstall it and sane in the hope of getting it working.
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

D1Wayne
Level 3
Level 3
Posts: 198
Joined: Tue Apr 24, 2007 6:11 am
Location: Pacific North West

Postby D1Wayne » Mon Apr 30, 2007 1:44 pm

did you try
Mark for Complete Removal (synaptics)
or the
--purge remove (option if using apt-get)
followed by
sudo apt-get autoremove?

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Mon Apr 30, 2007 5:56 pm

yepp - tried Mark for Complete Removal (synaptics) and autoremove. However purge remove reveals the error. I've removed sane before brscan, but as the removal script wants sane there i get the error. (tries to remove /usr/local/Brother/sane/GrayCmData/ wich obviously was removed when sane was removed)
Well I think I'll recover my last backup and remove brscan first, because as it is I don't think it's possible.... unless I find and edit the script :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

moment 22

Postby Husse » Tue May 01, 2007 2:13 pm

Well after recovering the disk image of the day before yesterday I get the same error.
I.e. if I remove sane before I try to remove the Brother driver I get an error regarding /usr/local/Brother/sane/GrayCmData/ and a few others like it.
AND I get the same error if I don't remove sane first :(
Image
Don't fix it if it ain't broken, don't break it if you can't fix it


Return to “Other topics”

Who is online

Users browsing this forum: No registered users and 5 guests