Window Focus Completely Broken

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Spirrwell
Level 1
Level 1
Posts: 7
Joined: Thu May 05, 2011 5:32 pm

Window Focus Completely Broken

Postby Spirrwell » Sat Nov 04, 2017 6:37 pm

Hello there.

So I've done a fresh install of Linux Mint 18.2 on my desktop and it seems that no matter what, within minutes of booting Mint that the window focus completely breaks. I'm not sure if it's window focus, but to describe it, I'm typically unable to click controls, sometimes I can click inside of an open application, but focus seems to be locked to another open window and I can't type or anything. Like if I press the super key to bring up the start menu, I can't type there. Just everything is completely broken and I have to reboot to fix it... For a few minutes.

Now just as a note, I was having this same kind of problem in Ubuntu 16.04 I believe. The latest version of Ubuntu which uses GNOME appears to be fine now. But yeah, I don't know what to do, I just want the OS to work right, and I really just have no idea how to even figure out what's going wrong. I tried doing an apt-get upgrade, still the same result.

Any help or information is appreciated!

I wouldn't think this is a hardware problem, but here's my system specs:

MOBO: MSI Z87M Gaming
CPU: Intel Core i7-4770K
GPU: NVIDIA GTX 980 Ti
WLAN: Broadcom BCM4360
RAM: 16GB DDR3 G.SKILL Ripjaws (2x8GB)
Keyboard: G.SKILL Ripjaws KM780R
Mouse: G.SKILL Ripjaws MX780

Hoser Rob
Level 9
Level 9
Posts: 2824
Joined: Sat Dec 15, 2012 8:57 am

Re: Window Focus Completely Broken

Postby Hoser Rob » Sun Nov 05, 2017 9:59 am

Those specs are not actually useful ... copy/paste this into the terminal and copy/paste the text output here:

Code: Select all

inxi -Fxz

Spirrwell
Level 1
Level 1
Posts: 7
Joined: Thu May 05, 2011 5:32 pm

Re: Window Focus Completely Broken

Postby Spirrwell » Sun Nov 05, 2017 11:32 pm

Hoser Rob wrote:Those specs are not actually useful ... copy/paste this into the terminal and copy/paste the text output here:

Code: Select all

inxi -Fxz


Sure:

System: Host: SpirrwellTech Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.2 Sonya
Machine: Mobo: MSI model: Z87M GAMING (MS-7866) v: 1.0 Bios: American Megatrends v: V1.5 date: 06/02/2015
CPU: Quad core Intel Core i7-4770K (-HT-MCP-) cache: 8192 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28000
clock speeds: max: 3900 MHz 1: 909 MHz 2: 1396 MHz 3: 1091 MHz 4: 988 MHz 5: 1099 MHz 6: 1116 MHz
7: 1003 MHz 8: 1099 MHz
Graphics: Card: NVIDIA GM200 [GeForce GTX 980 Ti] bus-ID: 01:00.0
Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
Resolution: 1920x1080@144.00hz, 2560x1080@60.00hz
GLX Renderer: GeForce GTX 980 Ti/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.90 Direct Rendering: Yes
Audio: Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Card-2 NVIDIA Device 0fb0 driver: snd_hda_intel bus-ID: 01:00.1
Card-3 Corsair driver: USB Audio usb-ID: 003-005
Card-4 Blue Microphones Yeti Stereo Microphone driver: USB Audio usb-ID: 003-002
Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network: Card-1: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller
driver: alx port: d000 bus-ID: 03:00.0
IF: enp3s0 state: down mac: <filter>
Card-2: Broadcom BCM4360 802.11ac Wireless Network Adapter driver: wl bus-ID: 06:00.0
IF: wlp6s0 state: up mac: <filter>
Drives: HDD Total Size: 5001.0GB (1.0% used) ID-1: /dev/sda model: Samsung_SSD_850 size: 500.1GB
ID-2: /dev/sdb model: Samsung_SSD_850 size: 250.1GB ID-3: /dev/sdc model: ST2000DM001 size: 2000.4GB
ID-4: /dev/sdd model: ST2000DM001 size: 2000.4GB ID-5: /dev/sde model: Samsung_SSD_850 size: 250.1GB
Partition: ID-1: / size: 229G used: 47G (22%) fs: ext4 dev: /dev/sdb1
ID-2: swap-1 size: 0.51GB used: 0.00GB (0%) fs: swap dev: /dev/sdb2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:56C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 255 Uptime: 2 min Memory: 952.7/15989.4MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35


Return to “Other topics”

Who is online

Users browsing this forum: No registered users and 4 guests