Symlinks not visible in archives?

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
User avatar
fblais
Level 1
Level 1
Posts: 18
Joined: Mon Aug 27, 2012 8:03 am
Location: Québec, Canada

Symlinks not visible in archives?

Postby fblais » Mon Nov 06, 2017 9:14 am

Hi.
Mint 18.2, 64 bits, XFCE DE here.
I got a gtk theme archive. (zip format)
I know there are symlinks in the archive at a few places (I can see them when opening the archive in Windows) but opening the archive with both file-roller and xarchiver, the symlinks are not visible.
Extracting the archive doesn't create them either.
Any idea?
I'm going to try opening the archive within Xubuntu 17.10 tonight to see if it's the same thing.

TIA!
François

User avatar
MintBean
Level 9
Level 9
Posts: 2545
Joined: Fri Aug 07, 2015 6:54 am
Location: Blighty

Re: Symlinks not visible in archives?

Postby MintBean » Mon Nov 06, 2017 4:44 pm

I've heard of that issue before. I don't *think* it's a Mint specific issue but let us know what you find.

Is there an alternative to the archive? If it came from Github, you can easily clone the source.

User avatar
fblais
Level 1
Level 1
Posts: 18
Joined: Mon Aug 27, 2012 8:03 am
Location: Québec, Canada

Re: Symlinks not visible in archives?

Postby fblais » Tue Nov 07, 2017 11:11 am

I tried the same thing with Xubuntu 17.10 and it showed the same bug...
Using unzip in a terminal works, but that's not the best solution...

He's using Sourceforge, by the way.

User avatar
MintBean
Level 9
Level 9
Posts: 2545
Joined: Fri Aug 07, 2015 6:54 am
Location: Blighty

Re: Symlinks not visible in archives?

Postby MintBean » Tue Nov 07, 2017 12:09 pm

fblais wrote:Using unzip in a terminal works, but that's not the best solution...
I would have called it a 'limitation,' but if it works in the terminal then it's definitely in the 'bug' category.

User avatar
fblais
Level 1
Level 1
Posts: 18
Joined: Mon Aug 27, 2012 8:03 am
Location: Québec, Canada

Re: Symlinks not visible in archives?

Postby fblais » Tue Nov 07, 2017 4:29 pm

Just tried a live Xubuntu 17.04 session, and same thing...
I'll submit a bug report on Mint's Bug Launchpad.

User avatar
MintBean
Level 9
Level 9
Posts: 2545
Joined: Fri Aug 07, 2015 6:54 am
Location: Blighty

Re: Symlinks not visible in archives?

Postby MintBean » Tue Nov 07, 2017 5:44 pm

Cheers, good work.

Tiffansy
Level 1
Level 1
Posts: 1
Joined: Mon Nov 13, 2017 3:55 am

Re: Symlinks not visible in archives?

Postby Tiffansy » Mon Nov 13, 2017 3:56 am

Just tried a live Xubuntu 17.04 session, and same thing...

User avatar
fblais
Level 1
Level 1
Posts: 18
Joined: Mon Aug 27, 2012 8:03 am
Location: Québec, Canada

Re: Symlinks not visible in archives?

Postby fblais » Mon Nov 13, 2017 7:14 am

Thanks for confirming the bug!


Return to “Other topics”