[SOLVED] Very slow startup followed by keyboard & mouse lagging

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Sun Nov 26, 2017 9:47 am

[SOLVED] Very slow startup followed by keyboard & mouse lagging

Post by mint-enthusiast » Sun Nov 26, 2017 10:30 am

Hello everyone!
After successfully installing and running LinuxMint and LMDE2 on a PC and an ASUS-laptop I encountered problems with a new install on the third computer, a new ASUS laptop.
It's a 64 bit system where I installed Linux Mint Mate Sarah alongside Windows 10 and ugraded everything (apt-get upgrade & apt-get dist-upgrade). The install took a very long time (several hours).
Windows runs normally but unfortunately Linux takes several minutes to boot. When it's finally done it runs extremely "bumpy", appearing to stop every few seconds or so
(mouse-pointer freezes for a second, keyboard-input stops, even in terminal, and resumes and stops again...)
BTW, the touchpad doesn't work with Linux (but USB-mouse does).
I've already switched from gnome to XFCE4 which didn't solve the problem. I tried several things to improve performance (https://sites.google.com/site/easylinuxtipsproject/3)
like setting the swappiness to 10 and removing indexing (apt-xapian-index) - no noticeable change. Also deactivated unnecessary startup items (bluetooth).
I've verified the uuids reported by blkid with those in fstab - they match.

Code: Select all

systemd-analyze critical-chain:
graphical.target @41.275s
└─multi-user.target @41.275s
  └─[0;1;31mntp.service @32.314s +8.952s[0m
    └─network-online.target @32.298s
      └─[0;1;31mNetworkManager-wait-online.service @23.299s +8.998s[0m
        └─[0;1;31mNetworkManager.service @20.701s +2.578s[0m
          └─dbus.service @20.453s
            └─basic.target @20.431s
              └─sockets.target @20.431s
                └─acpid.socket @20.431s
                  └─sysinit.target @20.387s
                    └─[0;1;31msystemd-update-utmp.service @20.301s +84ms[0m
                      └─[0;1;31msystemd-tmpfiles-setup.service @20.078s +219ms[0m
                        └─local-fs.target @20.053s
                          └─run-cgmanager-fs.mount @20.759s
                            └─local-fs-pre.target @15.432s
                              └─[0;1;31mlvm2-monitor.service @5.225s +10.206s[0m
                                └─lvm2-lvmetad.service @6.414s
                                  └─lvm2-lvmetad.socket @5.224s
                                    └─-.slice @4.843s

Code: Select all

systemd-analyze blame:
         10.516s dev-sda5.device
         10.206s lvm2-monitor.service
          8.998s NetworkManager-wait-online.service
          8.952s ntp.service
          5.305s systemd-rfkill.service
          3.042s accounts-daemon.service
          2.809s ModemManager.service
          2.578s NetworkManager.service
          2.489s loadcpufreq.service
          2.085s networking.service
          2.018s keyboard-setup.service
          1.756s thermald.service
          1.746s boot-efi.mount
          1.623s irqbalance.service
          1.585s systemd-journald.service
          1.572s virtualbox-guest-utils.service
          1.451s systemd-udevd.service
          1.327s console-setup.service
          1.211s systemd-tmpfiles-setup-dev.service
          1.182s wpa_supplicant.service
          1.168s console-kit-daemon.service
          1.028s bluetooth.service
          1.023s polkitd.service
           994ms systemd-logind.service
           989ms user@1000.service
           950ms grub-common.service
           947ms ondemand.service
           909ms speech-dispatcher.service
           901ms systemd-fsck@dev-disk-by\x2duuid-242E\x2dDC9C.service
           853ms lm-sensors.service
           800ms systemd-modules-load.service
           682ms udisks2.service
           644ms rsyslog.service
           597ms dev-sda6.swap
           572ms dev-hugepages.mount
           512ms ureadahead-stop.service
           492ms upower.service
           460ms kmod-static-nodes.service
           429ms ufw.service
           400ms sys-kernel-debug.mount
           396ms dev-mqueue.mount
           334ms console-kit-log-system-start.service
           333ms systemd-udev-trigger.service
           268ms systemd-sysctl.service
           244ms cpufrequtils.service
           242ms avahi-daemon.service
           219ms systemd-tmpfiles-setup.service
           187ms systemd-journal-flush.service
           130ms systemd-remount-fs.service
           116ms binfmt-support.service
           104ms rtkit-daemon.service
            93ms hddtemp.service
            91ms systemd-random-seed.service
            84ms systemd-update-utmp.service
            78ms alsa-restore.service
            67ms plymouth-read-write.service
            59ms rc-local.service
            57ms pppd-dns.service
            51ms systemd-user-sessions.service
            51ms setvtrgb.service
            40ms resolvconf.service
            33ms plymouth-quit-wait.service
            30ms plymouth-start.service
            29ms plymouth-quit.service
            26ms dns-clean.service
            16ms proc-sys-fs-binfmt_misc.mount
            15ms systemd-update-utmp-runlevel.service
            10ms openvpn.service
             8ms sys-fs-fuse-connections.mount
Not posting dmesg here since it's too big. Several "Could not create tracefs" messages look suspicious, though.
I've tried the whole night to understand the problem and find a solution but finally I give up. Any ideas?

EDIT: upgrade to 18.2 Sonya appears to have fixed the problem! :D
Last edited by JeremyB on Sun Nov 26, 2017 10:31 am, edited 1 time in total.
Reason: added code tags

Level 11
Level 11
Posts: 3935
Joined: Sun Aug 09, 2015 10:00 am

Re: [SOLVED] Very slow startup followed by keyboard & mouse lagging

Post by deepakdeshp » Thu Nov 30, 2017 9:15 am

Now 18.3is available too for Cinnamon
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Other topics”