Linux Mint 18 Touchpad not working

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
harshad2592
Level 1
Level 1
Posts: 1
Joined: Sun Jan 28, 2018 11:24 am

Linux Mint 18 Touchpad not working

Post by harshad2592 » Sun Jan 28, 2018 11:30 am

i am using linux mint 18 (dell inspiron 15 3521)
My touchpad not working
I tried every solution from internet
when I check input devices using xinput -list

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ MOSART Semi. 2.4G Wireless Mouse id=9 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ Laptop_Integrated_Webcam_HD id=10 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
↳ Dell WMI hotkeys id=12 [slave keyboard (3)]

Can someone please help me solve this problem

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 288
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Linux Mint 18 Touchpad not working

Post by Joe2Shoe » Sun Jan 28, 2018 12:06 pm

Maybe this will help. Found this solution from Arch Linux Forum:
https://bbs.archlinux.org/viewtopic.php?id=148115

To get the touchpad working, append:
"i8042.notimeout i8042.nomux" to the kernel boot parameters of /etc/default/grub

1. Edit GRUB:
sudo gedit /etc/default/grub

2. Locate this line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

3. Extend the line with adding the kernel boot parameter:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.notimeout i8042.nomux"

4. Update GRUB:
sudo update-grub

5. Reboot the system.

Good luck.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

Post Reply

Return to “Other topics”