Linux changes my computer clock

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
judgedredd007
Level 1
Level 1
Posts: 3
Joined: Sun Dec 24, 2017 7:19 pm

Linux changes my computer clock

Post by judgedredd007 » Sat Feb 10, 2018 9:27 pm

I have a quad boot system (Windows XP, Linux Mint 18.1, Knoppix 8.1, Spinrite 6.0) and I have noticed that when I boot into Linux Mint from the grub menu, after hibernating Windows XP (I use XP 99% of the time), the Linux OS messes up the laptop's bios clock/computer clock but it does it in a very strange way.

When in Linux the clock in the bottom right corner has the correct time but when I then reboot the computer and restart Windows (coming out from hibernation mode) the clock in Windows has to be changed back because it shows London, GMT, time. When I change it it changes back after a while. So I then have to do a restart and go into the BIOS where I see the BIOS clock is on London, GMT, time.

I change it back to my local time, EST, and continue to boot into Windows via the grub menu.

While the clock is now fixed my Outlook express messages that come in still show London, GMT, time.

What the hell is going on? And what can I do about it?

By the way, this problem of the BIOS clock being changed happens every time I boot in Linux Mint. Also, I never had this problem before installing Linux Mint so it is a Linux Mint problem not a Windows problem.

The laptop is a Toshiba M70-337 1.7GHz, 2GB RAM, 1TB hard drive (with 6 partitions) and Windows XP SP3.

User avatar
MintBean
Level 9
Level 9
Posts: 2955
Joined: Fri Aug 07, 2015 6:54 am
Location: Blighty

Re: Linux changes my computer clock

Post by MintBean » Sat Feb 10, 2018 10:00 pm

It's no more a Linux problem than it's a Windows problem. They just work differently and that causes a conflict.
https://www.howtogeek.com/323390/how-to ... l-booting/

User avatar
Pierre
Level 17
Level 17
Posts: 7293
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Linux changes my computer clock

Post by Pierre » Sat Feb 10, 2018 11:45 pm

this is a fairly common problem, when multi-booting PCs.
:(
you can attempt to determine which system is causing this error,
and fix the issue as per the above post.

or, you can simply check that both systems are Internet Time Enabled:
ie: that the system will check itself against the Internet Time Clock,
& within a short time, after being booted up - - usually with 90s as a rule.
the system should then display the correct time in the clock area.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

User avatar
trytip
Level 8
Level 8
Posts: 2058
Joined: Tue Jul 05, 2016 1:20 pm

Re: Linux changes my computer clock

Post by trytip » Sun Feb 11, 2018 12:34 am

change it to local time
timedatectl status
timedatectl set-local-rtc 1
reboot
if things don't work out you can undo with timedatectl set-local-rtc 0
Image

User avatar
tenfoot
Level 5
Level 5
Posts: 894
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Re: Linux changes my computer clock

Post by tenfoot » Sun Feb 11, 2018 1:45 am

I notice the OP writes
When in Linux the clock in the bottom right corner has the correct time but when I then reboot the computer and restart Windows (coming out from hibernation mode) the clock in Windows has to be changed back because it shows London, GMT, time. When I change it it changes back after a while. So I then have to do a restart and go into the BIOS where I see the BIOS clock is on London, GMT, time.
and in my ignorance wonder whether he first of all closed Windows down completely before booting into Linux Mint and whether this would make a difference.
tenfoot
Death does not send a letter giving three week' notice. It arrives when you are eating raspberry sweets (Lars Mytting - The Sixteen Trees od the Somme)

Post Reply

Return to “Other topics”