Black screen at boot after editing fstab

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
LMJ
Level 3
Level 3
Posts: 126
Joined: Tue Aug 11, 2015 6:00 am

Black screen at boot after editing fstab

Post by LMJ » Sun Feb 25, 2018 2:56 am

Hello, I had a go at editing fstab, doing my best to follow along with instructions I was given a couple of years ago, but for a different configuration. Sadly, although I did copy and paste the completed fstab onto a document, so I could paste it here if anything went wrong, I seem to have saved it in my Mint drive, and not an external drive :( - so it is inaccessible right now. The next time I tried to boot into Mint 18.3, I just got a black screen and an error message, which I will transcribe below.
I haven't got a clue where to go from here, I don't know enough to make a good choice from options given in error message, so would like step by step beginner style instructions, as I haven't been in this situation before.

My Mint OS is on an external flash drive, which I boot into a Windows machine.

Obviously, a screenshot was impossible. My camera failed to capture image in light available, so here is what error message said -

""5.35586 sd 1:0:0:0: (sdc)No caching page mode found
5.355947 sd 1:0:0:0: (sdc) assuming drive cache:write through
Welcome to emergency mode! After logging in type journactl -xb to view system logs, systemctl to reboot, systemctl default or ^D to try again to boot into default mode (or press Control -D to continue)""

sdc is a small flash drive that I edited its fstab line not to automount. It's not part of my Mint Drive.
I didn't change anything in relation to the vital partitions of my Mint OS. I was helped to create a data partition separate from /home a couple of weeks ago, and I edited the data partiton line in fstab so as not to automount

Thanks in advance for your help
Linux mint is my first experience with Linux, am escaping Windows, Dual booting Mint Cinnamon 18.3 64bit with Win 7 Home Premium .AMD E-350 Processor (2 CPUs),1.6GHz, 4096MB RAM,DirectX 11, AMD Radeon HD 6310 Graphics, Realtek High Definition Audio.

User avatar
catweazel
Level 14
Level 14
Posts: 5449
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Black screen at boot after editing fstab

Post by catweazel » Sun Feb 25, 2018 3:13 am

LMJ wrote:
Sun Feb 25, 2018 2:56 am
I haven't got a clue where to go from here
When you get to the blank screen, press ctrl+alt+F1 then use sudo nano /etc/fstab. Undo your changes then ctrl+o <enter> to save, and ctrl-x to exit.
A new scientific truth does not triumph by convincing its opponents and making them see the light, but rather because its opponents eventually die, and a new generation grows up that is familiar with it. - Max Planck

LMJ
Level 3
Level 3
Posts: 126
Joined: Tue Aug 11, 2015 6:00 am

Re: Black screen at boot after editing fstab

Post by LMJ » Sun Feb 25, 2018 11:05 pm

When you get to the blank screen, press ctrl+alt+F1 then use sudo nano /etc/fstab. Undo your changes then ctrl+o <enter> to save, and ctrl-x to exit.
Well, that saved my bacon! Thank you very much :D I probably looked like your Catweazle pic when it went wrong:-) Please would you help me to edit the fstab correctly? I didn't manage to find the pasted copy I had made of the fstab that caused the problem, which I regret as it means I can't be shown the mistake I made. Below is a current fstab showing all the drives I was trying to prevent from automounting. They are marked with ******. Ones that I wanted to have mnt/Windows mount points, I also marked with WW (I think mnt/Windows is a correct mount point? I just don't want them to show up at all).

Partition list prior to automount edit
paxl@Hello ~ $ sudo parted -l && sudo blkid -o list
[sudo] password for paxl128:
Model: ATA ST9500325AS (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 107GB 107GB primary ntfs boot
2 107GB 123GB 16.1GB primary fat32 hidden
3 123GB 500GB 377GB primary ntfs
4 500GB 500GB 16.8MB primary esp


Model: SanDisk ExtremePro (scsi)
Disk /dev/sdb: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 30.0GB 30.0GB primary ext4 boot
2 30.0GB 82.5GB 52.5GB primary ext4
4 82.5GB 123GB 40.5GB primary ext4
3 123GB 128GB 5000MB primary linux-swap(v1)


Model: TOSHIBA TOSHIBA USB DRV (scsi)
Disk /dev/sdc: 7748MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 7748MB 7747MB primary fat32 boot


Model: WD My Passport 0830 (scsi)
Disk /dev/sdd: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 440GB 440GB primary ntfs
2 440GB 1000GB 560GB extended lba
6 440GB 786GB 346GB logical ntfs
5 786GB 1000GB 214GB logical ext4


Model: Multiple Card Reader (scsi)
Disk /dev/sde: 7948MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 7948MB 7947MB primary fat32 boot, lba


device fs_type label mount point UUID
-------------------------------------------------------------------------------
/dev/sda1 ntfs (not mounted) EED8FE1ED8FDE4AD ******WWW
/dev/sda2 vfat (not mounted) BAA8-00B0 ****** I'm not sure about this one, it's the Windows recovery image I think, or for hibernation, and I don't think it ever shows up in Mint
/dev/sda3 ntfs DDrive (not mounted) DAE69349E6932533 ******WWW
/dev/sdb1 ext4 / 7e2767c2-c84d-4d6b-965a-6f61b932fc4a
/dev/sdb2 ext4 /home 68f31ae3-063f-4c06-9785-613c93f79c98
/dev/sdb3 swap [SWAP] c6b9633d-21bf-4bc1-afc6-250a023643e3
/dev/sdb4 ext4 Data /home/paxl128/Data 1553ee04-af73-493a-be2b-28e6b4ded352 ********
/dev/sda4 (not mounted)
/dev/sdc1 vfat 8GB TOSHYEL /media/paxl128/8GB TOSHYEL 30EB-98E0 **********
/dev/sde1 vfat 8GBMICRO /media/paxl128/8GBMICRO 8018-12D6 ************
/dev/sdd1 ntfs NTFSBlue (not mounted) 01D0F98195B922A0 ***** WW
/dev/sdd5 ext4 MintExtBlue (not mounted) e77bbd14-ebff-d001-a06b-bd14ebffd001 **********
/dev/sdd6 ntfs Blue2ntfs (not mounted) 17250F6805332865 *******WW
paxl@Hello ~ $
Linux mint is my first experience with Linux, am escaping Windows, Dual booting Mint Cinnamon 18.3 64bit with Win 7 Home Premium .AMD E-350 Processor (2 CPUs),1.6GHz, 4096MB RAM,DirectX 11, AMD Radeon HD 6310 Graphics, Realtek High Definition Audio.

User avatar
catweazel
Level 14
Level 14
Posts: 5449
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Black screen at boot after editing fstab

Post by catweazel » Mon Feb 26, 2018 1:36 am

LMJ wrote:
Sun Feb 25, 2018 11:05 pm
Well, that saved my bacon! Thank you very much :D
You're most welcome.
Below is a current fstab showing all the drives I was trying to prevent from automounting.
I didn't see an fstab there at all. When posting the output of this terminal command, please enclose the results in code markers "</>", which you can select from the mini toolbar above the textbox where you type your reply, otherwise it's impossible to read.

Now, to deal with trying to prevent drives from automounting. Perhaps you're mistaking what automount is with unmounted devices showing up in your file manager. No fixed hard drive will automount unless it's specified in fstab so there's no need to edit fstab to prevent them mounting. That however doesn't mean the drives won't show up in your file manager so that you can click on them and mount them. Also, the same doesn't necessarily apply to USB flash drives, for example, because your system may be setup to automount removable drives.

So, based on that, can you please clarify what you mean by 'prevent from automounting'?
A new scientific truth does not triumph by convincing its opponents and making them see the light, but rather because its opponents eventually die, and a new generation grows up that is familiar with it. - Max Planck

LMJ
Level 3
Level 3
Posts: 126
Joined: Tue Aug 11, 2015 6:00 am

Re: Black screen at boot after editing fstab

Post by LMJ » Tue Feb 27, 2018 4:44 am

I didn't see an fstab there at all. When posting the output of this terminal command, please enclose the results in code markers "</>", which you can select from the mini toolbar above the textbox where you type your reply, otherwise it's impossible to read.
I hope the freshly copied terminal readout, and fstab I have pasted in below - hopefully correctly this time - are helpful.
can you please clarify what you mean by 'prevent from automounting'?
1) In Nemo, the option to ''automount removeable media when inserted and on startup'', is not selected. Yet Windows CDrive does automount on startup. (If I right click on the desktop icon, the option to unmount/eject is there). I would like to edit fstab so it does not automount at all.
At startup, icons for thumb drives connected, are present on the desktop. Right click on these gives the option to eject safely. As Fstab shows that they are not mounted, you are right in guessing that I was mistaking their visibilty for a sign they were automounting.
2)I don't want any windows drives to be visible/accessible to Mint - Neither ''CDrive' nor 'DDrive'
3) I have an external back up drive with 3 partitions. NTFSBlue, Bluentfs, and MintExtBlue. When it's plugged in I don't want the two NTFS partitons to be visible or accessible to Mint (give them Windows mount points ?) MintExtBlue is where my Mint back ups get saved, and I don't want this to automount.

I hope it's clearer now what help I am asking for. Thank you :)

This is what the Fstab currently looks like -

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdc1 during installation
UUID=7e2767c2-c84d-4d6b-965a-6f61b932fc4a /               ext4    errors=remount-ro 0       1
# /home was on /dev/sdc2 during installation
UUID=68f31ae3-063f-4c06-9785-613c93f79c98 /home           ext4    defaults        0       2
# swap was on /dev/sdc3 during installation
UUID=c6b9633d-21bf-4bc1-afc6-250a023643e3 none            swap    sw              0       0
UUID=1553ee04-af73-493a-be2b-28e6b4ded352 /home/paxl128/Data ext4 defaults,noatime 0     3

 - -And a fresh copy of terminal readout -      
 

Code: Select all

paxl@Hello ~ $ sudo parted -l && sudo blkid -o list
[sudo] password for paxl: 
Model: ATA ST9500325AS (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type     File system  Flags
 1      1049kB  107GB  107GB   primary  ntfs         boot
 2      107GB   123GB  16.1GB  primary  fat32        hidden
 3      123GB   500GB  377GB   primary  ntfs
 4      500GB   500GB  16.8MB  primary               esp


Model: SanDisk ExtremePro (scsi)
Disk /dev/sdb: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system     Flags
 1      1049kB  30.0GB  30.0GB  primary  ext4            boot
 2      30.0GB  82.5GB  52.5GB  primary  ext4
 4      82.5GB  123GB   40.5GB  primary  ext4
 3      123GB   128GB   5000MB  primary  linux-swap(v1)


Model: Multiple Card Reader (scsi)
Disk /dev/sdc: 7948MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  7948MB  7947MB  primary  fat32        boot, lba


Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sdd: 8003MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      16.4kB  8003MB  8003MB  primary  ntfs


device     fs_type label    mount point    UUID
-------------------------------------------------------------------------------
/dev/sda1  ntfs             /media/paxl128/EED8FE1ED8FDE4AD EED8FE1ED8FDE4AD
/dev/sda2  vfat             (not mounted)  BAA8-00B0
/dev/sda3  ntfs    DDrive   (not mounted)  DAE69349E6932533
/dev/sdb1  ext4             /              7e2767c2-c84d-4d6b-965a-6f61b932fc4a
/dev/sdb2  ext4             /home          68f31ae3-063f-4c06-9785-613c93f79c98
/dev/sdb3  swap             [SWAP]         c6b9633d-21bf-4bc1-afc6-250a023643e3
/dev/sdb4  ext4    Data     /home/paxl128/Data 1553ee04-af73-493a-be2b-28e6b4ded352
/dev/sdd1  ntfs    SANBLUE8GB (not mounted) 01D208B14A5D0750
/dev/sdc1  vfat    8GBMICRO /media/paxl128/8GBMICRO1 8018-12D6
/dev/sda4                   (not mounted)  
paxl@Hello ~ $ 
Linux mint is my first experience with Linux, am escaping Windows, Dual booting Mint Cinnamon 18.3 64bit with Win 7 Home Premium .AMD E-350 Processor (2 CPUs),1.6GHz, 4096MB RAM,DirectX 11, AMD Radeon HD 6310 Graphics, Realtek High Definition Audio.

Post Reply

Return to “Other topics”