BUG(?) "the specified directory is invalid" when it is not!

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
zezin
Level 1
Level 1
Posts: 5
Joined: Sun Feb 25, 2018 12:47 pm

BUG(?) "the specified directory is invalid" when it is not!

Post by zezin » Sun Feb 25, 2018 12:54 pm

Hello there!
I got a message that says "The specified directory is invalid." when i was trying to execute:
$mono tuxlol.exe patch --dir /home/series789/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot\ Games/League\ of\ Legends/.
It happens that the directory is actually real and i can go there manually, but the command doesnt appears to be able to reach it... Someone know's what is the issue with that? i would be very glad to solve this... :oops:
$inxi;
"CPU~Dual core Intel Core i5-2450M (-HT-MCP-) speed/max~811/3100 MHz Kernel~4.4.0-116-generic i686 Up~1:43 Mem~1104.9/5880.7MB HDD~500.1GB(20.4% used) Procs~197 Client~Shell inxi~2.2.35"

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 331
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: BUG(?) "the specified directory is invalid" when it is not!

Post by Joe2Shoe » Sun Feb 25, 2018 1:09 pm

Try removing this part: " --dir " in the pathway.
tuxlol.exe patch /home/series789/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot\ Games/League\ of\ Legends/
Worth a shot.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

zezin
Level 1
Level 1
Posts: 5
Joined: Sun Feb 25, 2018 12:47 pm

Re: BUG(?) "the specified directory is invalid" when it is not!

Post by zezin » Sun Feb 25, 2018 3:47 pm

Didnt work, the tuxlol software expect "patch" and "--dir", it doesnt run without it.

User avatar
WharfRat
Level 20
Level 20
Posts: 11464
Joined: Thu Apr 07, 2011 8:15 pm

Re: BUG(?) "the specified directory is invalid" when it is not!

Post by WharfRat » Sun Feb 25, 2018 4:14 pm

Shouldn't it be patch -d /home/series789/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot\ Games/League\ of\ Legends/

or patch --directory=/home/series789/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot\ Games/League\ of\ Legends/ :?:
ImageImage

zezin
Level 1
Level 1
Posts: 5
Joined: Sun Feb 25, 2018 12:47 pm

Re: BUG(?) "the specified directory is invalid" when it is not!

Post by zezin » Sun Feb 25, 2018 5:52 pm

WharfRat wrote:
Sun Feb 25, 2018 4:14 pm
Shouldn't it be patch -d /home/series789/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot\ Games/League\ of\ Legends/

or patch --directory=/home/series789/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot\ Games/League\ of\ Legends/ :?:
I tried and it also didnt work, not at all. But thanks, bro!

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 331
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: BUG(?) "the specified directory is invalid" when it is not!

Post by Joe2Shoe » Sun Feb 25, 2018 6:00 pm

Seems to me that the path you specified is not correct. Follow the path to "drive_c/Riot\ Games/League\ of\ Legends/", then right-click that folder, then copy the exact location and paste it into your original path. Sometimes, paths can be tricky.
Good luck.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

User avatar
MrEen
Level 6
Level 6
Posts: 1350
Joined: Mon Jun 12, 2017 8:39 pm

Re: BUG(?) "the specified directory is invalid" when it is not!

Post by MrEen » Sun Feb 25, 2018 6:27 pm

Did you first cd to the tuxlol dir?

zezin
Level 1
Level 1
Posts: 5
Joined: Sun Feb 25, 2018 12:47 pm

Re: BUG(?) "the specified directory is invalid" when it is not!

Post by zezin » Sun Feb 25, 2018 6:36 pm

Joe2Shoe wrote:
Sun Feb 25, 2018 6:00 pm
Seems to me that the path you specified is not correct. Follow the path to "drive_c/Riot\ Games/League\ of\ Legends/", then right-click that folder, then copy the exact location and paste it into your original path. Sometimes, paths can be tricky.
Good luck.
I already did it, but i tried again just to be sure and it doesnt change anything hahaha but thanks bro!
Last edited by zezin on Sun Feb 25, 2018 6:38 pm, edited 1 time in total.

zezin
Level 1
Level 1
Posts: 5
Joined: Sun Feb 25, 2018 12:47 pm

Re: BUG(?) "the specified directory is invalid" when it is not!

Post by zezin » Sun Feb 25, 2018 6:37 pm

MrEen wrote:
Sun Feb 25, 2018 6:27 pm
Did you first cd to the tuxlol dir?
i did it.

Post Reply

Return to “Other topics”