libqtwebkit-dev_2.3.2_0ubuntu11 missing from repository [SOLVED by upgrading to 18.3]

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
jw jensen
Level 1
Level 1
Posts: 20
Joined: Tue Feb 27, 2018 3:06 am

libqtwebkit-dev_2.3.2_0ubuntu11 missing from repository [SOLVED by upgrading to 18.3]

Post by jw jensen » Tue Feb 27, 2018 5:28 pm

I understand that Debian is trying to phase out QtWebKit, and is doing so by (first) making the development files unavailable. The author of the DebianWiki on this subject, states that developers should migrate to Qt5 to continue using QtWebKit. There is a note on the Ubuntu web site stating that some maintainer removed the -dev files from the Ubuntu repository as requested.

Unfortunately, I have 60,000 - 80,000 lines of code (which I authored and maintain alone), depending on Qt4, and some of it depending on QtWebkit for displaying help from local html files. About 50,000 are in active sourceforge projects.

Please take steps to put the QtWebKit-dev package back in the Mint/Ubuntu repository, and ensure that QtWebKit is supported by Mint as long as Qt4 is distributed by Mint. I would like to migrate to Qt5 at my own pace and for my own reasons.
Last edited by jw jensen on Sat Mar 17, 2018 8:49 pm, edited 2 times in total.

User avatar
phd21
Level 16
Level 16
Posts: 6217
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: libqtwebkit-dev_2.3.2_0ubuntu11 missing from repository

Post by phd21 » Tue Feb 27, 2018 10:51 pm

Hi "jw jensen"

Can't you install the full QT Development environments (Qt4 and QT5) from their website?


Linux Mint 18.x - libqtwebkit-dev 2.3.2-0ubuntu11 (amd64 binary) in ubuntu xenial
http://launchpadlibrarian.net/227986888 ... _amd64.deb

Linux Mint 17.x -
http://archive.ubuntu.com/ubuntu/pool/m ... _amd64.deb

libqtwebkit-dev_2.3.2 - Google Search
https://www.google.com/search?q=libqtwe ... e&ie=UTF-8


Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

jw jensen
Level 1
Level 1
Posts: 20
Joined: Tue Feb 27, 2018 3:06 am

Re: libqtwebkit-dev_2.3.2_0ubuntu11 missing from repository

Post by jw jensen » Tue Feb 27, 2018 11:08 pm

jw jensen wrote:
Tue Feb 27, 2018 5:28 pm
I understand that Debian is trying to phase out QtWebKit, and is doing so by (first) making the development files unavailable. The author of the DebianWiki on this subject, states that developers should migrate to Qt5 to continue using QtWebKit. There is a note on the Ubuntu web site stating that some maintainer removed the -dev files from the Ubuntu repository as requested.

Unfortunately, I have 60,000 - 80,000 lines of code (which I authored and maintain alone), depending on Qt4, and some of it depending on QtWebkit for displaying help from local html files. About 50,000 are in active sourceforge projects.

Please take steps to put the QtWebKit-dev package back in the Mint/Ubuntu repository, and ensure that QtWebKit is supported by Mint as long as Qt4 is distributed by Mint. I would like to migrate to Qt5 at my own pace and for my own reasons.
Thanks very much for the kind response. Yes, I can and have. Works great. There is only one problem: the qt.io web site seems to provide 4.8.6 (not sure, still investigating), but the ubuntu/mint repositories provide 4.8.7. Maybe somebody at Debian/Ubuntu/Mint is making enhancements? In fact the Debian repository actually has the required -dev stuff, and I've downloaded it. Besides the question about version, there is the issue that Debian and Ubuntu are both trying to get rid of QtWebKit (-dev only for now). I would like Mint, which still ships Qt4 with its Cinnamon distro, to continue with QtWebKit in their repositories as long as Qt4 is shipped.

altair4
Level 19
Level 19
Posts: 9028
Joined: Tue Feb 03, 2009 10:27 am

Re: libqtwebkit-dev_2.3.2_0ubuntu11 missing from repository

Post by altair4 » Wed Feb 28, 2018 3:42 pm

Please take steps to put the QtWebKit-dev package back in the Mint/Ubuntu repository, and ensure that QtWebKit is supported by Mint as long as Qt4 is distributed by Mint. I would like to migrate to Qt5 at my own pace and for my own reasons.
Um ... No one in this forum can make that happen. The people who could make that happen do not participate in this forum. This is not a Mint thing as it happens with Ubuntu and the forums of all the other distros.

If you have a bug or a feature request you need to go through the process and file it with the appropriate authority
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

jw jensen
Level 1
Level 1
Posts: 20
Joined: Tue Feb 27, 2018 3:06 am

Re: libqtwebkit-dev_2.3.2_0ubuntu11 missing from repository

Post by jw jensen » Wed Feb 28, 2018 4:13 pm

altair4 wrote:
Wed Feb 28, 2018 3:42 pm
Please take steps to put the QtWebKit-dev package back in the Mint/Ubuntu repository, and ensure that QtWebKit is supported by Mint as long as Qt4 is distributed by Mint. I would like to migrate to Qt5 at my own pace and for my own reasons.
Um ... No one in this forum can make that happen. The people who could make that happen do not participate in this forum. This is not a Mint thing as it happens with Ubuntu and the forums of all the other distros.

If you have a bug or a feature request you need to go through the process and file it with the appropriate authority
Thanks for the response. Mint directs me to these forums if I have a bug or other issue with Mint. Please explain what internal resources Mint has in the way of coders or influence with Debian or Ubuntu. Or is it just these forums. I had hoped that Mint might be able to advocate on my behalf as Mint user.

Please help by indicating generally what I can and can't reasonably expect from Mint and these forums.

User avatar
phd21
Level 16
Level 16
Posts: 6217
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: libqtwebkit-dev_2.3.2_0ubuntu11 missing from repository

Post by phd21 » Wed Feb 28, 2018 4:33 pm

Hi "jw jensen",

You are welcome...

As user "altair4" just stated, with certain software you have to contact whoever is maintaining that software to report a request or bugfix, etc... A lot of software that Mint provides through the Software Manager or Synaptic Package Manager (SPM) is from Ubuntu.

You never did say which edition and version of Linux Mint you are using, and if you were able to install "libqtwebkit-dev_2.3.2" so that you could continue to maintain your code base?
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

altair4
Level 19
Level 19
Posts: 9028
Joined: Tue Feb 03, 2009 10:27 am

Re: libqtwebkit-dev_2.3.2_0ubuntu11 missing from repository

Post by altair4 » Wed Feb 28, 2018 6:45 pm

Please explain what internal resources Mint has in the way of coders or influence with Debian or Ubuntu. Or is it just these forums. I had hoped that Mint might be able to advocate on my behalf as Mint user.
If it's a true bug or in this case a feature request whatever influence Mint may or may not have with upstream projects will not be instigated from this forum. Only from GitHub.

Mint starts with the Ubuntu repository then adds things to it so a request to add something new to it might very well fall under Mint's jurisdiction. Asking for it here will do you no good because the folks that can make it happen are not here,
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

User avatar
phd21
Level 16
Level 16
Posts: 6217
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: libqtwebkit-dev_2.3.2_0ubuntu11 missing from repository

Post by phd21 » Wed Feb 28, 2018 7:35 pm

Hi "jw jensen",

FYI: I have the full version of the QT 5.9 development system installed.

While I was helping out other forum members, I decided to run a virus scan on my system and "BitDefender" came up with this result below. This is a video file and does not seem to be a Linux virus or issue per se, but I thought I would bring it up to your attention.
Object '/home/user69/Qt5.9.0/5.9/Src/qtwebengine/src/3rdparty/chromium/third_party/afl/src/docs/vuln_samples/ffmpeg-h264-bad-ptr-800m.mp4' is infected with 'Exploit.CVE-2014-8438.Gen'
Adobe Flash Player up to 11.2.202.411/13.0.0.250/15.0.0.189 Use-After-Free memory corruption
https://vuldb.com/?id.68141


Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Post Reply

Return to “Other topics”