[Solved] Resume problems after suspend

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
Mithrandir
Level 2
Level 2
Posts: 77
Joined: Thu Jun 28, 2012 3:14 am

[Solved] Resume problems after suspend

Post by Mithrandir » Wed Mar 14, 2018 8:30 am

Hi,
I set kde to suspend the system when I close the lid. I never had problems, but in last days, when I reopen the lid, the system doesn't present the login screen as usually: it freezes in a black screen and I have to shutdown with the power button.
I have tested with the older 4.10.0-40 kernel, and the resume occurs without problems. So I believe that is a kernel update that causes the problem.
The problem occurs with the last kernels 4.13.xx, and I have to use the older kernel 4.10.0-40 to fix the problem. Can I fix it in the last kernels 4.13 or have I to use the older kernels? Generally newer kernels should have to work better...
I read other topics about this problem in the last month, but I have not found how fix it.
Thanks in advance,

Code: Select all

$ inxi -Fxz
System:    Host: debian Kernel: 4.10.0-40-generic x86_64 (64 bit gcc: 5.4.0) Desktop: KDE Plasma 5.8.9 (Qt 5.6.1)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: ASUSTeK (portable) product: UX303UB v: 1.0
           Mobo: ASUSTeK model: UX303UB v: 1.0 Bios: American Megatrends v: UX303UB.202 date: 08/27/2015
CPU:       Dual core Intel Core i7-6500U (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10368
           clock speeds: max: 3100 MHz 1: 800 MHz 2: 799 MHz 3: 799 MHz 4: 799 MHz
Graphics:  Card-1: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Card-2: NVIDIA GM108M [GeForce 940M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 driver: intel Resolution: 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.10.0-40-generic
Network:   Card: Intel Wireless 7265 driver: iwlwifi bus-ID: 02:00.0
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 256.1GB (62.5% used) ID-1: /dev/sda model: HFS256G32MND size: 256.1GB
Partition: ID-1: / size: 44G used: 19G (44%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 184G used: 124G (72%) fs: ext4 dev: /dev/sda3
           ID-3: swap-1 size: 8.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 32.5C mobo: N/A
           Fan Speeds (in rpm): cpu: 2300
Info:      Processes: 229 Uptime: 3:09 Memory: 1773.4/7877.9MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
Last edited by Mithrandir on Wed Mar 14, 2018 4:09 pm, edited 1 time in total.
Asus UX303UB - Ram 8GB - HD 256GB - Intel Core i7-6500U - Intel Sky Lake Integrated Graphics - NVIDIA GM108M [GeForce 940M] - Intel Wireless 7265
Linux Mint 18.3 Sylvia - Kde Plasma 5.8.9

Mithrandir
Level 2
Level 2
Posts: 77
Joined: Thu Jun 28, 2012 3:14 am

Re: Resume problems after suspend

Post by Mithrandir » Wed Mar 14, 2018 4:09 pm

I have to apologize for my topic. The problem depended from a corruption of the video card's driver.his driver
I have reinstalled this driver and now the resume occurs without problem with the newest kernels too.
Cheers =)
Asus UX303UB - Ram 8GB - HD 256GB - Intel Core i7-6500U - Intel Sky Lake Integrated Graphics - NVIDIA GM108M [GeForce 940M] - Intel Wireless 7265
Linux Mint 18.3 Sylvia - Kde Plasma 5.8.9

Post Reply

Return to “Other topics”