HDD Spindown (I can't solve it)

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
ripperle
Level 1
Level 1
Posts: 1
Joined: Thu May 10, 2018 1:13 pm

HDD Spindown (I can't solve it)

Post by ripperle » Thu May 10, 2018 2:05 pm

Hello,

I use my computer as a normal desktop pc and as a nas and home automation server. The system has 4 HDD drives for data storage (NAS) and one SSD for Linux mint...
The computer is a 24/7 system, so normally no user is logged in and only the demons running (like samba and home automation software).
If I want to do something with the pc, I just switch on the monitor and login my user. When I am finished I dont shut down the pc, I just log out the user and switch of the monitor.

Therefore i want to spin down all 4 HDDs after 10 minutes to safe Energy ...
It works almost fine with "hd-idle" (hdparm don't worked reliable). When I switch in the computer and don't log in, all HDDs spin down after 10 Minutes. If I read or write data from a remote system through the samba deamon, the hdd spin up and after file handling it will spin down with 10 minutes delay...

BUT ONE THING DON'T WORK AND DRIVES ME CRAZY :wink:

When I log in with my. User all hdd spin up and sometimes one or 2 HDDs don't spin down anymore. Even if I log out...
I can force the hdd to spin down with hdparm -Y /dev/sdd, but sometimes it spins up again after some minutes...
Workaround at this point: Reboot the system and don't log in again...

So here are my questions:
1. Why the HDDs spin up when I log in? They do not spin up when I log in with bash command line (no cinnamon)
2. What is the best way to detect, which process is spinning up the hdd... I already tried inotify tool without success (https://unix.stackexchange.com/question ... -harddrive)

Can somebody help me? Please keep it as simple as possible, because I am a Linux rookie :?

Thanks,
ripperle

Code: Select all

System:    Host: Server Kernel: 4.4.0-124-generic x86_64 (64 bit gcc: 5.4.0)
           Console: tty 0 Distro: Linux Mint 18.1 Serena
Machine:   Mobo: ASUSTeK model: H170I-PRO v: Rev X.0x
           Bios: American Megatrends v: 3401 date: 03/16/2017
CPU:       Dual core Intel Pentium G4560 (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 14015
           clock speeds: max: 3500 MHz 1: 799 MHz 2: 799 MHz 3: 838 MHz 4: 799 MHz
Graphics:  Card: Intel Device 5902 bus-ID: 00:02.0
           Display Server: X.org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           tty size: 84x41 Advanced Data: N/A out of X
Network:   Card-1: Intel Ethernet Connection (2) I219-V
           driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: down mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-3: Atmel AT91SAM CDC Demo Application usb-ID: 001-004
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 11130.2GB (40.5% used)
           ID-1: /dev/sda model: TS128GMTS800 size: 128.0GB
           ID-2: /dev/sdb model: ST2000DM001 size: 2000.4GB
           ID-3: /dev/sdc model: WDC_WD30EZRX size: 3000.6GB
           ID-4: /dev/sdd model: ST2000DL003 size: 2000.4GB
           ID-5: /dev/sde model: ST4000DM000 size: 4000.8GB
Partition: ID-1: / size: 110G used: 17G (16%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 8.46GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 156 Uptime: 52 min Memory: 556.2/7855.9MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

Post Reply

Return to “Other topics”