LM 19 - notify-send not working via crontab

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
ttjimera
Level 1
Level 1
Posts: 31
Joined: Fri Jun 27, 2014 8:47 pm

LM 19 - notify-send not working via crontab

Post by ttjimera » Sun Jul 08, 2018 9:20 pm

I have a script that runs as a crontab job at a fixed interval. It monitors for certain events on the system and when triggered will use notify-send to notify me. The code for this is as follows:

Code: Select all

export DISPLAY=:0 && notify-send --urgency=normal "Event message here" 
This used to work perfectly in LM18.*. But since migrating to LM19 I am no longer getting notification when the event triggered. However, if I run the script manually from a terminal I can still get the notification.

Anybody have any idea what is going on here? According to https://blog.linuxmint.com/?p=3557 there is some changes made to the notification system for Cinnamon 3.8. But I am not sure if this is the source of the problem here. Would appreciate any pointer from anybody here. Thanks

ttjimera
Level 1
Level 1
Posts: 31
Joined: Fri Jun 27, 2014 8:47 pm

Re: LM 19 - notify-send not working via crontab

Post by ttjimera » Sun Jul 08, 2018 10:27 pm

I forgot to mention that I have also tried to redirect stderr from the command above into a file to see if there are any errors. But there was none.

Post Reply

Return to “Other topics”