LM 19 - Can't install libncurses5-dev [SOLVED]

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
gonquin
Level 1
Level 1
Posts: 2
Joined: Mon Jul 09, 2018 6:31 am

LM 19 - Can't install libncurses5-dev [SOLVED]

Post by gonquin » Mon Jul 09, 2018 6:40 am

  • Fresh install of Linux Mint 19
  • Installed build-essential and enabled Sources
When I try to install libncurses5-dev I get the following messages:

Code: Select all

libncurses5-dev:
  Depends: libtinfo5 (=6.1-1ubuntu1) but 6.1-1ubuntu1.18.04 is to be installed
  Depends: libncurses5 (=6.1-1ubuntu1) but 6.1-1ubuntu1.18.04 is to be installed
 Depends: libtinfo-dev but it is not going to be installed
What's the problem here?
Last edited by gonquin on Tue Jul 10, 2018 6:05 am, edited 1 time in total.

gonquin
Level 1
Level 1
Posts: 2
Joined: Mon Jul 09, 2018 6:31 am

Re: LM 19 - Can't install libncurses5-dev

Post by gonquin » Tue Jul 10, 2018 6:03 am

After some updates:

Code: Select all

libncurses5 will be downgraded
libncursesw5 will be downgraded
libtinfo5 will be downgraded
libncurses5-dev (version 6.1-1ubuntu1) will be installed
libtinfo-dev (version 6.1-1ubuntu1) will be installed
Downgraded and installed.

I needed the libraries to compile from source calcurse 4.3.0 which works now!

Post Reply

Return to “Other topics”