Samba will not start in Mint 19

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
pinnerite
Level 1
Level 1
Posts: 20
Joined: Fri Dec 28, 2012 9:19 am

Samba will not start in Mint 19

Post by pinnerite » Thu Jul 12, 2018 3:50 am

Since installing Mint 19 over a week ago I have been struggling to get Samba to start.

# systemctl status smbd reports:

Status: "smbd: ready to serve connections..."
Tasks: 4 (limit: 4915)
CGroup: /system.slice/smbd.service
├─1288 /usr/sbin/smbd --foreground --no-process-group
├─1296 /usr/sbin/smbd --foreground --no-process-group
├─1297 /usr/sbin/smbd --foreground --no-process-group
└─1317 /usr/sbin/smbd --foreground --no-process-group

Jul 12 08:08:25 albury.asandco smbd[7188]: [2018/07/12 08:08:25.316265, 0] ../source3/auth/user_util.c:371(map_username)
Jul 12 08:08:25 albury.asandco smbd[7188]: can't open username map /etc/samba/smbusers. Error No such file or directory
Jul 12 08:08:26 albury.asandco smbd[7188]: [2018/07/12 08:08:26.426379, 0] ../source3/auth/user_util.c:371(map_username)
Jul 12 08:08:26 albury.asandco smbd[7188]: can't open username map /etc/samba/smbusers. Error No such file or directory
Jul 12 08:08:26 albury.asandco smbd[7188]: [2018/07/12 08:08:26.431544, 0] ../source3/auth/user_util.c:371(map_username)
Jul 12 08:08:26 albury.asandco smbd[7188]: can't open username map /etc/samba/smbusers. Error No such file or directory
Jul 12 08:09:17 albury.asandco smbd[7288]: [2018/07/12 08:09:17.119678, 0] ../source3/auth/user_util.c:371(map_username)
Jul 12 08:09:17 albury.asandco smbd[7288]: can't open username map /etc/samba/smbusers. Error No such file or directory

Which is true, there isn't one. I have run smbpasswd (again) but that makes no difference.

This is part of my current samba.conf (just globals and one share):

Code: Select all

[global]
    workgroup =AGROUP
    netbios name = ATLAS
    
    #  default is security = user
    
    server string = %h
    map to guest = Bad User
    log file = /var/log/samba/%m.log
    max log size = 50
    printcap cache time = 60
    printcap name = cups
    dns proxy = No
    guest ok = Yes
    encrypt passwords = yes
    smb passwd file = /etc/samba/smbpasswd
    
    name resolve order = lmhosts bcast host wins
      
    # The following two lines were added 7 Jan 2016
    
    force user = alan
    force group = alan
    
    preferred master = no
    domain master = no
    local master = no


[alan]
    comment = Alan's service
    path = /home/alan
    valid users = alan
    admin users = alan
    read only = No

This computer uses caddies so the drives can be unplugged. When plugged in, a Mageia 5 system on a second drive (which Mint was intended to replace) works perfectly well!

I am baffled.

altair4
Level 19
Level 19
Posts: 9226
Joined: Tue Feb 03, 2009 10:27 am

Re: Samba will not start in Mint 19

Post by altair4 » Thu Jul 12, 2018 7:03 am

Why not just reset your smb.conf to the factory fresh settings and add only your [alan] share definition at the end of it?

You can find a copy of the default smb.conf here: /usr/share/samba/smb.conf
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

pinnerite
Level 1
Level 1
Posts: 20
Joined: Fri Dec 28, 2012 9:19 am

Re: Samba will not start in Mint 19

Post by pinnerite » Sat Jul 14, 2018 3:55 pm

I have tried that and reinstalled samba fro the command line this time.
Windows 10 will now come up (Under VMware Player) and can access the shares.
Windows XP cannot.

Post Reply

Return to “Other topics”