Mint 18.2 (and now 19) is having several problems, for no apparent reason...

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
vladtepes
Level 3
Level 3
Posts: 169
Joined: Sat Feb 25, 2012 7:48 am
Location: Brisbane, Australia
Contact:

Mint 18.2 (and now 19) is having several problems, for no apparent reason...

Post by vladtepes » Fri Jul 20, 2018 6:09 am

I'll preface this by saying I've been away from the Linux world for some time (and was only a raw beginner previously) so stupid questions may be forthcoming.

I did have Mint 18.2 Cinnamon up and running fine - wireless worked (connected no problems).

Well I've moved the computer to the next room, and now it's not connecting to wireless at all. (and I have no wired connection there). My cell phone can get wireless there though.

But that's not the only problem.

If I click on either of my two SATA drives it tells me that it is unable to mount the drive?

Ahh I'm so confused and would really appreciate any advice or guidance that people are able to offer.

Thank you so much.

Code: Select all

michael@Minty ~ $ inxi -Fxz
System:    Host: Minty Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.3 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   System: Gigabyte product: H87-D3H
           Mobo: Gigabyte model: H87-D3H-CF v: x.x
           Bios: American Megatrends v: F5 date: 08/03/2013
CPU:       Quad core Intel Core i7-4770 (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27137
           clock speeds: max: 3900 MHz 1: 3102 MHz 2: 3894 MHz 3: 3899 MHz
           4: 3743 MHz 5: 3891 MHz 6: 3270 MHz 7: 3702 MHz 8: 2931 MHz
Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1680x1050@59.95hz
           GLX Renderer: Mesa DRI Intel Haswell Desktop
           GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network:   Card: Intel Ethernet Connection I217-V
           driver: e1000e v: 3.2.6-k port: f080 bus-ID: 00:19.0
           IF: eno1 state: down mac: <filter>
Drives:    HDD Total Size: 5251.1GB (0.7% used)
           ID-1: /dev/sda model: ST3000DM001 size: 3000.6GB
           ID-2: /dev/sdb model: Samsung_SSD_840 size: 250.1GB
           ID-3: /dev/sdc model: WDC_WD20EZRX size: 2000.4GB
Partition: ID-1: / size: 198G used: 6.0G (4%) fs: ext4 dev: /dev/sdb2
           ID-2: swap-1 size: 34.23GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 229 Uptime: 17 min Memory: 614.8/32055.5MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
michael@Minty ~ $ 
Last edited by vladtepes on Sat Jul 21, 2018 9:39 am, edited 2 times in total.
Keep Calm
and
Impale Your Enemies

User avatar
michael louwe
Level 9
Level 9
Posts: 2784
Joined: Sun Sep 11, 2016 11:18 pm

Re: My Mint 18.2 is having several problems, for no apparent reason...

Post by michael louwe » Fri Jul 20, 2018 6:19 am

vladtepes wrote:.
.
For the Wifi problem, try different positions for your desktop computer. Check the connection of the Wifi adapter card and SATA drives which may have been dislocated by the move from one room to another.

Use the Live LM USB/DVD to post the inxi results, ie copy the results to a USB-stick.
Can you mount the drives with the Live LM USB/DVD.?

vladtepes
Level 3
Level 3
Posts: 169
Joined: Sat Feb 25, 2012 7:48 am
Location: Brisbane, Australia
Contact:

Re: My Mint 18.2 is having several problems, for no apparent reason...

Post by vladtepes » Fri Jul 20, 2018 6:47 am

* Vlad scrambles around looking for USB stick with live version on it *
Keep Calm
and
Impale Your Enemies

vladtepes
Level 3
Level 3
Posts: 169
Joined: Sat Feb 25, 2012 7:48 am
Location: Brisbane, Australia
Contact:

Re: My Mint 18.2 is having several problems, for no apparent reason...

Post by vladtepes » Fri Jul 20, 2018 7:07 am

Trying to boot from the 18.2 USB it comes up with errors including can not mount /de/loop0 ... on //filesystem.squashfs

?
Keep Calm
and
Impale Your Enemies

vladtepes
Level 3
Level 3
Posts: 169
Joined: Sat Feb 25, 2012 7:48 am
Location: Brisbane, Australia
Contact:

Re: My Mint 18.2 is having several problems, for no apparent reason...

Post by vladtepes » Fri Jul 20, 2018 9:56 am

OK so I have tried booting into Mint 19 Tara which works BUT it still doesn't recognise the wifi AT ALL (so it's not even looking for a network apparently), and nor can it mount the HDD's.

SATA and power cables all seem seated ok (and surely the UEFI wouldn't recognise them if they weren't)

So.. I'm at a bit of a loss...
Keep Calm
and
Impale Your Enemies

User avatar
karlchen
Level 19
Level 19
Posts: 9425
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: My Mint 18.2 is having several problems, for no apparent reason...

Post by karlchen » Fri Jul 20, 2018 10:09 am

Hello, Vladtepes.

Looking at your inxi report, I wonder a bit where the wifi interface may have gone? I only see an entry about the wired ethernet card.

Code: Select all

Network:   Card: Intel Ethernet Connection I217-V
           driver: e1000e v: 3.2.6-k port: f080 bus-ID: 00:19.0
           IF: eno1 state: down mac: <filter>
No wifi interface is mentioned in the inxi report at all. What kind of interface does this desktop use? And internal one? Or and external one, connect to a USB adapter perhaps?

You have moved the desktop machine from one room to another room. Have you taken the time to open the cover and check that all cables and cards are still firmly seated?

Regards,
Karl
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

User avatar
michael louwe
Level 9
Level 9
Posts: 2784
Joined: Sun Sep 11, 2016 11:18 pm

Re: My Mint 18.2 is having several problems, for no apparent reason...

Post by michael louwe » Fri Jul 20, 2018 5:22 pm

vladtepes wrote:.
.
While powered-off, try unplugging and replugging the SATA drives.

vladtepes
Level 3
Level 3
Posts: 169
Joined: Sat Feb 25, 2012 7:48 am
Location: Brisbane, Australia
Contact:

Mint 18.2 & now 19 is having several problems

Post by vladtepes » Sat Jul 21, 2018 9:04 am

OK well,
While powered-off, try unplugging and replugging the SATA drives.
Tried that to nil effect. Still doesn't (says it can't) mount them.

Pulled the wireless card to find that one of the aerials (and plugs on the card) has broken.
It has Ch0, ch1 and ch2 and it's ch0 that has broken - in case that makes any difference.
I even tried putting the wireless card into the other available slot - still no changes to the inxi output - evidently the card is not being detected at all?

----

Well I tried something a little more dramatic. Installed LM 19 in lieu of 18.2

But the same issues still exist.

I wish I had a long LAN cable to run to the other room...

weird how inxi reports all the drives and their capacities, but then Linux says it cannot mount the drives. What the?
(This is me going to 'computer', via the desktop icon and then clicking any of the drive icons).

So.... what now I wonder ?
Keep Calm
and
Impale Your Enemies

vladtepes
Level 3
Level 3
Posts: 169
Joined: Sat Feb 25, 2012 7:48 am
Location: Brisbane, Australia
Contact:

Re: Mint 18.2 (and now 19) is having several problems, for no apparent reason...

Post by vladtepes » Sun Jul 22, 2018 5:23 am

UPDATE:

Issue 1: HDD's not mounting - SOLVED. I didn't have a partition on them. Sorted now :)

Issue 2: WiFi - still not found. As per my earlier post -

Pulled the wireless card to find that one of the aerials (and plugs on the card) has broken.
It has Ch0, ch1 and ch2 and it's ch0 that has broken - in case that makes any difference?
I even tried putting the wireless card into the other available slot - still no changes to the inxi output - evidently the card is not being detected at all?
Keep Calm
and
Impale Your Enemies

User avatar
michael louwe
Level 9
Level 9
Posts: 2784
Joined: Sun Sep 11, 2016 11:18 pm

Re: Mint 18.2 (and now 19) is having several problems, for no apparent reason...

Post by michael louwe » Sun Jul 22, 2018 7:16 am

@ vladtepes, .......
vladtepes wrote:.
.
There are Linux-compatible USB Wifi adapters for sale at around US$10 each. ... https://www.wirelesshack.org/top-linux- ... pters.html

vladtepes
Level 3
Level 3
Posts: 169
Joined: Sat Feb 25, 2012 7:48 am
Location: Brisbane, Australia
Contact:

Re: Mint 18.2 (and now 19) is having several problems, for no apparent reason...

Post by vladtepes » Sun Jul 22, 2018 8:52 am

Unfortunately that list is from Dec 2017 so doesn't guarantee compatibility with the latest linux kernel.

I was hoping to find something I could buy locally (Australia) as I don;t want to wait 2 weeks to get this thing online....

I have started a NEW THREAD HERE: viewtopic.php?f=53&t=273918
and would appreciate input re wireless in the new thread - thanks all !
Keep Calm
and
Impale Your Enemies

Post Reply

Return to “Other topics”