Mint 19 apparently ignores "do not lock screen" setting

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
sgbeal
Level 1
Level 1
Posts: 7
Joined: Tue Jan 24, 2017 4:01 am

Mint 19 apparently ignores "do not lock screen" setting

Post by sgbeal » Fri Aug 03, 2018 5:12 am

i'm running Mint 19 with Cinnamon. i'm not 100% sure which forum this question/report should go to, so i'm throwing it into "Other topics"...

The screensaver config offers 2 "Lock settings":

1) Lock the computer when put to sleep

2) Lock the computer after the screensaver starts

Both of those are turned OFF on my system (as is the screensaver).

Despite both being turned off, the screen is locking when waking up from being suspended (which i use multiple times per day).

My question is: how do i get it to NOT lock the screen when entering/coming out of suspend mode?

Any hints would be greatly appreciated!

Edit: it's also locking the screen when i close and open the lid. It's configured to "do nothing" (not suspend) when the lid is closed while on AC power.

PS: Mint 18.3 and earlier did not do this - they woke up directly to my desktop with no screen lock.

(Sidebar: nobody but me in this household uses my computer, so locking the screen is not a concern. If someone breaks in and tries to use it, i have much larger problems than my computer's security. Any preaching about "how insecure" this is will be ignored.)
Last edited by sgbeal on Sun Aug 05, 2018 11:06 am, edited 2 times in total.

User avatar
smurphos
Level 6
Level 6
Posts: 1401
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Mint 19 apparently ignores "do not lock screen" setting

Post by smurphos » Sun Aug 05, 2018 5:10 am

Try this for this lid issue. There are a few suspend bugs being actively worked on looking at Github at the moment.

sudoedit /etc/systemd/logind.conf

This will open that file in nano with root privileges. Use the arrow keys to scroll to the end of the commented out sections and add these two lines

Code: Select all

HandleLidSwitch=ignore
HandleLidSwitchDocked=ignore
Then hit Ctrl-X followed by Y and enter to save.

Logout & Log back in...see if it works.

gm10
Level 9
Level 9
Posts: 2639
Joined: Thu Jun 21, 2018 5:11 pm

Re: Mint 19 apparently ignores "do not lock screen" setting

Post by gm10 » Sun Aug 05, 2018 5:18 am

^ along those lines, did you maybe play around with dconf-editor and switch this setting?
cinnamon-inhibit-lid-switch.png

User avatar
smurphos
Level 6
Level 6
Posts: 1401
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Mint 19 apparently ignores "do not lock screen" setting

Post by smurphos » Sun Aug 05, 2018 5:49 am

Scrap my suggested fix - I can confirm the bug with the same settings and that fix isn't working.

gm10
Level 9
Level 9
Posts: 2639
Joined: Thu Jun 21, 2018 5:11 pm

Re: Mint 19 apparently ignores "do not lock screen" setting

Post by gm10 » Sun Aug 05, 2018 6:18 am

Maybe you guys should create a new user account and log in to that instead, see if it works. I got no problems and I didn't have to modify anything other than to uncheck the box in screensaver settings.

sgbeal
Level 1
Level 1
Posts: 7
Joined: Tue Jan 24, 2017 4:01 am

Re: Mint 19 apparently ignores "do not lock screen" setting

Post by sgbeal » Sun Aug 05, 2018 6:26 am

smurphos wrote:
Sun Aug 05, 2018 5:49 am
Scrap my suggested fix - I can confirm the bug with the same settings and that fix isn't working.
Bummer :(. Maybe it's because you didn't use emacs to edit logind.conf? ;)

In any case, i made this change (with emacs!) and we'll see what happens the next time i restart (which is admittedly rare).
gm10 wrote:
Sun Aug 05, 2018 5:18 am
^ along those lines, did you maybe play around with dconf-editor and switch this setting?
That option was already set to "on" in my system. The lock-on-suspend option, visible a few lines down from there, is off. Hmmm... the searching dconf for "lock" reveals that org.mate and org.gnome have several conflicting options which enable locking (i'm using Cinnamon). i'll disable those and see what happens. Hmmm.... org.cinnamon.desktop.lockdown.disable-lock-screen sounds promising. i'll try that one.

Oh, well. It's not "broken" as-is, just terribly annoying (i suspend my computer any time i'll be away from it for more than 5 minutes or so, so i come out of suspend mode a lot). i'll wait and see if it gets fixed in a regular update.

i'll report back if my scorched-earth policy of disabling any dconf setting with "lock" in the name has any effect.

Thanks for the assistance!

sgbeal
Level 1
Level 1
Posts: 7
Joined: Tue Jan 24, 2017 4:01 am

Re: Mint 19 apparently ignores "do not lock screen" setting

Post by sgbeal » Sun Aug 05, 2018 6:28 am

gm10 wrote:
Sun Aug 05, 2018 6:18 am
Maybe you guys should create a new user account and log in to that instead, see if it works. I got no problems and I didn't have to modify anything other than to uncheck the box in screensaver settings.
A new user account? i've had this account for more than two decades and no little screen lock bug is going to take that away from me! :)

gm10
Level 9
Level 9
Posts: 2639
Joined: Thu Jun 21, 2018 5:11 pm

Re: Mint 19 apparently ignores "do not lock screen" setting

Post by gm10 » Sun Aug 05, 2018 6:32 am

sgbeal wrote:
Sun Aug 05, 2018 6:28 am
gm10 wrote:
Sun Aug 05, 2018 6:18 am
Maybe you guys should create a new user account and log in to that instead, see if it works. I got no problems and I didn't have to modify anything other than to uncheck the box in screensaver settings.
A new user account? i've had this account for more than two decades and no little screen lock bug is going to take that away from me! :)
I mean just for testing, so you can see if it also happens with default user settings (you'll have to uncheck the option in the screensaver settings again though). If it doesn't happen then, you'll know it's a problem with your main user's settings. Otherwise you'll know that you don't have to search through the user settings any longer because it won't make a difference.

It's just a useful troubleshooting technique to quickly rule out user settings as the cause.

sgbeal
Level 1
Level 1
Posts: 7
Joined: Tue Jan 24, 2017 4:01 am

[SOLVED (well, worked around)] Re: Mint 19 apparently ignores "do not lock screen" setting

Post by sgbeal » Sun Aug 05, 2018 6:41 am

gm10 wrote:
Sun Aug 05, 2018 6:32 am
It's just a useful troubleshooting technique to quickly rule out user settings as the cause.
Luckily i didn't have to go that far (it could have quickly ruled out a global-level problem but wouldn't have helped me find which local setting - possibly inherited from some 10-year-old config bits - is the culprit).

Following your suggestion to look in dconf-editor, i searched for "lock" and disabled any and all settings which mentioned screen/screensaver/suspend/hibernate locking, regardless of which desktop environment they were for. One of those settings solved it. My guess is that it was org.cinnamon.desktop.lockdown.disable-lock-screen. Let's test that... Nope, that toggle didn't make a difference. Apparently it was one of the other 6 or 8 i toggled, but i can't be bothered to go try them out one by one :|.

User avatar
smurphos
Level 6
Level 6
Posts: 1401
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: [SOLVED (well, worked around)] Re: Mint 19 apparently ignores "do not lock screen" setting

Post by smurphos » Sun Aug 05, 2018 6:45 am

sgbeal wrote:
Sun Aug 05, 2018 6:41 am
but i can't be bothered to go try them out one by one :|.
:roll: :wink: Fair enough - at least we know it's fixable.

sgbeal
Level 1
Level 1
Posts: 7
Joined: Tue Jan 24, 2017 4:01 am

Re: Mint 19 apparently ignores "do not lock screen" setting

Post by sgbeal » Sun Aug 05, 2018 11:07 am

Update: the toggles i switched earlier apparently only resolve the problem when coming out of suspend (and, i suspect, hibernate, but haven't yet tried that). When simply shutting the laptop lid and re-opening it, with the system configured to "do nothing" when the lid is closed when running on AC, the lock is activated :(.

User avatar
smurphos
Level 6
Level 6
Posts: 1401
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Mint 19 apparently ignores "do not lock screen" setting

Post by smurphos » Wed Aug 08, 2018 1:51 am

sgbeal wrote:
Sun Aug 05, 2018 11:07 am
Update: the toggles i switched earlier apparently only resolve the problem when coming out of suspend (and, i suspect, hibernate, but haven't yet tried that). When simply shutting the laptop lid and re-opening it, with the system configured to "do nothing" when the lid is closed when running on AC, the lock is activated :(.
See viewtopic.php?f=208&t=273378&p=1509068#p1509068 for a workaround.

Also for coming out of suspend issues kernel 4.15.0.30 includes a bug fix for xorg crashes coming out of suspend - that might fix the other issue.

sgbeal
Level 1
Level 1
Posts: 7
Joined: Tue Jan 24, 2017 4:01 am

Re: Mint 19 apparently ignores "do not lock screen" setting

Post by sgbeal » Fri Aug 10, 2018 9:32 am

smurphos wrote:
Wed Aug 08, 2018 1:51 am
See viewtopic.php?f=208&t=273378&p=1509068#p1509068 for a workaround.
That did it :-D. Thank you! Finally lock-screen free! :-D

Post Reply

Return to “Other topics”