Mint 19 - Suspend not working

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Ariake
Level 1
Level 1
Posts: 3
Joined: Sat Aug 04, 2018 3:01 am

Mint 19 - Suspend not working

Post by Ariake » Sat Aug 04, 2018 3:14 am

Hello everyone,

I've upgraded to Linux Mint 19 and my suspend mode, by using the GUI or the command line, doesn't work.

Here is the 'journalctl -u suspend.target' output:

Code: Select all

Dependency failed for Suspend.
suspend.target: Job suspend.target/start failed with result 'dependency'.
And 'systemctl status systemd-suspend.service' output:

Code: Select all

● systemd-suspend.service - Suspend
   Loaded: loaded (/lib/systemd/system/systemd-suspend.service; static; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2018-08-04 08:50:35 CEST; 4h 2min ago
     Docs: man:systemd-suspend.service(8)
 Main PID: 764 (code=exited, status=1/FAILURE)

août 04 08:48:55 quentin-XPS systemd[1]: Starting Suspend...
août 04 08:48:55 quentin-XPS systemd-sleep[764]: Suspending system...
août 04 08:50:35 quentin-XPS systemd[1]: ^[[0;1;39m^[[0;1;39msystemd-suspend.service: Main process exited, code=exited, status=1/FAILURE
août 04 08:50:35 quentin-XPS systemd[1]: ^[[0;1;39m^[[0;1;39msystemd-suspend.service: Failed with result 'exit-code'.
août 04 08:50:35 quentin-XPS systemd[1]: ^[[0;1;39mFailed to start Suspend.
$ inxi -Fxz

Code: Select all

System:    Host: quentin-XPS Kernel: 4.15.0-29-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1) Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Dell product: XPS 15 9560 serial: N/A
           Mobo: Dell model: 05FFDN v: A00 serial: N/A
           UEFI: Dell v: 1.3.3 date: 05/08/2017
Battery    BAT0: charge: 77.8 Wh 89.0% condition: 87.4/97.0 Wh (90%)
           model: SMP DELL GPM0365 status: N/A
CPU:       Quad core Intel Core i7-7700HQ (-MT-MCP-) 
           arch: Skylake rev.9 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464
           clock speeds: max: 3800 MHz 1: 1000 MHz 2: 1000 MHz 3: 1000 MHz 4: 1000 MHz
           5: 1000 MHz 6: 1000 MHz 7: 1000 MHz 8: 1000 MHz
Graphics:  Card-1: Intel Device 591b bus-ID: 00:02.0
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@59.93hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
           version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card Intel CM238 HD Audio Controller driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.15.0-29-generic
Network:   Card-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
           driver: ath10k_pci bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Atheros usb-ID: 001-002
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 512.1GB (19.0% used)
           ID-1: /dev/nvme0n1 model: PM961_NVMe_SAMSUNG_512GB size: 512.1GB
Partition: ID-1: / size: 81G used: 26G (34%) fs: ext4 dev: /dev/nvme0n1p7
           ID-2: /home size: 92G used: 58G (67%) fs: ext4 dev: /dev/nvme0n1p8
           ID-3: swap-1 size: 8.19GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 52.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 290 Uptime: 1 day Memory: 5875.9/15892.2MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (zsh 5.4.2) inxi: 2.3.56

User avatar
Ariake
Level 1
Level 1
Posts: 3
Joined: Sat Aug 04, 2018 3:01 am

Re: Mint 19 - Suspend not working

Post by Ariake » Sat Aug 04, 2018 8:51 am

Ok after 2 days of investigations I've found interesting things:

- First, it's a problem that occurs specifically with the last version of Ubuntu 18.04, the bad thing is that the all new Linux Mint 19 is based on it.
- Second, it touches a few machines with some specific hardware, I've got an XPS 15 9560, and it seems that the latest XPS (from 2016 to 2018) have some troubles with suspend.
- There is information on how to find some workaround here: https://askubuntu.com/questions/1029474 ... 70#1044270
- It seems to be a kernel problem with from kernel 4.15 to 4.17, currently, with the latest kernel update, we are at the 4.15.0-29 on Mint 19.
- The good point is that someone has succeeded to patch the kernel and it seems to work: https://bugs.launchpad.net/ubuntu/+sour ... ug/1774950 this patch has now been committed but still not released.

So now I have 2 questions for the linux Mint community:

1) Do you think I can try the patched kernel with Mint even if that one has been destinated to Ubuntu?
2) When a patch is release on Ubuntu, how much time people using Mint usually wait to get it?

poncho524
Level 1
Level 1
Posts: 6
Joined: Fri Aug 03, 2018 1:04 pm

Re: Mint 19 - Suspend not working

Post by poncho524 » Sat Aug 04, 2018 9:17 am

I'm having the same problem on a Dell Precision. I ended up just going back to Mint 18.3 (and not updating to the latest kernel release (4.15) for that). I'd like to know if there's a way to update 19 to get past this, and if it truly does fix the problem.

User avatar
smurphos
Level 6
Level 6
Posts: 1432
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Mint 19 - Suspend not working

Post by smurphos » Sat Aug 04, 2018 9:19 am

Ariake wrote:
Sat Aug 04, 2018 8:51 am
1) Do you think I can try the patched kernel with Mint even if that one has been destinated to Ubuntu?
2) When a patch is release on Ubuntu, how much time people using Mint usually wait to get it?
1) Should be OK - Mint's kernels come from Ubuntu.
2) No wait - released kernels are available to Ubuntu and Mint users at the same time.

gm10
Level 9
Level 9
Posts: 2796
Joined: Thu Jun 21, 2018 5:11 pm

Re: Mint 19 - Suspend not working

Post by gm10 » Sat Aug 04, 2018 9:20 am

Ariake wrote:
Sat Aug 04, 2018 8:51 am
1) Do you think I can try the patched kernel with Mint even if that one has been destinated to Ubuntu?
2) When a patch is release on Ubuntu, how much time people using Mint usually wait to get it?
Only responding to those two questions:
1) Mint uses Ubuntu kernels, anyway, so yes. That said, and while I didn't read through the bug report you linked, I did see that the patched kernel was based on 4.15.0-24, which was revoked very quickly due to some serious bugs, so you may run into other issues using that.
2) As stated, Mint uses Ubuntu kernels, so there is no delay.

Rocky Bennett
Level 4
Level 4
Posts: 386
Joined: Tue May 12, 2015 6:22 pm

Re: Mint 19 - Suspend not working

Post by Rocky Bennett » Sat Aug 04, 2018 11:30 am

I have experienced this problem and started threads about it here at this forum as well as the Ubuntu forum. Unfortunately the "bug" is baked in and no kernel patch will fix the problem. I finally gave up and moved on to openSUSE.

User avatar
Ariake
Level 1
Level 1
Posts: 3
Joined: Sat Aug 04, 2018 3:01 am

Re: Mint 19 - Suspend not working

Post by Ariake » Sat Aug 04, 2018 12:09 pm

I didn't expect to see as much activity over there! Thank everyone for your answers, that's awesome to have an active community like this. :D

That's very nice that we can get the kernel update at the same time as the Linux users.
I will not try to install the patched kernel because I don't especially want to run into other trouble due to a version that has been revoked as gm10 states.


I hope this thread will help other people that have the same problem.

poncho524
Level 1
Level 1
Posts: 6
Joined: Fri Aug 03, 2018 1:04 pm

Re: Mint 19 - Suspend not working

Post by poncho524 » Sun Aug 05, 2018 4:56 pm

I'm not sure this has been much help, but maybe more of a support group. at least we know we're not alone ;) but we haven't really seen a true solution. :( i went back to 18.3 so i could use my computer. I'm going to keep tabs on the forums to see if anyone confirms a solution.

So if anyone out there runs into this and has a fix going forward, please share!

gm10
Level 9
Level 9
Posts: 2796
Joined: Thu Jun 21, 2018 5:11 pm

Re: Mint 19 - Suspend not working

Post by gm10 » Sun Aug 05, 2018 5:18 pm

poncho524 wrote:
Sun Aug 05, 2018 4:56 pm
I'm not sure this has been much help, but maybe more of a support group. at least we know we're not alone ;) but we haven't really seen a true solution. :( i went back to 18.3 so i could use my computer. I'm going to keep tabs on the forums to see if anyone confirms a solution.

So if anyone out there runs into this and has a fix going forward, please share!
We'd need more information to try and offer a solution. OP only provided a log excerpt that a dependency failed, but not which one, and you provided nothing other than saying that 18.3 works. So since kernel issues where mentioned above as a likely reason the first thing to try would be to use the same kernel in LM19 that works for you in LM18.3

Post Reply

Return to “Other topics”