Upgrade to kernel 4.15 fails

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
myfathersson
Level 1
Level 1
Posts: 3
Joined: Fri May 18, 2018 12:36 pm

Upgrade to kernel 4.15 fails

Post by myfathersson » Thu Aug 16, 2018 8:32 pm

OS: Mint 18.3, Cinnamon 64 3.6.7
Kernel: 4:13.0-45 generic
Hardware: HP DV7, I7 Q720, NVIDIA GT216M (GeForce 230M), Samsung 860 250GB (RVT01B6Q), 8GB ram

I hope this is the correct forum for this topic.

The last 2 kernel updates have caused problems with my system. In both cases it was the 4.15 update. All updates where done using Update Manager.

In both cases it caused Cinnamon to keep crashing. I was able to restart with the old kernel to fix the problem then removed the 4.15 kernel.

Just wondering if anyone else has had problems with 4.15. I had seen on a site (I forget where...somewhere in my wonderings) that there were problems with the 4.15 kernel. I was hoping the last update had fixed the problems, but, alas...

I'm ok with staying with 4.13 but it would be better to update if possible to ensure I get all the latest security updates.

I'm not a linux expert. I've been running on Mint for about 6 months trying to wean myself off the MS habit. Love Mint. But it needs more poking and prodding than Windows to get everything working.

Any ideas on how the diagnose what the issue it with 4.15?

Peter

User avatar
smurphos
Level 8
Level 8
Posts: 2058
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Upgrade to kernel 4.15 fails

Post by smurphos » Fri Aug 17, 2018 1:12 am

myfathersson wrote:
Thu Aug 16, 2018 8:32 pm
NVIDIA GT216M (GeForce 230M)
Probably ^

See viewtopic.php?f=60&t=275647&start=20

There are issues with some proprietary Nvidia drivers not building kernel modules in 4.15.x kernels in 18.x. The OP in the linked post solved the issue by moving to the nouveau driver. The other solution is upgrade to Mint 19.

To be sure it's the same issue for you we'd need to see your inxi -Fxz output to know what driver your GPU is using.

myfathersson
Level 1
Level 1
Posts: 3
Joined: Fri May 18, 2018 12:36 pm

Re: Upgrade to kernel 4.15 fails

Post by myfathersson » Fri Aug 17, 2018 9:29 am

Smurphos

Thanks for the reply. I'll check out the link.

inxi -Fxz output:

Code: Select all

System:    Host: peterHPdv7Mint Kernel: 4.13.0-45-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Hewlett-Packard (portable) product: HP Pavilion dv7 Notebook PC v: 049D210000241210000020000
           Mobo: Hewlett-Packard model: 365C v: 32.25
           Bios: Hewlett-Packard v: F.1D date: 10/05/2010
CPU:       Quad core Intel Core i7 Q 720 (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 12768
           clock speeds: max: 1600 MHz 1: 939 MHz 2: 1054 MHz 3: 1094 MHz
           4: 964 MHz 5: 967 MHz 6: 1027 MHz 7: 974 MHz 8: 1071 MHz
Graphics:  Card: NVIDIA GT216M [GeForce GT 230M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1600x900@60.08hz, 1920x1080@60.00hz
           GLX Renderer: GeForce GT 230M/PCIe/SSE2
           GLX Version: 3.3.0 NVIDIA 340.104 Direct Rendering: Yes
Audio:     Card-1 Intel 5 Series/3400 Series High Definition Audio
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GT216 HDMI Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.13.0-45-generic
Network:   Card-1: Broadcom BCM43224 802.11a/b/g/n driver: wl bus-ID: 02:00.0
           IF: wlo1 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 250.1GB (38.3% used)
           ID-1: /dev/sda model: Samsung_SSD_860 size: 250.1GB
Partition: ID-1: / size: 50G used: 12G (26%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 171G used: 78G (48%) fs: ext4 dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 61.0C mobo: N/A gpu: 0.0:61C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 246 Uptime: 16 min Memory: 2790.3/7967.9MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
UPDATE: Switched to the nouveau driver and installed 4.15.0-32 without issue. Thanks for the help. And I apologize for not finding the referenced topic myself. I don't know why I didn't find it when I searched. I'm guessing a UBF (User Brain Failure)...crap search terms. I'll consider upgrading to 19 but I'm a firm believer in IIABDFI (If It Ain't Broke, Don't Fix It).

Thanks again.

myfathersson
Level 1
Level 1
Posts: 3
Joined: Fri May 18, 2018 12:36 pm

Re: Upgrade to kernel 4.15 fails

Post by myfathersson » Sun Aug 19, 2018 1:08 pm

I spoke too soon.

Mint freezes when it sleeps from inactivity. Nothing wakes the computer; my only option is to hard boot it. I turned off the lock features in the screen saver to no avail. I scanned the system log for obvious reasons for the freeze up, didn't see anything, but then I don't know what I'm looking for. I tried Cntl-Alt-Esc to restart Cinnamon, didn't work.

Unless someone has a better idea, I'm gonna have to roll back to 4.13.

I'd consider installing 19 but I installed it on another machine and it kept crashing...makes me nervous.

I was really hoping for greater stability so I could get my wife and others on to linux, but it just wouldn't do for them to have to be constantly prodding the system to get it working. I don't tinker with the system so I don't think it's what I'm doing. Maybe it's a hardware issue. Any ideas?

Update: After rolling back to kernel 4.13 and changing the video driver back to the Nvidia version, the system is still freezing after a period of inactivity and the screensaver kicks in. It only stopped after restoring the Timeshift from just before I did the 4.15 update. How can I diagnose what the issue is?

Post Reply

Return to “Other topics”