Compose Key not working in Linux Mint 19

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
ShadWolf
Level 1
Level 1
Posts: 36
Joined: Sat Sep 06, 2014 2:59 am

Compose Key not working in Linux Mint 19

Post by ShadWolf » Mon Oct 08, 2018 6:15 am

I'm having some issues getting my Compose Key to work in Mint 19, I upgraded from 18.3 a while ago, and I had my compose key configured to Left Win Key, but for some reason it's not working at all like it normally should in LM19 using the Left Win Key in my Keyboard Preferences.

Configuration:

Code: Select all

System Preferences:
    >> Keyboard
        >> Layouts
            >> [Options...]
                >> Position of Compose key
                [x] Left Win
Expected Result:

Press [Left Win] key once, and type compose a unicode character, ie; Copyright Sign [U+00A9] unicode character O + c => ©

This is a quicker and simpler form of being able to type unicode characters without knowing the actual unicode alphanumeric codes. Instead what's happening is when I press my Compose Key, nothing happens, doesn't enter Unicode Compose mode like it usually should do.

Q: Have you tried turning it ON and OFF again or chosing different compose keys?
A: Yes, many times, no effect, no matter what key I select.

User avatar
kyphi
Level 8
Level 8
Posts: 2321
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Compose Key not working in Linux Mint 19

Post by kyphi » Mon Oct 08, 2018 5:20 pm

Since you posted your question in the Main Edition Support, I assume that you are using Cinnamon.

Pressing the left Win key shows the Main Menu.

Holding down Shift+Ctrl and typing u00a9 produces © when Shift+Ctrl are released.

Pressing the specified Compose key followed by O and c produces ©.

Considering that the left Win key already has an assigned function, specify a different key to act as Compose key. I use the Caps Lock key. See if the Caps Lock key works for you.

To set the Compose key, open System Settings, Hardware, Keyboard, Layouts, Options, Position of Compose key - and place a tick next to your chosen key.
Linux Mint 19 Cinnamon - 64bit

MichealHeitz
Level 1
Level 1
Posts: 5
Joined: Fri Apr 13, 2018 7:10 am

Re: Compose Key not working in Linux Mint 19

Post by MichealHeitz » Tue Oct 09, 2018 5:07 am

kyphi wrote:
Mon Oct 08, 2018 5:20 pm
Since you posted your question in the Main Edition Support, I assume that you are using Cinnamon.

Pressing the left Win key shows the Main Menu.

Holding down Shift+Ctrl and typing u00a9 produces © when Shift+Ctrl are released.

Pressing the specified Compose key followed by O and c produces ©.

Considering that the left Win key already has an assigned function, specify a different key to act as Compose key. I use the Caps Lock key. See if the Caps Lock key works for you.

To set the Compose key, open System Settings, Hardware, Keyboard, Layouts, Options, Position of Compose key - and place a tick next to your chosen key.
Or you can also check these steps if using Cinnamon

Run the keyboard application (from menu or from the settings).

Choose the Layouts tab.

At the right bottom of the window, you've a Options... button.

You've then access to different options, including "Keyboard Layout Options".

Post Reply

Return to “Other topics”