Page 1 of 1

Trouble when closing and opening lid, laptop.

Posted: Sat Apr 06, 2019 9:20 am
by jeppezon
Hello!

First off, I want to apologize if I posted this in the wrong forum section. However, I am not sure if this is a hardware or network issue. Might even be a faulty configuration in the software that causes this?

Hardware and OS:
Okay, let's start with specifying the hardware and OS. I run Asus Zenbook UX303LN-R4297H, the OS is Linux Mint 19 Cinnamon 3.8.9 with kernel 4.15.0-47-generic.

The Problem:
After I have closed the lid of my laptop and open it again I do not have a wifi-connection anymore. To solve this I try to restart the os by using the task bar. When I click restart it is as if I click "log out" which do not even exist, I just get thrown instantly to my login window. If I click shutdown, nothing at all happens. I have even tried using the terminal and issued `sudo shutdown` but once again, nothing happens. I then run `sudo reboot` and then the laptop restarts (no loading screen when shutting down) but when it boots up again, it is super slow.
It takes several minutes, I have only let this run until it is completed a few times, in hope that it would solve the issue for good. Usually I press and hold my on/off button until it's off and then boot it up again, this is much faster and the time it takes is considered "normal" and what I'm used to.
When I'm back, everything is working normal until I once again close the lid and open it again.

Another symptom I get (sometimes) when I open the lid again, is that my connected USB devices reconnects. The sound of disconnecting a USB memory and then connecting it again sounds. Followed browser window of the files on the USB.

Any help at all would be appreciated, not sure where to even start troubleshooting since I'm fairly new to Linux in general.

Re: Trouble when closing and opening lid, laptop.

Posted: Sat Apr 06, 2019 6:36 pm
by bartszu
Selection_197.jpg

Re: Trouble when closing and opening lid, laptop.

Posted: Tue Apr 09, 2019 3:36 pm
by jeppezon
bartszu wrote:
Sat Apr 06, 2019 6:36 pm
Selection_197.jpg
This is one workaround indeed but do not really solve the problem.

Re: Trouble when closing and opening lid, laptop.

Posted: Tue Apr 09, 2019 7:10 pm
by pbear
I don't know the solution either, but recall having seen a similar report a month or so ago. What I suggested there, and the OP said worked, is to suspend from Menu, then close the lid. Opening the lid should bring up both the system and the internet connection. Not as convenient as simply closing the lid, I suppose, but it's not much hardship either and you get a true suspend out of the bargain.

By the way, the shutdown command doesn't need sudo, but will run sooner if you say shutdown now. Both things true also of reboot.

Re: Trouble when closing and opening lid, laptop.

Posted: Wed Apr 10, 2019 5:06 am
by jeppezon
pbear wrote:
Tue Apr 09, 2019 7:10 pm
I don't know the solution either, but recall having seen a similar report a month or so ago. What I suggested there, and the OP said worked, is to suspend from Menu, then close the lid. Opening the lid should bring up both the system and the internet connection. Not as convenient as simply closing the lid, I suppose, but it's not much hardship either and you get a true suspend out of the bargain.

By the way, the shutdown command doesn't need sudo, but will run sooner if you say shutdown now. Both things true also of reboot.
Thanks, I just gave it a try and it seems to work. I will continue this way and hope that the solution is consistent.

Re: Trouble when closing and opening lid, laptop.

Posted: Thu Apr 11, 2019 12:27 pm
by pbear
You're welcome. Pretty sure it'll keep working. That's how I've been doing it for nearly two years.