Authentication prompt for suspend/hibernate

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
User avatar
lonely_llama
Level 1
Level 1
Posts: 25
Joined: Mon Jul 22, 2019 12:08 am

Authentication prompt for suspend/hibernate

Post by lonely_llama » Tue Sep 03, 2019 11:25 pm

Each time the system suspends after being idle, or I try to trigger a suspend/hibernate from another application (for example, qBittorrent 'suspend/hibernate after downloads complete'), I get an authentication prompt for root.
If i trigger hibernate manually from the menu, it grinds the disk for ages, then takes me to the lockscreen, after which I have to hibernate a second time for it to work. I've taken to locking the screen first before hibernating as a workaround but why does this happen?

carum carvi
Level 5
Level 5
Posts: 953
Joined: Sun Apr 16, 2017 11:44 pm

Re: Authentication prompt for suspend/hibernate

Post by carum carvi » Wed Sep 04, 2019 3:01 am

My girlfriend's HP laptop (LM18.3 Cinnamon) cant suspend nor hibernate. It crashes her laptop every single time. I am lucky though, having not experienced such issues. Suspend and hibernation problems are quite common in Linux though. This is due to a lack of support for Linux by hardware manufacturers. Hibernation is disabled in LM19. It depends on the hardware you are using wether you will experience none or severe issues with suspend. You did find a smart workaround, which is not ideal of course. I cant really help you lonely llama, only suggest you try 2 things:

-There is an option in the system settings in Cinnamon to disable the locking of the screen when you suspend.
-Choosing suspend instead of hibernation is another easy fix, which hopefully will give you a more troublefree experience.

User avatar
Spearmint2
Level 16
Level 16
Posts: 6167
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Authentication prompt for suspend/hibernate

Post by Spearmint2 » Wed Sep 04, 2019 3:38 am

Try the combo of CTRL + ALT+L
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
lonely_llama
Level 1
Level 1
Posts: 25
Joined: Mon Jul 22, 2019 12:08 am

Re: Authentication prompt for suspend/hibernate

Post by lonely_llama » Fri Sep 06, 2019 7:09 am

carum carvi wrote:
Wed Sep 04, 2019 3:01 am
My girlfriend's HP laptop (LM18.3 Cinnamon) cant suspend nor hibernate. It crashes her laptop every single time. I am lucky though, having not experienced such issues. Suspend and hibernation problems are quite common in Linux though. This is due to a lack of support for Linux by hardware manufacturers. Hibernation is disabled in LM19. It depends on the hardware you are using wether you will experience none or severe issues with suspend. You did find a smart workaround, which is not ideal of course. I cant really help you lonely llama, only suggest you try 2 things:

-There is an option in the system settings in Cinnamon to disable the locking of the screen when you suspend.
-Choosing suspend instead of hibernation is another easy fix, which hopefully will give you a more troublefree experience.
I have no problems with hibernation, it works perfectly fine since I set it up. I don't want to be prompted for a password when I've turned off prompting in power manager for suspend/hibernate.

User avatar
lonely_llama
Level 1
Level 1
Posts: 25
Joined: Mon Jul 22, 2019 12:08 am

Re: Authentication prompt for suspend/hibernate

Post by lonely_llama » Sat Sep 07, 2019 4:09 am

Spearmint2 wrote:
Wed Sep 04, 2019 3:38 am
Try the combo of CTRL + ALT+L
For what exactly, besides locking the screen, which has nothing to do with what I'm asking? As I've stated, I do not want to be prompted for a password when I resume after suspend/hibernate, and I've disabled 'lock screen when system is going to sleep' in Xfce power manager.

User avatar
Spearmint2
Level 16
Level 16
Posts: 6167
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Authentication prompt for suspend/hibernate

Post by Spearmint2 » Sat Sep 07, 2019 11:55 am

lonely_llama wrote:
Sat Sep 07, 2019 4:09 am
Spearmint2 wrote:
Wed Sep 04, 2019 3:38 am
Try the combo of CTRL + ALT+L
For what exactly, besides locking the screen, which has nothing to do with what I'm asking? As I've stated, I do not want to be prompted for a password when I resume after suspend/hibernate, and I've disabled 'lock screen when system is going to sleep' in Xfce power manager.
Open Control Center, go to Login Window preferences, check the box for not requiring a login, see if that also works for suspend and hibernate.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
lonely_llama
Level 1
Level 1
Posts: 25
Joined: Mon Jul 22, 2019 12:08 am

Re: Authentication prompt for suspend/hibernate

Post by lonely_llama » Sat Sep 07, 2019 8:41 pm

I'm on Xfce, not Cinnamon, there's no such option in the login preferences.
Login window.png
What I have is Light locker - (disabling the first toggle here had no effect either).
Light locker settings.png
...and power manager.
Xfce power manager.png
Turned off authentication in all these places, but each time I unlock the screen after resume from suspend/hibernate, there is an authentication prompt similar to what you get on running Synaptic or doing anything that requires root privileges.

Post Reply

Return to “Other topics”