PC does not fully shutdown from Linux[SOLVED]

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: PC does not fully shutdown from Linux

Post by muffybean »

Enough to see that as far as the software is concerned, shutdown is fine. Although this wouldn't be a fix, one of the best tests is probbely [edit: wow...] having you boot with the nouveau.modeset=0 kernel parameter, assuming you are still on nouveau rather than the binary nvidia driver now.

To do that, replace noefi in /etc/default/grub with nouveau.modeset=0 per the instructions given then as well, save the file, run sudo update-grub, reboot, and try to shutdown.
Are we talking about doing this in Terminal?

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noefi"
changing to

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0"
?


Yes I am still on nouveau.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
rene
Level 16
Level 16
Posts: 6693
Joined: Sun Mar 27, 2016 6:58 pm

Re: PC does not fully shutdown from Linux

Post by rene »

In sudo nano /etc/default/grub in the terminal, yes. And noting again, to after having changed /etc/defauult/grub in that manner, to run sudo update-grub, reboot, and only then try the shutdown (the parameter likely gives you a basic resolution in the GUI upon reboot, but we're just testing).
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: PC does not fully shutdown from Linux

Post by muffybean »

rene wrote:
Sun Dec 22, 2019 4:16 pm
In sudo nano /etc/default/grub in the terminal, yes. And noting again, to after having changed /etc/defauult/grub in that manner, to run sudo update-grub, reboot, and only then try the shutdown (the parameter likely gives you a basic resolution in the GUI upon reboot, but we're just testing).
I rebooted and was then in what looked like safe mode as you get in Windows in 640 type screen. Had an issues getting to the shutdown button on my desktop but solved that by organising by name. Shutdown but no change. How do I get back to normal as in that screen on my big screen tv a lot of stuff I can't reach. Should I restore via timeshift? It is getting a bit silly now as another issue that is cropping up each time is I am cutting off power supply when everything has stopped working my bios is being reset to fail safe and I have to go in and set it all up again!
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: PC does not fully shutdown from Linux

Post by muffybean »

Right I have found out another thing and that is when the stuff stops completely in shutdown, rather than cut the power off, if I shut the machine down completely by pressing the power button until the machine stops I do not get the bios reverting to safe mode. That means the machine boots up normally the next time.

I am currently restoring the machine back via timeshift. Could not do it using my mouse as in safe mode screen I could not get to the start restore butting. Had to do it via the tab button until I reached in sequence and then pressed enter and it is now restoring but now I have come to a standstill because I cannot reach the relevant control and have had to stop. Think I have CZ image I can use and may have to as I am in a right mess here. I am going to have to go with it as I will be out most of tomorrow as I have to take my wife to hospital for suspected cancer in her throat so I getting really stumped.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
rene
Level 16
Level 16
Posts: 6693
Joined: Sun Mar 27, 2016 6:58 pm

Re: PC does not fully shutdown from Linux

Post by rene »

There is/was no need for timeshift; just revert the previous: open a terminal again, sudo nano /etc/default/grub, remove nouveau.modeset=0, save, sudo update-grub, reboot.

But I guess I'll be out then; I have no suggestions left I'm sorry to say.
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: PC does not fully shutdown from Linux

Post by muffybean »

Right I got round all this by writing down these commands from my other PC and reversed things via Terminal and I am now back to

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noefi"
in GRUB on -70.

As I said in my previous message I have to take my wife to hospital tomorrow and think I am going to have to curtail this until after Christmas as I am not spending enough time with my wife and son.

One idea I have to try after Christmas is to do a CZ image of my current system then do a clean install on the machine of LM 19.3 to see if that works without any issues. That way it will prove whether is software related or hardware. If it is software then I will proceed to rebuild my setup as I had it.

So Rene I wish you a very happy Christmas and will get back to you after next Saturday.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
rene
Level 16
Level 16
Posts: 6693
Joined: Sun Mar 27, 2016 6:58 pm

Re: PC does not fully shutdown from Linux

Post by rene »

Same, and one thing I did think of was your "CZ" medium shutting down correctly; that would be to say it's not hardware. I don't use CloneZilla, but I take it it's a bootable ISO. If you can distill which kernel it's running that might tell you something.

But yes, same wishes, and possibly see you back later...
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: PC does not fully shutdown from Linux

Post by muffybean »

rene wrote:
Sun Dec 22, 2019 5:55 pm
Same, and one thing I did think of was your "CZ" medium shutting down correctly; that would be to say it's not hardware. I don't use CloneZilla, but I take it it's a bootable ISO. If you can distill which kernel it's running that might tell you something.

But yes, same wishes, and possibly see you back later...
Yes it is a bootable USB Live stick. It does take time but it is very safe I find, took me a few runs before I got comfortable with it and use it before any major change, I have an image prior to upgrading to 19.3.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
Reddog1
Level 3
Level 3
Posts: 152
Joined: Wed Jun 01, 2011 2:12 pm

Re: PC does not fully shutdown from Linux

Post by Reddog1 »

I had a shutdown problem with my laptop running 18.3 and the 4.13 kernel. I tried every solution that I could think of and none worked, but the issue eventually resolved itself after a software update (not a kernel update). I did discover a workaround that might work for you, at least it is worth a try. I think you are using Mate and I use xfce, so this may or may not be germane.

Instead of choosing shutdown from the menu, choose 'logout'. The system should bring up the login screen. In the corner of the screen, then choose the power button, which will bring up another screen where you can choose shutdown. In my case, my laptop would then complete a shutdown with power off, which it would not do using the normal process without a logout first.
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: PC does not fully shutdown from Linux

Post by muffybean »

Instead of choosing shutdown from the menu, choose 'logout'. The system should bring up the login screen. In the corner of the screen, then choose the power button, which will bring up another screen where you can choose shutdown. In my case, my laptop would then complete a shutdown with power off, which it would not do using the normal process without a logout first.
No that failed as well. So what I decided to do is to use my CZ USB live stick and boot into that. When I went into its procedures and then cancelled and was eventually given the option to reboot or shutdown, I chose shutdown and the problem still exists. Now when I used CZ just before this issue started it did shutdown properly but think this was just a coincidence that this happened prior to a fault occurring. I think when I installed the USB 3.0 card I must have disturbed something in the box as it points now to a hardware issue.

When I can get around to it I will open the box up and cross check all the connections to make sure they a correct. I am now totally convinced that it is hardware and not software problem. I do apologise to you all for causing any inconvenience in helping me. Although I will say it has helped me in that learning curve about the Linux system, so thank you all for that.

In conclusion I do wish you all a very happy Christmas and hope my problem has not caused any of you an inconvenience. :oops: :roll:
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
rene
Level 16
Level 16
Posts: 6693
Joined: Sun Mar 27, 2016 6:58 pm

Re: PC does not fully shutdown from Linux

Post by rene »

muffybean wrote:
Sun Dec 22, 2019 7:36 pm
[ ... ] and hope my problem has not caused any of you an inconvenience. :oops: :roll:
We're fine. Although I do hope that next time you pick an instant to have your computer hardware break it doesn't coincide with some of us experiencing the exact same symptoms from a kernel update at that exact same time... :D
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: PC does not fully shutdown from Linux

Post by muffybean »

rene wrote:
Mon Dec 23, 2019 6:16 am
muffybean wrote:
Sun Dec 22, 2019 7:36 pm
[ ... ] and hope my problem has not caused any of you an inconvenience. :oops: :roll:
We're fine. Although I do hope that next time you pick an instant to have your computer hardware break it doesn't coincide with some of us experiencing the exact same symptoms from a kernel update at that exact same time... :D
Laughing.jpg
Laughing.jpg (5.17 KiB) Viewed 369 times
Hope you have a nice Christmas.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: PC does not fully shutdown from Linux

Post by muffybean »

We're fine. Although I do hope that next time you pick an instant to have your computer hardware break it doesn't coincide with some of us experiencing the exact same symptoms from a kernel update at that exact same time...
At long last I have found the culprit. I have been waiting for a USB 3.0 front panel adaptor to arrive to put in the slot that my Floppy sits. I already have a Pcie USB powered adaptor fitted with a socket for extending the USB 3.0 slots to the front. I also had a USB 3.0 two port docking station connected to one of the USB 3.0 ports on the Pcie adapter.

I stripped the PC down and fitted the front ports and connected it to the pcie adaptor. I then thoroughly checked all the connections to the two internal drives, plus that the RAM sticks were properly seated. Then before I boxed up I then booted up and I rebooted and all was fine. I then shutdown via the OS and it shutdown perfectly; I assumed that it must have been attributed to one the things I checked on.

Then I boxed everything up, connected all the other stuff but when I booted up nothing was showing on the screen. I fiddled with the HDMI connector and then I unplugged the USB 3.0 lead from the docking station to the rear USB 3.0 port. Then everything became alive and it booted up. I shutdown again and same problem. So this time I pulled out the lead from the USB Dock St to the rear USB port. After another reboot I then shutdown and it closed instantly! I then connected the dock st to a standard USB (2.0) port and all was working fine.

So the issue is with this older machine I cannot have that docking station hooked up to the USB 3.0 port. Obviously being an older system it does not recognise USB 3.0 ports in DOS mode. It is fine when I am in Linux the ports are seen. On reflection I should have realised this earlier as when I had my keyboard plugged into a USB 3.0 port it was not recognised. Do not understand why though when a USB 3.0 accessory is connected to one of the USB ports it prevents the machine from shutting down properly. Just wonder if there is a workaround for this problem.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
rene
Level 16
Level 16
Posts: 6693
Joined: Sun Mar 27, 2016 6:58 pm

Re: PC does not fully shutdown from Linux

Post by rene »

Thanks for reporting back. Does your BIOS have the option to disable USB Legacy support, either universally or for USB3 specifically? If yes, does it change anything? Any other suspicious-looking USB (-power) related BIOS options?

If no go, I don't believe you ended up trying acpi=force as a kernel parameter, right? (i.e., through that /etc/default/grub edit that we detailed before). That would be a good try then after all...
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: PC does not fully shutdown from Linux

Post by muffybean »

rene wrote:
Tue Dec 31, 2019 11:14 am
Thanks for reporting back. Does your BIOS have the option to disable USB Legacy support, either universally or for USB3 specifically? If yes, does it change anything? Any other suspicious-looking USB (-power) related BIOS options?

If no go, I don't believe you ended up trying acpi=force as a kernel parameter, right? (i.e., through that /etc/default/grub edit that we detailed before). That would be a good try then after all...
Right Rene I disabled the USB legacy support but that did not do anything other than to disable the USB 3 Dock station, when I had the USB 3 dock plugged into a USB 3 port the system will not boot, not even into post until I pull the lead out. I even disabled the on system USB controller in the bios but that stopped everything, including my keyboard and mouse in the Distro. Reverted things back in the bios and all is working well. So will look at that kernel thing but that will be later.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
rene
Level 16
Level 16
Posts: 6693
Joined: Sun Mar 27, 2016 6:58 pm

Re: PC does not fully shutdown from Linux

Post by rene »

If you hadn't detailed that the dock works fine in a USB2 port... that would've sounded like a USB port-level short. And in that sense, don't you just have a flaky USB3 port? I believe from your description you don't have another USB3 port to try? Any other USB device in that USB3 port works?

Well, anyways, I'm going to be off for a bit. Happy festivities if any, happy non-festivities if none...
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: PC does not fully shutdown from Linux

Post by muffybean »

It is a new USB 3.0 pcie adaptor with 2 USB 3.0 ports I fitted in the machine just before Christmas, it works fine within the distro. I have the docking station plugged into it with a spare SATA 2.5" internal drive plugged into one of the SATA ports on the dock which I use to store Videos and other stuff on. I also do some backups to it.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
rene
Level 16
Level 16
Posts: 6693
Joined: Sun Mar 27, 2016 6:58 pm

Re: PC does not fully shutdown from Linux

Post by rene »

Alrighty then... until later.
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: PC does not fully shutdown from Linux

Post by muffybean »

Well I hope your festivities went well and to that end I wish a very happy New Year.

Right I have now done all my testing and it looks almost 100% that this old machine does not like a USB 3.0 appliance plugged into the USB 3.0 adaptors. I received a new WD Elements 1TB USB 3.0 external drive today for backups on my machines and other stuff like videos. First of all I plugged it into one of the USB 3.0 ports on the front of the machine in the Linux distro and it picked it up immediately. I then rebooted and all was fine there. I then shutdown the machine with the drive still plugged into the front USB 3.0 port and the same story, no complete shutdown and had to hold in the power button to shut it down properly.

Now I can use USB 3.0 ports to work in the distro but would have to unplug them to shutdown. One other thing is if I plug my Logitech wired keyboard into any of the USB 3.0 ports and switch on, the keyboard is not recognised and I could not get into the bios by pressing delete.

Unless you have any thoughts it does not look like I can have anything plugged into the USB 3.0 ports to start up or shutdown. They are fine in the standard USB 2.0 ports.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
rene
Level 16
Level 16
Posts: 6693
Joined: Sun Mar 27, 2016 6:58 pm

Re: PC does not fully shutdown from Linux

Post by rene »

Let's first try that acpi=force kernel parameter. I'm fairly sure the shutdown thing will be repairable, if need be through specifuc USB-power related shutdown scripts (the keyboard not being recognized in the USB3 ports by the BIOS will not be) but first need to know if acpi=force] does anything useful.
Post Reply

Return to “Other topics”