PC does not fully shutdown from Linux[SOLVED]

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: PC does not fully shutdown from Linux

Post by muffybean »

rene wrote:
Tue Dec 31, 2019 7:19 pm
Let's first try that acpi=force kernel parameter. I'm fairly sure the shutdown thing will be repairable, if need be through specifuc USB-power related shutdown scripts (the keyboard not being recognized in the USB3 ports by the BIOS will not be) but first need to know if acpi=force] does anything useful.
I was just posting this message when your response came in and deleted the message <LOL>. Did that above changing from NOACPI=Force to ACPI=Force and connected up the WD 1TB drive to USB 3.0 front USB 3.0 port and left the Docking station on the USB 2.0 port. Did all the usual reboot and when I did the shutdown in this config it shutdown fine. I then tried the Docking station hooked up to USB 3.0 and the shutdown problem returned. So reverted back to before and all was well again. Tested this a few times just to make sure and all was well. So it is a case of I do not plug the Docking station into USB 3.0 port but the WD External drive is fine.


It is no big deal not being able to use the Docking station in the USB 3.0 port as I only use it to plug in the internal SATA drive, plus it has a fast USB charging port that works fine, plus two other USB ports to use. Been a long journey but it has all sorted at the end. :roll:
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
rene
Level 16
Level 16
Posts: 6693
Joined: Sun Mar 27, 2016 6:58 pm

Re: PC does not fully shutdown from Linux

Post by rene »

Well, accessing the station's SATA drive over USB3 rather than USB2 would've probably been good... but if you're good, them I'm good :)
Post Reply

Return to “Other topics”