Running "Ruby on Rails" on Cassendra?

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 6
Joined: Sun Apr 15, 2007 11:33 pm

Running "Ruby on Rails" on Cassendra?

Postby dm_fw » Wed Jun 27, 2007 8:34 pm

I installed all of the packaged for "Ruby on Rails" on the Cassendra release of Mint. However, I can not get the gem to install the mySql driver. When I enter

sudo gem install mysql

I get the message:

Building native extensions. This could take a while...
extconf.rb:1:in `require': no such file to load -- mkmf (LoadError)
from extconf.rb:1

ERROR: While executing gem ... (RuntimeError)
ERROR: Failed to build gem native extension.
Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/mysql-2.7 for inspection.

I searched the net and tried various fixes for Ubuntu, but none appear to work for Mint. Anyone have an idea if I am missing something or will rails not work on this release?


Level 23
Level 23
Posts: 19590
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Thu Jun 28, 2007 5:53 am

What about this one: ... buntu-fix/

I must say this looks odd: "sudo gem install mysql"
Don't fix it if it ain't broken, don't break it if you can't fix it

Return to “Other topics”

Who is online

Users browsing this forum: No registered users and 2 guests