unable to mount an external drive

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Level 4
Level 4
Posts: 283
Joined: Sat Jun 09, 2007 9:18 pm

unable to mount an external drive

Postby twodogs » Tue Jul 03, 2007 2:48 pm

hi all,

thank you for your help as i am new to linux and Mint.

1)my problem: i have installed mint on my laptop and desktop. i have an external 300 gig drive that i store stuff on. i know it works because i had MS on my computers and i could use it then. well, now that i have mint installed, i get an icon on my desktop (external drive). i double click it and now i can see all my files on the external drive. i can drag files off and onto my desktop but and i can not put the files back onto my external drive. i can't copy/paste anything!

2)to try to fix this myself, i went to start>system>ntfs configuration tool and clicked on the box that says 'enable write support for external device' clicked ok and rebooted. now i don't see the icon on the desktop and i go to 'computer' and i can see the drive (external drive). but i can't open it now. a box pops up and says 'cant mount volume - unable to mount external device.'

i tried doing a search for external drive problems but not much found and what i did find was similar (an XP partition) but still did not fix my problem.

i have tried uplugging and plugging the drive back in, in hopes that it would mount but it doesn't.

i am trying to learn linux but this problem is stumping me and i feel it is very easy to fix just don't know how. can anyone help me?

Thanks, Dave.

Level 4
Level 4
Posts: 283
Joined: Sat Jun 09, 2007 9:18 pm

my /etc/fstab

Postby twodogs » Tue Jul 03, 2007 3:01 pm

# /etc/fstab: static file system information.
# -- This file has been automaticly generated by ntfs-config --
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/hda1 :
UUID=8b3bc4bf-d622-4a00-82c6-822be5896a0a / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/hda5 :
UUID=cddae7aa-207b-47a0-b152-16cd5d99a35e none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0

i have mint on one partition (/) and a swap file. i know, bad. but i will fix later with a root, home, and swap. i have a cd and dvd drive in the computer as well but i don't see an external drive. that means i should use mintDisk? right?

User avatar
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Postby Boo » Tue Jul 03, 2007 10:54 pm

mintdisk should have been mounting it before as read/write.

the ntfs config looks like it has tried to take over.

so un-check the ntfs config mount external... then ok

there is a /etc/fstab.pre-ntfs-config file, you could swap this for your fstab but i found no difference between the files.

you can now try plugging in your external drive, or reboot and then try.

Now where was i going? Oh yes, crazy!

Return to “Other topics”