(FIXED) Minor cursor issue after complete Update Pack 2

Archived topics about LMDE 1
Forum rules
thomasmc
Level 1
Level 1
Posts: 37
Joined: Tue Jan 19, 2010 5:43 pm

(FIXED) Minor cursor issue after complete Update Pack 2

Postby thomasmc » Mon Jul 25, 2011 12:40 pm

I'm set up to use the "latest" repo, and installed the Update Pack 2, in it's entirety, yesterday.

I'm happy to report that even though I let it update EVERYTHING, (I unpinned everything I had pinned), my proprietary ATI drivers still work fine, and I can now even boot to the latest kernel without problem, something I hadn't been able to do before.

But, I have noticed one small problem. Now, when I move my cursor to the bottom right corner area of the screen, it sticks for a second or two. It will come "unglued" if I wait, so it's not that big of a problem, just annoying.

Anyone have any ideas how to resolve this?
Last edited by thomasmc on Mon Aug 22, 2011 7:15 pm, edited 1 time in total.

bikrus
Level 1
Level 1
Posts: 25
Joined: Sat Jul 16, 2011 6:43 am

Re: Minor cursor issue after complete Update Pack 2 install

Postby bikrus » Wed Jul 27, 2011 3:01 am

In XFCE with nvidia (proprietary) there is no such issue.

thomasmc
Level 1
Level 1
Posts: 37
Joined: Tue Jan 19, 2010 5:43 pm

Re: Minor cursor issue after complete Update Pack 2 install

Postby thomasmc » Sun Aug 14, 2011 1:57 pm

According to the ATI forum, this is a bug in the 64 bit Catalyst driver, and still hasn't been fixed.

I did search around, and found a temporary workaround. It's not pretty, for me the cursor now flickers a lot, and disapears when it isn't moving, but at least it doesn't get stuck in the corner anymore.

edit (as root) /etc/X11/xorg.conf
add this line to the Device section:

Option "SWcursor"

This causes the cursor to be drawn by software, instead of hardware, which is the default.

Hopefully the next release of the Catalyst software will fix this.

thomasmc
Level 1
Level 1
Posts: 37
Joined: Tue Jan 19, 2010 5:43 pm

(FIXED) Minor cursor issue with ATI driver

Postby thomasmc » Mon Aug 22, 2011 7:14 pm

I just found there is a new version of the Catalyst driver on the ATI site. I downloaded it, and it fixes the "stuck cursor" problem.
You can find the driver @ http://support.amd.com/us/gpudownload/l ... ng=English


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 7 guests