Summary of my installation of LMDE 201204 x86-64

Archived topics about LMDE 1
Level 1
Level 1
Posts: 7
Joined: Thu May 03, 2012 5:00 am

Summary of my installation of LMDE 201204 x86-64

Post by kaji331 »

I am Chinese user, so forgive my English errors.

This is my first time to use LinuxMint Debian Edition.

I downloaded the LMDE-201204-mate-x86_64-DVD, written it into a USB stick by latest Universal USB installer in Windows 7. I entered the live-usb successfully without typing anything.

The first problem was how to install it into my hard driver. I clicked the icon of installer on the desktop. It gave me a information tip about authority and nothing happened. I searched the internet, finally I found the installation method. I had to hold Ctr+Alt+F1, went to tty1, typed root, then I could enter root account without typing password. I typed passwd root, gave a password to root account. Then I held Ctr+Alt+F7, went back to tty7 (the desktop), clicked the menu, found the terminal, typed su, typed the root password, typed /usr/bin/live-installer. OK, I started the installer, and completed the installation.

When I started my system, I like and use Cinnamon. I found 5 serious problems.

I. about root accout.

Remember: Do not give a password to root account. You can use the default root terminal, sudo or gksudo. Do not use su or gksu, because root have no password. If you gave a password to root, it will cause many problems even if you delete root password after a while. I encountered this problem and I had to reinstall the whole system. I wish LMDE developers can solve the problem, let us use root as Ubuntu.

II. Chinese input method:fcitx

fcitx is a very popular Chinses input method. I installed the 4.x version from synaptic. But it is not enough stable like Ubuntu in cinnamon. I installed it successfully first time. But when I reinstall the system, the fcitx had a problem making it useless. It could start with system, but it couldn't work when I typed Ctrl+space. I purged it and install another input method ibus, then I purged ibus and reinstall fcitx. fcitx worked well again.

III. Hybrid graphic card (double graphic card)

Many notebooks have double graphic card now, intel+amd or intel+nvidia. I have intel+nvidia notebook, so I tested it. Now, intel+nvidia notebook can't use nvidia card with nouveau driver, but notebook powers two of them, even only intel card works. We need turn off nvidia card for saving battery. Intel card is enough for routine jobs.

There are three methods by Bumblebee Project ( ... PM-methods). ACPI_call is old, sophisticated and not enough stable. The easiest method is vgaswitcheroo, even it doesn't support suspend and hibernate. It needs kernel with compiled vgaswitcheroo module. But I found LMDE's kernel without vgaswitcheroo. I wish the developers focus this problem, even it may be debian's problem.

The instead method is bbswitch. I need download it from

make load
sudo make -f Makefile.dkms
sudo update-initramfs -u
sudo /sbin/rmmod nouveau
sudo modprobe bbswitch unload_state=0 load_state=1
sudo tee /proc/acpi/bbswitch <<<OFF

You can write the last 3 lines without sudo, and add a line "sleep 30" before them to /etc/rc.local before lines exit 0. This makes bbswitch work with system start.

IV. about notebook screen brightness

My notebook ASUS U36JC can remember brightness in Ubuntu 10.04. But it can't remember brightness in Ubuntu 12.04 and LMDE. I had to write the line below to /etc/rc.local before line exit 0.

echo x > /sys/class/backlight/acpi_video1/brightness

x is a number between 1~10. You can type this in a terminal, and find a suitable brightness number for you notebook. Then you write it for system boot.

V. about Cinnamon font

I wanna install some fonts for my system beauty. My LMDE's locale is zh_CN and LMDE's default font is ubuntu font. This is an English font, when the system need to show Chinese, it will use default Chinese font wenquanyi. But when I copied some Chinese fonts to ~/.fonts, the system used them right now, even I didn't change the default font Ubuntu in Cinnamon settings. I had to change font setting to default Chinese font wenquanyi by cinnamon settings, the gtk parts were correct, but cinnamon menu (left bottom of the desktop) was still the font in ~/.fonts. I don't know how to change it, so I have to delete all fonts in ~/.fonts.

I wish somebody tell me how to control my fonts, thanks.

These above are my summary about LMDE installation and using. I hope it useful for some new user and some advance user can share their experiences to me.

Level 1
Level 1
Posts: 7
Joined: Thu May 03, 2012 5:00 am

Re: Summary of my installation of LMDE 201204 x86-64

Post by kaji331 »

no one relies ?

Level 5
Level 5
Posts: 607
Joined: Sun Mar 16, 2008 5:28 am

Re: Summary of my installation of LMDE 201204 x86-64

Post by breaker »

Thanks for this. I needed to do sudo tasks from a Live USB iso boot but sudo was asking for a password (linuxmint-201204-xfce-dvd-64bit.iso) So I did what you did, pretty much;

pressed CTRL+ALT+F1 (then I saw and typed as shown below)

Code: Select all

Linux Mint Xfce Edition mint tty1
mint login: mint
mint@mint~$ su
mint mint # passwd
Enter new UNIX password: 
Retype new UNIX password: 
passwd: password updated successfully
pressed CTRL+D twice to log out of those, then pressed CTRL+ALT+F7 to get back to XFCE
Then I used su in the terminal emulator within XFCE for my needs. Sudo never worked.
rtfm - read the fine manual...
Boot info script:
PC-BIOS based booting, mbr, boot records;

Level 1
Level 1
Posts: 21
Joined: Tue Aug 09, 2011 3:29 am

Re: Summary of my installation of LMDE 201204 x86-64

Post by andy_0 »

The installer does not work for me either. Based on this thread ( you should create the USB device with Unetbootin. I will give that a try.


Return to “LMDE 1 Archive”