Dual boot error: invalid EFI file path

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 1
Joined: Thu Aug 16, 2012 8:48 am

Dual boot error: invalid EFI file path

Postby mintify » Thu Aug 16, 2012 8:52 am

Hello everybody!

I am sorry if this question has been answered before, I couldn't find a thread addressing this with the Advanced search.

I successfully installed LMDE Maya in an Asus UX32VD, after several tries. Windows 7 comes installed in sda2, while the efi partition is in sda1. I originally tried having /boot and / in a separate drive, sdb, and the bootloader also in sdb, but from inside Windows (usung EasyBCD) I could not for the love of me get the boot table to point to Mint.

I finally resolved this by installing grub in sda. But now the oppite is true. I can boot Mint, but even when Grub shows an item for Windows 7, when choosing it I get the message:

Code: Select all

error: invalid EFI file path

and I can't boot Windows.

Has anyone run into something similar?

Code: Select all

$ sudo parted /dev/sda print
Model: ATA Hitachi HTS54505 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End    Size    File system  Name                  Flags
 1      1049kB  211MB  210MB   fat32        EFI system partition  boot
 3      345MB   100GB  100GB   ntfs         Basic data partition
 2      100GB   101GB  512MB   ext2
 4      101GB   421GB  320GB   ext4
 6      421GB   473GB  52.4GB  fat32
 5      473GB   500GB  26.8GB  ntfs         Basic data partition  hidden, diag

Code: Select all

$sudo parted /dev/sdb print
Model: ATA SanDisk SSD i100 (scsi)
Disk /dev/sdb: 24.0GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system  Name  Flags
 1      17.4kB  2000MB  2000MB
 2      2000MB  24.0GB  22.0GB  ext4

Code: Select all

$ cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sdb2 during installation
UUID=7e1ba36c-168f-4b6c-b472-8fb94e85c6e0 /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda2 during installation
UUID=969a177c-28dd-4839-91b0-33f74503fcf1 /boot           ext2    defaults        0       2
# /boot/efi was on /dev/sda1 during installation
UUID=D80F-7408  /boot/efi       vfat    defaults        0       1
# /home was on /dev/sda4 during installation
UUID=bdf0fec5-99fa-49fc-9180-07c657a7492b /home           ext4    defaults        0       2
# swap was on /dev/sdb1 during installation
#UUID=16e49fb8-5df4-4b36-8582-91cb98f110f3 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

Level 1
Level 1
Posts: 22
Joined: Thu Mar 18, 2010 6:41 am

Re: Dual boot error: invalid EFI file path

Postby carpenter » Wed Aug 22, 2012 12:08 pm


I've just installed linuxmint 13 maya with mate, and have lost windows 7, it is listed in grub's list of entries but I'm getting the "invalid EFI file path" error, when I click on it...

Have you worked it out yet? I'm totally stuck, have only tried update-grub so far but this looks expensive to me :(

Any help out there?

I have now got a bit closer though to fixing my problem which may help you also (viewtopic.php?f=90&t=110829).

Return to “Archive”

Who is online

Users browsing this forum: No registered users and 4 guests